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Chapter 1. What’s New In Nways Manager-ATM

The following provides information on what’s new in Nways® Manager-ATM.

Version 2.0 of Nways Manager-ATM

The following gives an overview of the new or enhanced functions provided in Nways
Manager-ATM Version 2.0, and new devices that are supported.

v New support of:

– 8265 Nways ATM switches

– 8271 Nways Ethernet LAN switches (models, 524, 612, 624, and 712)

– 8371 Multilayer Ethernet Switch

– MSS Client

v Enhancements to LAN Emulation

– Ability to display VLANs for stations that are connected to:

- The 8270 Nways LAN Switch legacy LAN ports

- Any ATM campus port, provided that the station supports ATM Forum
Compliant LAN emulation.

– Discovery of the VLANs over:

- 8270 Nways LAN switches

- 8271 Nways Ethernet LAN switches (models, 108, 212, 216, and 412)

- 8272 Token Ring LAN switches

- 8281 ATM LAN bridges

- 8371 Multilayer Ethernet Switch

– Maintenance of discovered PVLANs

– Display of VLANs including the associated VLAN devices, virtual domains, ports
and stations

– Discovery of legacy LAN ports.

– Navigation from VLAN views to ELAN views and to FaultBuster.

– Broadcast Manager

The Broadcast Manager is a protocol filter on top of the standard LAN emulation
BUS mechanism, that allows you to specify that broadcast frames are sent only to
stations belonging to the same protocol.

v Extended support of PNNI topology

Version 2 Release 2 of Nways Manager-ATMC, provided first-level support of PNNI.
Nways Manager-ATM Version 2.0 provides extended support of PNNI. This is
provided by the PNNI MIB in the Control Point Version 4.0 in the 8265 Nways ATM
Switch.

The PNNI enhancements provide the network operator with topology debugging
information. For example, the operator can:
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– Check the topology for each PNNI device of a peer group against the actual ATM
topology of the peer group.

– Display, for a given PNNI device, the spanning tree inside the peer group.

v Enhanced Logical link management

The ATM interface logical link support has been enhanced so that you can now
manage all the logical links available on an interface. This allows you to configure
any logical links (including the ones defined on WAN interfaces).

v New FaultBuster diagnosis application that allows you to diagnose the reasons for
changes in status of resources, and to diagnose connectivity problems through a
single graphical interface.

v New Locate function that allows you to locate specific network devices managed by
Nways Manager-ATM.

v Ability to migrate changes made to labels in a previous release

v Support of the service category for Control Point Version 3.0
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Chapter 2. About Nways Manager-ATM Documentation

The documentation for IBM Nways Element Manager is designed to help you
understand the network management features of the product, and to describes how to
use it.

Prerequisite Knowledge

To understand the information presented in the online books, you should be familiar
with the concepts and terms used to describe monitoring networks, changing hardware
and software configurations, and resetting hardware modules.

You should also be familiar with:

v AIX® system administration

v AIXwindows® Environment/6000

v TCP/IP - SNMP environment

v NetView® for AIX or HP OpenView Windows

v ATM protocols and environment

v LAN emulation

v Use of Web browsers.

In addition you should be familiar with the devices supported by Nways Manager-ATM.
These are:

v 2210 Nways Multiprotcol Routers

v 2216 Nways MultiAccessNet Model 400s

v 8210 Nways Multiprotocol Switch Services Servers, and Nways Multiprotocol Switch
Services Server modules in 8260 Nways Multiprotocol Switching Hubs and 8265
Nways ATM Switches

v 8260 Nways Multiprotocol Switching Hubs

v 8265 Nways ATM Switches

v 8270 Nways LAN Switches

v 8271 Nways Ethernet LAN Switches

v 8272 Token-Ring Switches

v 8281 ATM LAN Bridges

v 8282 Workgroup Concentrators

v 8285 Nways ATM Workgroup Switches

v 8371 Multilayer Ethernet Switches

Highlighting Conventions

The following highlighting conventions are used in the online documentation with the
noted exceptions:
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Bold Menu choices, pushbuttons, commands, path names, default values,
user selections, and flags (in parameter lists).

For example: Enter the new value in this field and click on the OK
pushbutton.

Italics Parameters whose actual names or values are to be supplied by the
user, terms that are defined in the following text, and document titles.

For example, Cells are short, fixed-length packets of 53 bytes (48
bytes for the information field and 5 bytes for the header).

Monospace Messages in text, examples of portions of program code, examples of
text you might see displayed, information you should actually type,
and examples used as teaching aids.

For example, Type the command startsrc -t'tftp'

Naming Conventions

The following sections describe the naming conventions used throughout this online
documentation.

Note: Throughout the online books:

v IBM Nways Element Manager is shortened to Nways Element Manager.

v The term NetView for AIX or HP OpenView Windows is used to mean IBM
NetView for AIX V4.1 (5697-NVW) available under the TME 10® Management
Server V4R4 (CD-ROM SK2T-6032).

v The term ATM Hub is used to refer to an 8260 Nways Multiprotocol Switching
Hub.

v The term 8265 ATM Switch is used to refer to the 8265 Nways ATM Switch.

v The term ATM Workgroup Switch is used to refer to an 8285 Nways ATM
Workgroup Switch.

v The term ATM switch is used to mean the ATM Control Point and Switch
Module in an 8260 Nways Multiprotocol Switching Hub or 8265 Nways ATM
Switch, the integrated ATM switch in an ATM Workgroup Switch, or any other
ATM switch.

v The term ATM concentrator is used to refer to the 8282 Workgroup
Concentrator or any other ATM concentrator.

v The term ATM bridge is used to refer to an Nways 8260 ATM Tr/Ethernet LAN
Bridge Module, an 8281 ATM LAN Bridge, or any other ATM bridge.

v The term MSS server is used to refer to a stand-alone 8210 Nways
Multiprotocol Switch Services Server or an Nways Multiprotocol Switch
Services Server module located in an ATM Hub or an 8265 ATM Switch.

v The term ATM device is used to mean an ATM switch, an ATM bridge, an ATM
concentrator, an MSS server, or any other ATM device.
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v The term control point is used to mean the ATM Control Point Version 4.0,
located in the ATM Control Point and Switch Module in an ATM Hub or 8265
ATM Switch, or the integrated Control Point Switch in an 8285 Nways ATM
Workgroup Switch.
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Chapter 3. Overview of Nways Manager-ATM

The following provides information on ATM Campus Networks and LAN emulation.

ATM Campus Network

The purpose of an ATM Campus Network is to set up connections between ATM user
devices, the two end points of a connection. ATM subsystems can be interconnected in
order to build a local, privately owned and administered ATM campus network. Figure 1
shows the components of a typical Campus Network.

Network Components

The terms used to describe the components of an ATM Campus Network are defined
here:

Figure 1. Components of an ATM Campus Network
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ATM Campus Network
One or more ATM Clusters, ATM Peer Groups, or a mixture of both.

ATM Peer Group
One or more IBM or non-IBM ATM devices interconnected by PNNI interfaces,
and sharing the same peer group identifier. This peer group is controlled by
one administrative domain and a single private owner using one network
access protocol (UNI).

ATM Cluster
One or more IBM or non-IBM ATM devices not supporting the PNNI protocol
that share the same ATM network prefix subset (first 12 bytes in the ATM
address).

ATM User Device
An end system that encapsulates data into ATM cells and forwards them to the
ATM subsystem across a UNI interface. Examples of ATM user devices are:

v Servers and workstations equipped with ATM adapters

v ATM concentrators or workstations equipped with ATM adapters

v Routers with ATM adapters

v LAN ATM bridges.

The ATM control point passes the network prefix of an ATM address to
attached end systems using the Interim Local Management Interface (ILMI)
protocol.

Network Interfaces

The following protocols are defined in ATM standards for use across the interfaces used
connecting the components of an ATM campus network:

UNI Defines the interface between an ATM User Device (such as a
terminal, router, bridge, server, workstation, or concentrator equipped
with an ATM adapter) and the ATM network. The ATM subsystem
supports the private UNI defined by the ATM Forum UNI Specification
V3.1.

IISP Defines the interface between two ATM switches belonging to different
ATM routing domains. IISP is used to interconnect PNNI peer groups.

Operator intervention is required in order to define the addresses
reachable over IISP links.

You can define multiple IISP connections between two ATM switches.

PNNI Defines the interface between two ATM switches in the same routing
domain.

The PNNI interface supports networking functions without the need of
operator intervention, such as routing, node failure and node recovery,
backup, and topology management.

You can define multiple PNNI connections between two ATM
switches.
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Public UNI Interface to public network signaling is not supported.

VP tunnels can be defined on such a port, and signaling can be
supported through the VP.

VOID Interface is undefined at the physical level. A VP link (UNI, PNNI,
IISP) can be defined on such a port.

PNNI Network

PNNI is a network system for supporting ATM routing and path selection. It is structured
as a hierarchy of successive higher entities called levels. The ATM control point maps
these levels into nodes. For example, when a switch control point is running three
levels, the bottom level is executed in the PNNI’s node_0 subsystem, the next level is
running in the node_1 subsystem, and so on.

A default configuration is established the first time that a PNNI A-CPSW module is
powered on.

Level IDs and Peer Group IDs

The level ID is the length, in bits, of the peer group ID. The default value is 96 bits,
which can be changed from 0 to 104. It is important to realize that if you change the
level ID in one switch, you will also have to change it in all other switches of that same
peer group since all switches within a peer group must have the same peer group ID
(both length and content must be the same).

If you reconfigure the address then you not only reconfigure the address, but also the
peer group ID.

Explicitly setting the level ID forces the peer group ID to take on a default value.

Normally, if an attempt is made to set a parameter value to the same value already set,
PNNI will reject the command with an explanation for the refusal. One exception is the
level ID when the peer group ID is non-default set. This is because when the peer
group ID takes on a non-default value, then that value is changed by modifying the
level identifier even when the level ID is identical to the already configured one.

Summary Addresses

In PNNI, reachability is the advertising of end-system addresses throughout a peer
group for the purpose of setting up connections between end systems. Reachability in
PNNI routing is simplified by the capability of having groups of addresses with a
common prefix to be represented by that prefix. Such a prefix is called a summary
address. PNNI generates a default summary address to provide reachability to all end
systems attached to the switch whose addresses share the switch’s 13–byte ATM
address prefix, that is, whose addresses are generated by the ILMI address notification
protocol. Additional non-default summary addresses can be configured to provide
reachability for address groups that do not share their switch’s 13–byte ATM address
prefix.
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PNNI also supports path selection to end-systems that lie outside a peer group, that is,
end systems that are connected to a peer group via non-PNNI links (typically IISP
links).

PNNI also supports suppressed summary addresses.

Note: PNNI does not allow you to configure a suppressed summary address if the
same address prefix has already been configured as a summary address, or vice
versa. For example, if you configured a given summary address as exterior, then
PNNI will reject any attempts to configure the same address prefix as a
suppressed exterior summary address.

The total number of configurable summary addresses, which includes all four types
(internal, external, suppressed internal, and suppressed external), is limited to 30.

Every switch Control Point feeds end-system addresses (that do not share the switch’s
13–byte address prefix) to its PNNI subsystem which represents them by corresponding
summary addresses if these are already configured. The absence of a configured
summary address does not impair the reachability of end system addresses that would
otherwise be represented by that summary address: it simply increases the reachability
overhead for these addresses. Consequently, the removal of a configured summary
address does not impair the reachability of end systems that were previously
represented by the summary address: it simply increases PNNI’s reachability overhead.

Configuring a new summary address can affect the functioning of previously configured
summary addresses.

PNNI Routing

IBM’s PNNI Path Selection supports Available Bit Rate (ABR) in two ways,
precomputed and on-demand:

v Paths are precomputed and a specific route is obtained via table look-ups, resulting
in fast connection setup.

v Paths are computed on-demand, resulting in slower connection setups, but with more
optimization for the individual routes.

The default configured setting is for paths to be precomputed, and can be changed to
on-demand.

IBM’s PNNI Path Selection also supports Unspecified Bit Rate (UBR) two ways,
shortest path and longest path:

v The widest path approach finds the least-loaded path in terms of bandwidth
regardless of the number of hops required to reach the destination. This approach
balances the load on the paths through a network in the absence of critical
constraints within that network.

v The shortest path approach follows a two-step algorithm. In step one, paths with
minimal hop count to the destination are selected. In the second step, the widest
path approach is applied to the previously selected group of shortest paths to select
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the final route. This approach is favored when the network contains critical restraints
such as links (VCIs, VPIs) and/or switches that tend to become traffic bottlenecks.
The drawback of the shortest path approach is its reduced load-balancing capability.

The default configured setting is the widest path approach, and this can be changed to
shortest path.

ATM Management

ATM management is based on the following management interfaces:

v The M2-type management interface, as defined by the ATM Forum (ATM Forum
Management Interface Reference Architecture). This is the interface between Nways
Manager-ATM and the ATM devices.

v The Interim Local Management Interface (ILMI) as defined by the ATM Forum (ATM
UNI) and is the local protocol used between adjacent ATM devices for link
management and address registration.

SNMP is the management protocol used across each of these interfaces:

v SNMP over UDP/IP on the M2 interface

v SNMP over AAL5 on the ILMI and SSI interfaces

ATM resources that can be managed include:

v Physical resources:

– The ATM interfaces.

Interfaces are identified by an SNMP variable (the ifIndex from MIB-II). The
interface can also be identified directly by its slot and port number (IBM ATM
switches only).

– ATM modules (in IBM ATM switches only).

– ATM devices

v Logical resources:

– Virtual links. They are associated with a physical interface and are identified by a
VPI value (VPL) or a VPI and VCI value (VCL).

– Virtual connections. They may be PVCs or SVCs:

- A PVC is associated with a physical interface. It is identified by a PVC number.
In the case of a point-to-multipoint PVC, each PVC party is further identified by
its party number.

- An SVC is associated with a physical interface. It is identified by a call
reference and a logical link (VPI and VCI of the signaling channel used to
establish this SVC). In the case of a point-to-multipoint SVC, each SVC
end-point is further identified by its end-point number.

- As PVCs and SVCs are built using virtual links, they can also be identified by
the VPI value (for PVP) or the VPI and VCI values (PVC or SVC) and the
interface number of the primary end-point of the connection (where the PVC or
SVC was created).
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LAN Emulation

LAN Emulation is a network connectionless service that allows end systems to connect
to an ATM network as if it were attached to a traditional LAN.

LAN Emulation Network

Traditional LANs can be emulated over ATM by using LAN emulation. A traditional LAN
consists of:

v LAN segments, such as token-ring and Ethernet segments.

v A broadcast domain that corresponds to a group of LAN segments interconnected
through LAN bridges or switches. Broadcast domains are interconnected through
LAN routers.

An emulated LAN (ELAN) is the equivalent of a LAN segment over ATM. The
interconnection is achieved between:

v An ELAN and traditional LANs through ATM/LAN bridges and ATM/LAN switches.
The interconnected ELAN and LAN segments form a broadcast domain.

v Broadcast domains (isolated ELANs or ELANs connected to traditional LANs through
bridges and switches) through ATM routers.

An ELAN consists of:

v ATM end-points (ATM workstations) supporting LAN emulation.

v ATM edge-devices (for example, ATM/LAN bridges or ATM/LAN switches) supporting
LAN emulation.

v ATM routers supporting LAN emulation. An ATM router can be viewed as an ATM
end-point from a LAN emulation standpoint, because it behaves as a firewall
between broadcast domains. However, it is an edge-device because it acts as an
intermediate system between two end-points.

Figure 2 on page 15 shows an example of the physical and logical views of a simple
LAN Emulation Network.
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LAN Emulation Entities

LAN emulation is implemented through LAN emulation entities that use or provide LAN
emulation services. Several instances of a given entity can exist. These entities are:

v Servers of the following type:

– LAN Emulation Server (LES), which controls an ELAN. Any given LES instance
can control only one ELAN, or a part of an ELAN.

– Broadcast and Unknown Server (BUS), which handles unknown and
broadcast-related traffic for an ELAN. Any given BUS instance can handle only
one ELAN, or a part of an ELAN.

– LAN Emulation Configuration Server (LECS), which, when present, is in charge of
the configuration of ELANs. Any given LECS instance is responsible for a given
group of ELANs.

v Clients of the following type:

Figure 2. Simple LAN Emulation Network
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– LAN Emulation Client (LEC), which is in charge of making an ATM end-point
participate with a given ELAN. Any given LEC instance can be associated only
with one ELAN.

– Proxy LAN Emulation Client (proxy LEC), which is in charge of making traditional
LAN stations participate with a given ELAN. It is required in ATM/LAN bridges or
switches. Any given proxy LEC can be associated only with one ELAN.

An ATM device can implement any number of instances, but usually:

v Only one device implements an LECS entity, except for backup purposes. There is a
single LECS instance, except when administrative network partitioning is required.

v One or several devices implement LES and BUS entities.

– The LES and BUS entities are co-resident.

– There is a single LES instance for a given ELAN, except for load-distribution or
backup purposes. In this case, these instances are defined in separate LES
entities in separate ATM devices.

– There is a single BUS instance for a given ELAN, except for load-distribution or
backup purposes. In this case, these instances are defined in separate BUS
entities in separate ATM devices.

v Edge-devices, such as ATM/LAN bridges or switches, implement one or several
proxy LEC instances.

v Routers and native ATM LAN Emulation workstations implement one or several LEC
instances.

Addressing in ATM

ATM uses 20-byte hierarchical addressing.

The first 13 bytes of an ATM address are the network prefix. Each ATM switch in your
network must have a unique network prefix. ATM switches use this network prefix to
route VCC setup requests to the destination ATM switch. End systems, like the MSS
server, retrieve their network prefix from the ATM switch.

Bytes 14 through 19 of an ATM address are the end-system identifier (ESI), Each end
system attached to the same ATM switch must use a disjoint set of ESIs. When an end
system activates, it attempts to register its ESI with its ATM switch using the Integrated
Local Management Interface (ILMI).

ILMI defines a set of SNMP-based procedures used to manage the interface between
an end system and an ATM switch. End systems use ILMI to:

Figure 3. Composition of an ATM Address
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v Obtain the network prefix from the ATM switch

v Register the ESIs with the ATM switch

v Dynamically determine the UNI version of the ATM switch

v Allow LECs to get a list of LECS addresses from the ATM switch.

The ATM switch forces all of its registered ESIs to be unique.

Byte 20 of an ATM address is the selector.

End systems obtain their network prefix from the ATM switch and form their own
address by appending an ESI and selector. The selector is significant only within the
end system; it is not used to route calls within the ATM switch network, but is used
within end systems to uniquely identify the called and calling party.

The network prefix and ESI components of ATM addresses must be registered with
ATM switchs before calls can be placed or received. Each ATM address must be
unique, that is, it must not be a duplicate of an address already registered with the ATM
switch. If the address is not unique, the ATM switch will reject the registration.

One way to obtain a unique ATM address is to use the burned-in IEEE MAC address as
the ESI. Network devices are given a burned-in address (or universally administered)
MAC address when manufactured. The MAC address is guaranteed to be unique
among all burned-in MAC addresses.

Each ATM interface on an MSS server contains a burned-in MAC address that can be
used as an ESI. The MSS server also allows you to configure locally-administered ESIs
on each ATM interface.

ATM Addresses of LAN Emulation Components

Generally, ATM addresses must be unique among LAN emulation components.
However, a LES and BUS serving the same ELAN can share an ATM address, as is the
case with a Multiprotocol Switch Services Server (MSS server). Each ATM interface on
the Multiprotocol Switch Services Server contains a burned-in MAC address that can be
used as an end-system interface (ESI). The MSS server also allows you to configure
locally-administered ESIs on each ATM interface.

LAN emulation components are configured for a particular ATM interface. You can
decide to use the burned-in MAC address (provided for the device when manufactured)
as the ESI portion of the ATM address of the component or you can select one by the
locally-administered ESIs that have been defined for the ATM interface. Multiple LAN
emulation components can share the same ESI if they have the unique selectors. By
default, the configuration interface assigns to each LAN emulation component a unique
selector value for the configured ESI. You can override this assignment and explicitly
configure a particular selector value.

An ATM interface parameter determines the number of selectors per ESI reserved for
explicit assignment. The remainder are available for dynamic assignment by the ATM
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interface at run-time. LAN emulation components use only the selectors reserved for
explicit assignment. By default, 200 of the 256 possible selectors for each ESI are
reserved for explicit assignment. Run-time selector assignment is beneficial when you
do not need to control the assigned selector, for example, when you are configuring
clients in Classical IP that are not paired with an ARP server.

While ATM addresses must be unique among LAN emulation components, LAN
emulation components can use the same ATM addresses as non-LAN emulation
components, such as Classical IP servers.

Overview of Related Integrated Local Management Interface

The Integrated Local Management Interface (ILMI) defines a set of SNMP-based
procedures used to manage the user-network interface (UNI) between an ATM end
system and an ATM switch. The following ILMI functions are relevant to LAN emulation:

v Registration of ATM addresses (see “Addressing in ATM” on page 16).

v Dynamic determination of the signaling version being run in the ATM switch.

v Acquisition of the LECS ATM addresses.

As mentioned in “Addressing in ATM” on page 16, registration of ATM addresses is
achieved jointly between ATM end systems and ATM switches. ATM addresses must be
registered with the ATM switch before calls can be placed or received.

By default, the ATM interfaces of an MSS server use IMLI procedures to query the ATM
switch MIB in an attempt to determine the signaling version (UNI 3.0 or 3.1) being run
in the ATM switch. If the query succeeds, the ATM interface runs the same UNI version
as the ATM switch. If the query fails, the ATM interface runs UNI 3.0. You can override
the default and explicitly configure the UNI version that will run on the ATM interface.

Manually Configuring the Signaling Version

You will need to configure the signaling version manually if the ATM switch runs UNI 3.1
and has no UNI Version MIB variable. In this case, the ATM interface cannot
dynamically determine the UNI version. Because the ATM interface in the MSS server
uses UNI 3.0 by default, configure the ATM interface to use UNI 3.1.

Locating the LAN Emulation Configuration Server Using ILMI

ILMI is the chosen method for locating the LECS. The ILMI MIB in the ATM switch
includes a list of LECS ATM addresses that can be retrieved by LAN emulation clients
(LECs). This method is useful because the LECS ATM addresses need only be
configured in the ATM switches, not in the LECs, and there are fewer LECs than ATM
switches. LECs attempt to connect to the first LECS on the list. If the connection fails,
they try the next LECS address in succession until a connection is established.
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Function of LAN Emulation Configuration Servers

It is not necessary for LECs to use LAN Emulation Configuration Servers (LECSs), but
it is recommended. If a LECS is not used, each LAN emulation component must be
configured with the ATM address of the LES serving the emulated LAN (ELAN). Using
LECSs reduces network management by serving as a centralized repository for
configuration data, minimizing the configuration of the LECs.

Note: Only one LECS can be configured on each MSS server.

LECs connect to the LECS using well-defined procedures. The following steps are
attempted by a LEC, in order, until a virtual channel connection (VCC) to the LECS is
established.

v Connect to the LECS using any configured LECS address information (configuration
of an LECS ATM address at LECs is optional and is not recommended).

v Obtain a list of LECS addresses using ILMI and attempt to connect to each on the
list, in order, until a VCC is established.

v Establish a VCC to the well-known ATM address defined by the ATM forum.

As previously stated, ILMI is the preferred method for LECs to locate the LECS. The
well-known LECS address is required because not all ATM switches support the ILMI
method. Configuring the LECS address at the LECs should be done only when the ILMI
method is not supported by the ATM switch and the well-known LECS address is not
supported by the LAN emulation service.

The MSS server and 8260 Nways Multiprotocol Switching Hub support all three
methods (the preconfigured LECS address, ILMI connection, and the well-known ATM
address).

The LECS must provide initial configuration data to the LECs, the most important of
which is the ATM address of the LAN emulation server. To provide this information to a
LEC, the LECS must be able to identify the LEC and to determine the proper LES for
that LEC. The LECS identifies a LEC using information in the configuration request
frame dent by the LEC. The configuration request can also contain the following
information to identify the ELAN that the LEC is trying to join:

Primary ATM address of the LEC
This is required and uniquely identifies the LEC.

LAN destination associated with the LEC
This field can contain a MAC address or a route descriptor that uniquely
identifies the LEC, or it can be unspecified.

ELAN Name
This field can specify a name identifying the requested ELAN or the requesting
LEC. In an MSS server implementation, ELAN names are standard ASCII
strings. The ELAN name can be unspecified in the request.

ELAN Type
This field can specify that the LEC belongs to an Ethernet or token-ring ELAN,
or it can be unspecified.
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Maximum frame size supported by the LEC
This field can specify the upper bound on the size of a data frame that can be
processed by the LEC, or it can be unspecified. The LECS cannot assign a
LEC to an ELAN with a maximum frame size larger than that specified by the
LEC. If the ELAN allows frames too large for the LEC to handle, the LEC
cannot function on that ELAN.

Given this information, the LECS assigns the LEC to a LES. This is achieved using
policies and policy values. A policy is a criterion the LECS uses to make LEC-to-LES
assignment decisions. A policy value is a (value, LES) pair that indicates that the
specified value is to be assigned to the specified LES. For example, a policy could be
the MAC address of the LEC, and a policy value could be MAC ADDR_A, LES_1
meaning that a LEC with MAC ADDR_A will be assigned to LES_1 if the LEC has not
already been assigned to another LES because of a higher-priority policy. One set of
policies and policy values applies to all ELANs.

In accordance with the LAN Emulation service MIB Specification of the ATM Forum, the
following policies are defined:

v ATM address

v MAC address

v Route descriptor

v ELAN type

v Maximum frame size

v ELAN name

Policies also have priorities. The LECS examines policies in order of priority. Policies
with smaller values in the priority field are considered before those with larger values in
the priority field. Policies with equal values in the priority field are considered
simultaneously.

The LECS assigns a LEC to a LES when all of the policies at the current priority level
are satisfied and in agreement. The policies are satisfied when there is a policy value
that matches the corresponding field in the configuration request for each policy at the
current level. The policies are in agreement when the set of matches include a LES that
is common to all the policies. If these conditions are not met, the LECS considers the
policies at the next priority level. If the LECS is unable to find a LES at any priority
level, an unsuccessful configuration response is returned to the LEC.

The following provides an example of policies not in agreement. Suppose that the
policies at priority one are a MAC address and an ELAN name and one of the policy
values is X'400000121225', LES_A and the other is ELAN 1, LES_B. If the LEC
provides a MAC address of X'400000121225', the MAC address policy is satisfied. If
the LEC provides an ELAN name of ELAN 1, then the ELAN name policy is also
satisfied. In this case, the priorities at priority one are not in agreement because they
refer to different LESs. In this example, the LECS would examine the policies at the
next priority level.
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After determining the correct LES for a LEC, the LECS returns a configuration response
to the LEC that includes the following information:

v LES ATM address

v ELAN type

v Maximum frame size

v ELAN name.

The configuration response can also include type, length, and value (TLV) parameters.
TLV parameters provide a method of downloading optional or user-defined parameters
to the LEC.

Examples of the Use of LECS Assignment Policies

The following provides examples of LECS assignment policies.

ATM Address Policy

The MSS server LECS allows two types of ATM address policy values. The first type is
a variable-length ATM address prefix. For example, the policy value
(3999999999999900000102), LES_A implies that all LECs whose ATM address begins
with 3999999999999900000102 is to be assigned to LES_A.

The second type of ATM address policy is an ESI and selector of an ATM address. For
example, the policy value (10002345003281, LES_A) implies that the LEC with an ESI
of 100023450032 and selector of 81 is to be assigned to LES_A.

When given the ATM address of a LEC, the LECS searches firstly for a matching ESI
and selector. If no match is returned, the LECS searches for the ATM address prefix
policy value with the longest matching prefix. For example, the previously mentioned
policy value (399999999999990000, LES_B).

ATM address ESI and selector policy values can be used to assign LECs to LESs in a
manner independent of the physical location of the LEC (the ESI and selector is defined
locally to the LEC). ATM address prefixes are the only policy values that indicate any
geographic information.

LAN Destination Policy

LECs can be assigned to LESs based on upon a MAC address or a route descriptor.
Because a LAN destination uniquely identifies a LEC in a manner independent of
geographic location, this policy is useful in ensuring that the LEC is assigned to the
proper ELAN regardless of its physical location, for example, retaining the ELAN
memberships of a workstation when it is moved from one switch to another.

ELAN Name Policy

ELAN names are probably the most flexible of the assignment criteria. Here are some
ways of using ELAN name policy values:
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v Use the actual name of the ELAN

I LES_A serves ELAN 1, then create the policy value (ELAN 1, LES_A). LECs
specifying ELAN 1 in configuration requests will then be assigned to LES_A.

v Use aliases for the ELAN

For example, all LECs belonging to members of the Accounting Department could be
configured to use the ELAN name Accounting, while those belonging to the
Engineering Department could be configured to use the ELAN name Engineering.
Depending on the number of LECs on the ELANs, these names could be directed to
the same ELAN, for example, by configuring policy values:

(Accounting, LES_A)
(Engineering, LES_A)

or to different ELANs, for example, by configuring policy values:

(Accounting, LES_A)
(Engineering, LES_B)

This setup requires configuring the LECs with the correct ELAN name.

v Use names for the LECs

Each LEC can be given its own name, for example, the policy values (Joe, LES_A)
and (Mary, LES_A) could be created. The LECs configured with these names would
then be directed to the same LES. This method requires configuring the ELAN name
at each LEC and at the LECS. However, it allows Joe and Mary to move the LEC to
a new location. Even though moving causes the LEC to have a new ATM or MAC
address, as long as you configure the new LEC with the same ELAN name, you
retain the membership in the original ELAN. This technique also offers a moderate
amount of security if the names of each LEC are considered to be passwords.

v ELAN Type Policy

ELAN type policy values are most useful for providing default ELANs. For example,
the following policy values would ensure that every LEC is assigned to one of the
LESs:

(Token-ring ELAN type, LES_A)
(Ethernet ELAN type, LES_B)
(Unspecified ELAN type, LES_C)

Generally, policies used for providing default ELAN assignments should be given a
low priority, so that the more specific policies are considered first.

v Max Frame Size Policy

The maximum frame size policy can also be used to provide default ELAN
assignments.

Duplicate Policy Values

Duplicates occur when the same policy value is associated with multiple LESs for a
given policy. Duplicate policy values are allowed for the ELAN type and maximum frame
size policies, but are not allowed for other policies. Duplicate values are useful only
when combined with a different policy of the same priority.
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For example, assume that there are three ELANs:

v An Ethernet ELAN with a maximum frame size of 4544 bytes.

v A token-ring ELAN with a maximum. frame size of 4544 bytes.

v A token-ring ELAN with a maximum frame size of 18 190 bytes.

LECs could be assigned to the appropriate ELAN by setting the ELAN type and
maximum frame size policies to the same priority level and defining the following policy
values:

(Ethernet ELAN type, LES_1) (Max Frame Size = 4544, LES_1)
(Token-ring ELAN type, LES_2) (Max Frame Size = 4544, LES_2)
(Token-ring ELAN type, LES_2) (Max Frame Size = 18910, LES_1)

Type, Length, and Value (TLV) Parameters

The type, length, and value parameters, collectively termed TLVs, are defined on an
ELAN basis, which means the same set of TLVs is returned to all LECs that are
assigned to a particular ELAN. When a TLV is included in a configuration response, the
LEC must use the value specified in the TLV as an operating parameter if the LEC
recognizes the ELAN type. Examples of when TLVs might be beneficial are:

v When ELANs are spread over large geographical locations, the default timeout
values for LECs may be sufficient. These timeouts can be controlled for all LECs by
specifying their value in a TLV at the LECS.

v By default, ELANs use best effort connections to connect to the BUS. For ELANs
where BUS traffic is heavy, improved performance can be obtained by using reserved
bandwidth connections to the BUS. The characteristics of Multicast Send VCC
between the LEC and the BUS can be controlled with TLVs.

v A TLV can be used to download the ELAN segment number to source route bridges.

In addition to fine-tuning the configuration, TLVs force all clients on all ELANs to
operate with consistent parameters. The MSS server supports all ATM Forum-defined
TLVs along with arbitrary, user-defined TLVs.

Connecting to the LAN Emulation Server

After obtaining the ATM address of the LES, the LEC initiates a Control Direct VCC to
the LES. When this VCC has been established, the LEC sends a join request to the
LES. The LES responds by adding the appropriate point-to-multipoint Control Distribute
VCC and returns a join response. By default, the LES partitions proxy and non-proxy
clients onto separate Control Distribute VCCs as shown in Figure 4 on page 24.
However, you can configure the LES to use a single Control Distribute VCC for all LECs
to reduce the number of point-to-multipoint VCCs required. Partitioning the VCCs is
useful because it reduces the amount of nuisance traffic sent to non-proxy clients. No
ARP requests are sent to non-proxy clients. See “Addressing in ATM” on page 16.
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Control Direct VCC (bi-directional point-to-point)
From LEC to LES

Control Distribute VCC (point-to-multipoint)
From LES to LEC.

Address Registration

LECs register LAN destinations with the LES to ensure uniqueness and to allow the
LES to answer LE_ARP_REQUESTS, which LECs issue to learn the ATM address
associated with a particular LAN destination. Registrations include the LAN destination
and the ATM address that the LEC associates with the LAN destination. The LAN
destination can be either a MAC address, or a route descriptor.

Proxy LECs do not register the MAC address of stations on LAN segments that they
are bridging to the ELAN. Non-proxy LECs must, however, register all the LAN
destinations they represent. All route descriptors must be registered, regardless of
whether they are associated with a proxy or non-proxy LEC. Route descriptors are
applicable only to proxy LECs that are performing route bridging. A route descriptor
contains the bridge number of the proxy LEC and the segment number of a ring that
the LEC is bridging to, that is equivalent to one hop away.

Address Resolution

LAN communications are based upon source and destination MAC addresses. To
enable such communication on an ATM network, MAC addresses must be resolved to
ATM addresses. A LEC sends an LE_ARP_REQUEST to the LES to learn the ATM

Figure 4. Default Connections between LECs and the LES
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addresses of a particular LAN destination. If the LAN destination is registered, the LES
responds with the ATM address associated with the LAN destination. Otherwise, the
request is forwarded to all proxy LECs on the Control Distribute VCC. There is no need
to forward the request to non-proxy LECs because all of their LAN destinations are
registered. However, if the LES is configured to use a single Control Distribute VCC,
both proxy LECs and non-proxy LECs will receive the request. Control Distribute VCCs
provide an efficient way for the LES to distribute control frames to multiple LECs.

Proxy LECs respond to the LE_ARP_REQUESTs for unregistered MAC addresses they
represent. The LE_ARP_RESPONSE is sent to the LES on the Control Direct VCC,
and the LES forwards the response to the LEC that issued the request.

Connecting to the Broadcast and Unknown Server

After connecting to the LES, a LEC issues an LE_ARP_REQUEST for all the 1s
broadcast MAC address. The LES responds with the ATM address of the BUS The LEC
then initiates the establishment of Multicast Send VCC to the BUS, which responds by
adding the LEC to the appropriate point-to-point Multicast Forward VCC. By default, the
BUS partitions proxy and non-proxy LECs onto separate Multicast Forward VCCs.
However, as is the case with the Control Distribute VCC, the BUS can be configured to
use a single Multicast Forward VCC for all LECs.

Multicast Send VCC (bi-directional point-to-point)
From LEC to BUS

Multicast Forward VCC (point-to-multipoint)
From BUS to LEC.

Figure 5. Default Connections between LECs and the BUS
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Broadcast and Unknown Server Function

The basic function of a Broadcast and Unknown Server (BUS) is to:

v Distribute multicast frames to all LAN Emulation Clients (LECs) in the ELAN.

v Forward unicast frames to the appropriate destinations.

A LEC sends unicast frames to the BUS if it does not have a direct connection to the
LEC representing the destination. To avoid bottlenecks at the BUS, the rate at which a
LEC can send unicast frames to the BUS is limited. In the MSS server, the BUS has
two modes of operation:

v Partitioning the unicast frame domain.

v Not partitioning the unicast frame domain.

If you partition the unicast frame domain, the BUS uses two Multicast Forward VCCs.
Otherwise, the BUS uses a single Multicast Forward VCC.

If a single Multicast Forward VCC is used, all received frames are forwarded to all
LECs. If two multicast Forward VCCs are used, the BUS does not broadcast unicast
frames to all LECs. In this case, unicast frames destined for non-proxy LECs are
transmitted directly to the destination LEC on a Multicast Send VCC, and all other
unicast frames are transmitted only to proxy LECs using the Proxy Multicast Forward
VCC. When two multicast VCCs are used, the MSS server is considered to be in
intelligent BUS (IBUS) mode.

IBUS mode reduces nuisance unicast frames. These are unicast frames not destined
for the client; proxy clients do not receive unicast frames destined for non-proxy clients,
and non-proxy clients never receive nuisance unicast frames. In addition, network
bandwidth devoted to nuisance frames is reduced. However, BUS processing
requirements are increased and multicast frames must be transmitted twice (one on
each Multicast Forward VCC). Generally, IBUS operation is recommended, but this
option must be disabled in configurations that have source route bridges that join the
ELAN as non-proxies.

LAN Emulation Reliability

To increase LAN emulation reliability, each LES/BUS on an MSS server can be
independently configured for redundancy (the default is no redundancy). If redundancy
is enabled, the LES/BUS is configured to assume the role of the primary or backup
LES/BUS. Unless the LES/BUS has been configured as a redundant LES/BUS, it is the
primary LES/BUS and is the only LES/BUS visible to LECs. This LES/BUS is
responsible for setting up and maintaining a Redundancy VCC to the backup LES/BUS.
The presence of this VCC indicates that the primary LES/BUS is operational. The
backup LES/BUS does not accept Control Direct VCC calls while the Redundancy VCC
is established. However, if the Redundancy VCC is not present, the backup LES/BUS
services ELAN requests in the usual manner.
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For the redundancy protocol to be effective, LECs must detect the failure of the primary
LES/BUS and connect to the backup LES/BUS. LECS detects server failures using
released VCCs. Connection to the backup LES/BUS is achieved through the LECS.

When an LE_CONFIGURE_REQUEST is received, the LECS assigns the LEC to the
appropriate LES and ELAN. If the LES/BUS has no configured backup, then the LECS
returns the ATM address of the LES/BUS. If the LES is configured with a backup
LES/BUS, then the LECS can return the primary or backup LES/BUS ATM address.
The backup LES ATM address is returned if:

v The backup LES/BUS exists on the same MSS server as the LECS and is currently
serving the ELAN

v The primary LES/BUS exists on the same MSS server as the LECS and it is not
currently serving the ELAN

v Neither LES/BUS exists on the same MSS server as the LECS and the LEC was last
assigned to the primary LES/BUS within the last 5 minutes.

Otherwise, the primary LES/BUS ATM address is returned to the LEC.

The LECS retains a short-term memory of all LEC assignments so that it can alternately
direct a LEC to a primary and backup LES/BUS. This simple heuristic makes the
correct assignment in the nominal case of no failure and is self-correcting. At worst, the
heuristic causes the LEC to repeat the configuration phase of joining an ELAN.

LECS robustness can be achieved by establishing duplicate LECSs on multiple
platforms and including their ATM addresses in the ILMI database. LECs will then
connect to the backup LES/BUS if the primary LES/BUS is not available. For example,
LECS1 and the backup LES/BUS in Figure 6 on page 28. could be on MSS server 1,
while LECS2 and the primary LES/BUS could be on MSS server 2. Note that MSS
servers need not be dedicated to backup functions, because a single MSS server can
host backup LES/BUSs for some ELANs and primary LES/BUSs for other ELANs.
Configuration changes made to the primary LECS using the Nways ATM Manager is
automatically updated for the redundant LECS.
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LAN Emulation Security

Traditional LANs offers security in the sense that a physical connection implies that two
stations are on the same LAN. Because multiple emulated LANs can exist on a single
ATM network, stations that are not on the ELAN can be physically connected to stations
that are on the ELAN. This situation presents a security risk, because unauthorized
stations can connect to the LES and attempt to use its services.

To control ELAN membership, an MSS LES can be configured to validate
LE_JOIN_REQUESTs with the LECS. In this mode the LES forms an
LE_CONFIGURE_REQUEST on behalf of of the LEC using information from the
LE_JOIN_REQUEST. These LE_CONFIGURE_REQUESTs include the source LAN
destination, Source ATM address, ELAN type, maximum frame size, and ELAN name
from the LE_JOIN_REQUEST, along with the IBM security TLV. The security requests
are transmitted to the LECS by a multiplexing component called the LECS interface,
and the LECS must validate the request using its ELAN assignment database before
LECs are allowed to join the ELAN.

The LECS interface is associated with an ATM interface, and all LESs configured on the
ATM interface use the same LECS interface. The LECS interface conserves VCC
resources by multiplexing security requests from multiple LESs onto a single VCC to
the LECS. The LECS interface locates the LECS dynamically using the ILMI and
well-known LECS address mechanisms. After the VCC to the LECS is established, the
LECS interface issues a local query to determine whether the LECS is located on the
same MSS server. If it is, a local interface is used to confirm requests to join without
transmitting requests onto the ATM network.

To maximize the security of an ELAN, the following steps are recommended:

Figure 6. LAN Emulation Redundancy
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1. At the LECS, use ATM addresses to assign LECs to the LES. For further
information, see “Function of LAN Emulation Configuration Servers” on page 19.

2. Activate the LECS interface at the MSS server.

3. Activate the security option of the LESs.

4. Use address screening at the ATM switches. This option causes switches to validate
that calling stations use their actual ATM addresses in the call setup so that stations
cannot impersonate other stations.

These steps ensure that stations are correctly identified and that only authorized
stations join the ELAN.

Broadcast Manager

Broadcast Manager (BCM) is an extension to LAN emulation that consists of an
enhancement of the LAN emulation BUS. Without this enhancement:

v Multicast frames sent to the BUS are sent to all LECs on the ELAN.

v LECs that include the proxy function to provide bridging support, forward the
broadcast frames onto other LAN segments.

v All end stations receive and process every broadcast frame.

BCM can be enabled on individual ELANs for the IP, IPX, and NetBIOS protocols.
When BCM is enabled, a minimal amount of layer 2 and layer 3 information is decoded
for specific types of broadcast frames sent to the BUS. Whenever possible, BCM
transforms broadcast frames into unicast frames and sends them only to interested
LECs and end stations.

BCM reduces both network traffic and associated end-station overhead by filtering
nuisance broadcast frames. These functions can improve overall system performance
and enable practical deployment of larger ELANs.

LAN Emulation Administration

An administrative domain (domain for short) is a group of ELANs, including servers and
clients, administered by a given LECS. An unadministered domain is a group of ELANs
that is not administered by any LECS.

When several LECSs are in charge of administering the same domain (for backup or
load-distribution purposes), all of them must have exactly the same configuration.

When administrative partitioning of the network is desired, it is possible to create more
than one LECS instance. In this case, each instance is responsible for its own domain
(group of ELANs). No overlap is possible between any two domains. A domain is
administered through a policing profile, which is an ordered set of policing rules at the
same or different levels of priorities.

A policy is the list of the different values defined for a given policing rule.
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The policing profile and the policing rules define the criteria used within a domain to
assign a client to a given ELAN and associated LES. The client is assigned to the
ELAN and its LES when it passes the policies defined for the ELAN/LES, based on the
policing rules of the domain. For example, a domain might have a policing profile
consisting of a first priority policing rule by ATM address and a second priority policing
rule by ELAN name. Each ELAN/LES pair defined in the domain has a policy containing
a list of ATM addresses and a policy containing a list of ELAN names.
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Chapter 4. The Components of Nways Manager-ATM

IBM Nways Manager-ATM (abbreviated as Nways Manager-ATM) consists of ATM
Manager, LAN Emulation Manager, and FaultBuster. IBM Nways Manager-ATM is a
graphical user-interface tool for managing, monitoring, and diagnosing faults with ATM
resources and LAN emulation components in:

v ATM switches

v ATM bridges

v ATM concentrators

v MSS servers

v Non-IBM and IBM ATM devices supporting the PNNI protocol

Access is gained to Nways Manager-ATM from a workstation or from one or more
remote terminals attached to a host workstation for example, a dataless AIX station.

The Nways Manager-ATM Environment

The environment for Nways Manager-ATM consists of:

v An IBM RS/6000® POWERserver® workstation or HP-UX PA Risc-Based system.

v ObjectStore

v NetView for AIX or HP OpenView Windows.

For software and hardware requirements, refer to our Web site at:

http://www.networking.ibm.com/netmgt

Nways Manager-ATM allows remote management of devices via network connection
(inband).

Nways Manager-ATM can be coupled with IBM Nways Element Manager to provide
comprehensive IBM box management solution.
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Overview of ATM Manager

ATM Manager facilitates the management of ATM networks within an enterprise, namely
on a site or a campus and allows you to manage your ATM environments from a single
operator console on a NetView for AIX or HP OpenView Windows workstation. When
coupled with the IBM Nways Element Manager, Nways Manager-ATM offers a fully
integrated solution for IBM box management.

ATM Network Topology

Nways Manager-ATM provides the following topological support:

v Automatic discovery of ATM devices and physical links between elements.

Figure 7. Nways Manager-ATM in Nways Manager for AIX
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ATM devices are automatically discovered, placed in a submap, and monitored.
When the network changes, the discovery capability indicates the changes and
updates the network map.

v Dynamic display of the topology hierarchy of ATM nodes and interfaces on the
following:

– ATM Campus submap

– ATM Device submap

– ATM Meta-connection submap

– ATM View panel

– PNNI Peer Group panel

The graphical topology displays uses color coding to represent the status of resources.

If a resource becomes inactive or its operation becomes impaired, the information is
updated to reflect the change in status for the resource by changing the color of the
resource in the topology display. However, if the connection is lost with an ATM node,
the status is not updated, that is, the status color remains the same as when the
connection with the ATM node was lost.

ATM Resource Configuration

The following resources can be configured and monitored:

v ATM physical resources.

v Permanent virtual circuit (PVC) management, including creation and deletion (IBM
devices only).

v Switched virtual circuit (SVC) management, including tracking and forced clearing
(IBM devices only).

v Virtual path (VP) and virtual channel (VC) link management.

Context menus provide access to functions applicable to objects displayed in the
topology submaps and to online context-sensitive help information.

Fault Management

System reliability is increased through cooperative management with NetView for AIX or
HP OpenView Windows. Nways Manager-ATM can operate interactively with NetView
for AIX or HP OpenView Windows, allowing for recognition of network management
information from different sources, including:

v Display of traps

v Color coding of status information

v Logging of call failures.
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ATM Change Management

Nways Manager-ATM provides a quick way to download code upgrades in the switch
module through the network (inband) and allows easy problem fixes or function
migration on the switch module that hosts the ATM control program.

ATM Network Monitoring and Statistics

Key performance counters can be selected and their variations tracked over time. This
data can be saved in a file and displayed in various graphical forms. The availability of
performance information enhances the ATM network by facilitating network tuning.

Connection Tracking

Connections can be selected and tracked. The end-points and all the intermediate
nodes used by a connection can be graphically displayed.

Overview of LAN Emulation Manager

LAN Emulation Manager facilitates the management of LAN emulation components
within the network and provides dynamic display of the topology hierarchy of LAN
emulation components on the LAN Emulation Manager panels.

LAN Emulation Resource Configuration

The following resources can be configured and monitored:

v LAN emulation domains

v Emulated LANs (ELANs)

v LAN Emulation Configuration Servers (LECSs)

v LAN Emulation Servers (LESs)

v Broadcast and Unknown Servers (BUSs).

Context menus provide access to functions applicable to objects displayed on the
end-user interface panels to online context-sensitive help information.

A toolbar, provided on several panels, has pushbuttons with icons representing their
function. Functions which are not active are greyed out. Moving the mouse cursor to the
pushbutton shows its function.

Fault Management

Fault management is provided for the detection, analysis, and correction of problems
caused by the failure of the following LAN emulation components:

v LECSs

v LESs

v BUSs.
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Overview of FaultBuster

FaultBuster is a diagnostic application that provides you with status and connectivity
problems analysis within a single interface. The problems that are investigated are
represented in their context with all their related resources.

FaultBuster displays the reasons for the status of a selected resource with an
associated set of investigation actions. FaultBuster provides many shortcuts including a
way to return to a previous investigation context. FaultBuster can be called from various
places. When no ATM device is selected, the FaultBuster Selction panel is opened.
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Chapter 5. The ATM Manager and LAN Emulation Manager End-user
Interfaces

The ATM Manager, LAN Emulation Manager, and FaultBuster components of Nways
Manager-ATM are graphical applications, each with a set of panels and pull-down
menus based on X Window and OSF/Motif, which is compatible with NetView for AIX
V4 and NetView for AIX V5.

The end user interface shows an expanded graphical view of the ATM network with
different level views that can be displayed. Color coding is used to show the status of
the ATM devices, interfaces, connections, and LAN emulation components.

Accessing Functions

Not all functions are available for each object, type of module, or LAN emulation
component. When a function is not available, the option is grayed out in the menu and
cannot be selected.

Object Status

The following table gives you the colors used to show the status of objects.

Status Color

Critical Red

Marginal Yellow

Normal Green

Unmanaged Brown

Unknown Blue

Disabled Transparent Gray

Power Off Dark Gray

Notes:

1. Resources with a status of unknown or unmanaged do not affect aggregation.

2. If connection is lost with an ATM device, the status of the interface is not updated,
that is, the status color remains the same as when connection with the interface
was lost and the status of the ATM device changes to critical (red).

3. The LAN emulation topology status is provided by the LAN Emulation Manager. The
color of the VLANs icon is red if any LAN emulation resource is in a critical state. If
you use the acknowledge function of NetView for AIX or HP OpenView Windows,
the status of the VLANs icon will be set back to red at the next poll if a resource is
in a critical state.
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Object Representation

Objects are represented in ATM Manager and LAN Emulation Manager by icons. The
icons used are displayed on Legend panels that are displayed when you select Help ->
Legend from the menu bar of the corresponding end-user interface panels of the ATM
Manager or LAN Emulation Manager.

An object in ATM Manager may appear in different submaps. For example, an ATM
device appears in the IP Segment submap, the ATM Device submap, and on the ATM
View panel.

The NetView for AIX or HP OpenView Windows protocol switching function can be used
to navigate between different submaps that contain the same object.

The ATM Manager and LAN Emulation Manager components of the Nways
Manager-ATM application are started from icons in the NetView for AIX or HP
OpenView Windows Root submap (see “NetView for AIX Root Submap” on page 41).
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Chapter 6. Navigation within Nways Manager-ATM

The following describes the navigation within the ATM Manager, LAN Emulation
Manager, and FaultBuster components of Nways Manager-ATM

ATM Manager

The ATM Campus icon, which is displayed in the NetView for AIX Root submap and the
CMA menu, is available from the menu bar.

NetView for AIX Root Submap

The NetView for AIX Root submap is the access point when using ATM Manager.
Figure 8 shows an example of the NetView for AIX Root submap.

From the Root submap, you can:

v Manage and Unmanage the ATM Campus network.

You can use the standard NetView for AIX functions selected from the Options menu
to manage and unmanage the ATM Campus:

– Manage the ATM Campus

When the ATM Campus is managed each ATM device of the ATM Campus will be
polled each "polling interval" minutes. The symbol for the managed object reports
the status change by changing to the color that represents the status.

Note: You must have the Root submap open with read-write access.

Select Options -> Manage Objects in the Root submap when the ATM Campus
icon is selected. The selected ATM Campus becomes blue (unknown) until the
next poll when it shows its actual status.

– Unmanage the ATM Campus

Figure 8. NetView for AIX Root Submap
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An unmanaged ATM Campus is managed by ATM Manager, meaning that all the
ATM devices in this Campus will no longer be polled by ATMC, NetView for AIX or
HP OpenView Windows. The icon for the ATM Campus does not report the status
because it is not known. However, the icon is still visible.

Note: You must have the Root submap open with read-write access.

Select Options -> Unmanage Objects in the Root submap when the ATM
Campus icon is selected. The selected Campus becomes brown (unmanaged). If
an ATM Campus is discovered as unmanaged, all its ATM devices are polled at
least once but the ATM Campus stays in the unmanaged state.

v Double-click the ATM Campus icon to display the ATM Campus submap (see “ATM
Campus Submap”).

v Double-click on the VLANs icon to access the LAN Emulation Manager. (see “LAN
Emulation Manager” on page 52).

ATM Campus Submap

The ATM Campus submap is displayed by double-clicking the left mouse button on the
ATM Campus icon in the NetView for AIX Root submap. The ATM Campus submap
(see in Figure 9) shows all ATM Clusters (IBM and non-IBM ATM devices not supporting
the PNNI protocol), Peer Groups (IBM and non-IBM ATM devices supporting the PNNI
protocol), and a Default group that contains edge devices that have been discovered
but are not yet associated with an ATM switch.

An ATM Cluster contains all the devices that share the same ATM network prefix subset
(first 12 bytes in the ATM address).

A Peer Group contains all devices that share the same peer group identifier.

Note: If the submap is not in auto-layout mode, the ATM Clusters and Peer Groups
initially appear in the New Object Holding Area at the bottom of the display.

Figure 9. ATM Campus Submap
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Press annd hold the Ctrl + left mouse button Use to drag each icon into the
main display area. If more ATM Clusters or Peer Groups are discovered than
can be shown in the New Object Holding Area at the same time, you will not see
all the ATM Cluster or Peer Group icons until you have moved a sufficient
number of icons into the main display area.

You can perform the following actions:

v Manage ATM Clusters or Peer Groups

When an ATM Cluster or Peer Group is managed it can be exploded. The symbol for
the managed object reports the status change by changing to the color that
represents the compound status of the ATM devices.

Note: You must have the ATM Campus submap open with read-write access.

Select Options -> Manage Objects in the ATM Campus submap when one or more
ATM Clusters or Peer Groups are selected. The color of the selected ATM Clusters
or Peer Groups changes to blue (unknown) until the next poll when they show their
actual status.

v Unmanage ATM Clusters and Peer Groups

An unmanaged ATM Cluster or Peer Group is not managed by ATM Manager,
meaning that all the ATM devices belonging to this ATM Cluster or Peer Group will
no longer be polled by NetView for AIX or HP OpenView Windows. The icon for the
object does not report the status because it is not known. However, the icon is still
visible.

Note: You must have the ATM Campus submap open with read-write access.

Select Options -> Unmanage Objects in the ATM Campus submap when one or
more clusters are selected. The color of the selected ATM Cluster or Peer Groups
changes to brown (unmanaged).

v Explode an ATM Cluster or Peer Group to display the ATM device-level view of the
ATM Cluster or Peer Group.

v Perform a PNNI validation check for a peer group.

v Change the label of an ATM Cluster or Peer Group. See “Changing the Labels of
ATM Devices” on page 51.

v Change and save the position of an ATM Cluster or Peer Group. See “Changing and
Saving the Position of Icons” on page 52.

ATM Device Submap

The ATM Device submap is displayed by double-clicking the left mouse button on the
ATM Cluster or Peer Group icon in the ATM Campus submap. The ATM Device submap
displays the ATM device-level view and contains:

v Icons representing the ATM devices.
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Note: The number shown in the label under the ATM device icon is found in the HN
field of the ATM address of the ATM device.

v Icons representing the ATM connections or meta-connections between ATM devices.

When several connections exist between two ATM devices, they are grouped
together in a meta-connection object and only one connection is shown between the
two ATM devices in the ATM Device submap.

Note: The term connection is used here to name an object that connects two other
objects in NetView for AIX or HP OpenView Windows databases, as defined in
NetView for AIX or HP OpenView Windows terminology. This should not be
confused with the same term used in a purely ATM context, such as a virtual
ATM connection. The term used here represents a physical link, and a logical
link (shown as dashes) between two ATM devices.

Note: If the submap is not in auto-layout mode, the ATM device icons initially appear in
the New Object Holding Area at the bottom of the display. Press and hold the
Ctrl + the middle mouse button to drag each icon into the main display area. If
more ATM devices are discovered than can be shown in the New Object Holding
Area at the same time, you will not see all the icons until you have moved a
sufficient number of icons into the main display area.

Figure 10. ATM Device Submap for an ATM Cluster
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From this submap you can:

v Manage ATM devices

When an ATM device is managed the ATM device will be polled each "polling
interval" seconds. The symbol for the managed object reports the status change by
changing to the color that represents the status.

Note: You must have the ATM Device submap open with read-write access.

Select Options -> Manage Objects in the ATM Device submap (ATM device-level
view) when one or more ATM devices are selected. The selected ATM device(s)
become blue (unknown) until the next poll when they show their actual status.

v Unmanage ATM devices

An unmanaged ATM device is not managed by ATM Manager, meaning that this ATM
device will no longer be polled. The icon for the object does not report the status
because it is not known. However, the icon is still visible.

Note: You must have the ATM Device submap open with read-write access.

Select Options -> Unmanage Objects in the ATM Device submap when one or
more ATM devices are selected. The selected ATM device(s) become brown
(unmanaged).

If an ATM device is discovered as unmanaged, it is polled at least once but stays in
the unmanaged state.

v Select an ATM device icon (single-click the left mouse button) and choose one of the
items in the CMA menu at the top of the submap or from the context menu that is
displayed when you click the right mouse button on the selected ATM device icon.
Options that are not available are grayed out.

v Double-click on the ATM device to display an exploded view of the ATM device on
the ATM View panel.

v Double-click on the meta-connection to display the ATM Meta-Connection submap.

v Change the label of an ATM device. See “Changing the Labels of ATM Devices” on
page 51.

v Change and save the position of an ATM device. See “Changing and Saving the
Position of Icons” on page 52.

v Delete broken links from the submap. See “Deleting Broken Links” on page 52.

The icons and objects used in the ATM Device submap, and other views, are shown in
“Object Representation” on page 40.

ATM View

The ATM View can be displayed by doing one of the following:

v Double-clicking the left mouse button on an ATM device icon in the ATM Device
submap.
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Note: If you double-click on the icon of an ATM switch that contains a Control Point
with the Distributed Management Module (DMM) subset, the ATM View panel
may not open. In this case, use the following means of displaying the panel.

v Selecting the ATM device and choosing CMA -> Open ATM View from the menu bar
or from the context menu that is displayed when you click the right mouse button on
the ATM device.

The ATM View panel is displayed with icons representing the logical and physical ATM
ports of the ATM device.

The numbers shown under each ATM interface icon are in the form interface index.
Figure 11 shows a sample ATM View panel.

Three different views can be selected: row/column, star, or tabular list. To display the
view, choose Row/Column , Star , or Tabular from View on the menu bar.

When new interfaces are discovered, for example, when a new ATM Module is added
to an ATM switch, the devices are not shown in the display in an ordered manner.

On the ATM View panel, you can perform the following actions displayed when you click
the right mouse button on the selected ATM interface icon. Options that are not
available are grayed out.

v Highlight user, backbone, or all connections.

v Sort the display by, interface index, connection type, or remote ATM device type.
Select that the display is not sorted.

Figure 11. ATM View Panel
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v Select an interface icon (single-click the left mouse button) and choose one of the
items in the CMA menu

v Double-click on the ATM device icon in the ATM device status window to display the
configuration of the ATM device.

v If the ATM device contains LAN emulation components, double-click on the LAN
emulation icon to display the configuration of those components.

PNNI Topology Validation Panel

The PNNI Topology Validation panel displays the PNNI topology view of your ATM
switches supporting the PNNI protocol.

The PNNI Topology Validaation panel is displayed when you select a peer group icon in
the ATM Campus submap and choose PNNI Topology Validation from the context
menu that is displayed when you click the right mouse button on the peer group icon.
Figure 12 shows a sample PNNI Topology Validation panel.

When the PNNI Topology Validation panel is opened, a sanity check is automatically
started. This checks the view of the PNNI topology in relation to the ATM topology. If a
mismatch is detected, the IP address of the PNNI device is highlighted red.

PNNI Node View

If a PNNI device has a bad sanity check, that is, the PNNI topology view is different to
the ATM topology view of the PNNI devices, you can display the PNNI topology as seen
in the database.

The PNNI Node View is displayed by selecting the PNNI device and choosing PNNI
Node View from the context menu that is displayed when you click the right mouse
button on the selected PNNI device.

Figure 12. PNNI Topology Validation Panel
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A sample PNNI Node View is shown in Figure 13.

PNNI Spanning Tree View

Each PNNI device builds its own reachability spanning tree, which represents all the
routes to other PNNI devices that the local PNNI device knows. The local PNNI device
is at the root of the spanning tree. The spanning tree can be used, for example, to
debug ATM call failures with reason:

v No route to destination.

v Insufficient resources.

The PNNI Spanning Tree view is opened from the PNNI Topology Validation panel by
selecting a service category from the Service Category menu, clicking the left mouse
button on the PNNI device, and choosing PNNI Spanning Tree View from the context
menu that is displayed when you click the right mouse button on the PNNI device.

The PNNI Spanning Tree View shows the bandwidth available from the root PNNI
device to the destination PNNI devices. Figure 14 shows a sample Spanning Tree View.

Figure 13. PNNI Node View
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ATM Connection Submap

The ATM Meta-Connection submap is displayed by double-clicking the left mouse
button on a meta-connection in the ATM Device submap. The ATM Meta-Connection
submap contains:

v For each physical link between two ATM devices, the same pair of icons representing
these ATM devices.

v Icons representing ATM interfaces between these two ATM devices.

Figure 14. PNNI Spanning Tree
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IP Map Segment Submap

The IP Map Segment submap is opened by:

1. Double-clicking the left mouse button on the IP Internet icon in the Root submap
which displays the IP Internet Submap.

2. Double-clicking the left mouse button on the IP icon in the IP Internet Submap
which displays the IP Map Submap.

3. Double-clicking the left mouse button on a segment icon in the IP Map Submap
which displays the icons representing the ATM devices in the IP Segment submap.

Note: Selecting an ATM device icon in the IP Segment submap and choosing CMA ->
Open ATM View from the menu bar, or from the context menu that is displayed
when you click the right mouse button on the ATM device icon, displays the ATM
View panel for that ATM device.

Figure 16 on page 51 shows an example of the IP Map Segment submaps.

Figure 15. ATM Meta-Connection Submap
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Changing the Labels of ATM Devices

Each ATM device displayed on the ATM Manager submaps has a label, for example, an
ATM switch may have the IP address 9.100.42.66. This label can be changed to suit
your own requirements. For example, you may want to change the label of this ATM
switch to indicate its location, such as Peer Group 1. To do this:

1. Select the ATM device in the ATM Device submap, and choose CMA -> Change
Label from the menu bar or from the context menu that is displayed when you click
the right mouse button on the ATM device.

2. Enter the new label in the Label field and click on the Apply pushbutton.

A sample Change Label panel is shown in Figure 17 on page 52

Figure 16. IP Map Segment Submap
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Changing the Default Node Label for ATM Devices

The label for ATM devices shown in the ATM Manager submaps when Nways
Manager-ATM starts is IP Address. This can be changed to the ATM ESI if required.

To change the default node label do the following:

1. Select Administer -> Campus Manager SMIT from the menu bar.

2. Select Configure from the SMIT main menu.

3. Select Campus Manager - ATM Configuration .

4. Select Set the default node label format .

5. Set the value in the Default node label format field to ATM ESI and click on the
OK pushbutton.

6. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Changing and Saving the Position of Icons

You can change and save the position of icons on the ATM Campus submap and ATM
Device submap. The position of icons can be saved only when a background picture is
displayed.

To change the position do the following:

1. Press and hold Ctrl + the middle mouse button on the icon to drag the icon to the
required position.

2. To save its position, select View -> Nways -> Save Symbols Positions from the
menu bar.

Deleting Broken Links

If a link between two devices is broken, the status of the link changes to red. You can
delete this link by selecting the link and choosing CMA -> Delete Connection from the
context menu that is displayed when you click the right mouse button on the link.

LAN Emulation Manager

The VLANs icon is displayed in the NetView for AIX Root submap. See Figure 8 on
page 41

Figure 17. Change Label Panel
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VLAN Domain View

To use LAN Emulation Manager, double-click the left mouse button on the VLANs icon
in the NetView for AIX Root submap. This displays the VLAN Domain View shown in
Figure 18, which shows all existing domains, and a tree structure showing all VLAN
devices. On this panel, you can:

v You can create new domains and delete existing domains. However, default domain
unadmin always exists and cannot be deleted.

v Double-click on a domain to display an exploded view of the domain.

v If a plus sign is shown next to the ELAN or super ELAN, you can expand the the tree
view of the selected ELAN or super ELAN.

v Select an ELAN or super ELAN in the VLAN tree view to administer the ELAN or
show its configuration.

Exploded Domain Panel

The characteristics of domains are displayed on the Exploded Domain panel. These
consist of:

v The emulated LANs (ELANs) and super ELANs defined in the domain.

v The LAN Emulation Configuration Server (LECS) controlling the LAN emulation
resources. Does not apply if it is the default ('unadmin') domain.

v Policing rules and priorities defined by LECSs. Does not apply if it is the default
('unadmin') domain.

v Descriptions of the ELANs and super ELANs in the domain.

The Exploded Domain panel is displayed by double-clicking the left mouse button on
the domain icon in the VLAN Broadcast Domain View. The Exploded Domain panel
displays the ELANs within the domain and the LECS associated with the domain.

Figure 18. VLAN Domain View
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When you click on an ELAN icon, a description of the ELAN is displayed.

Exploded ELAN

The characteristics of ELANs are displayed on the Exploded Domain panel when you
select an ELAN icon, and on the Exploded ELAN panel. The characteristics consist of
the:

v LAN Emulation Clients (LECs) connected to the ELAN.

v LAN Emulation Configuration Server (LECS) managing the ELAN, including
redundant LECSes.

v LAN Emulation Servers defined in the ELAN.

v Broadcast and Unknown Server (BUS) defined in the ELAN.

v Information about the ELAN polling, such as:

– How often the ELAN is polled.

– The time and date the ELAN was last polled.

– The polling policy.

To display the Exploded ELAN panel:

1. Double-click the left mouse button on the Domain icon on the VLAN Domain View.

2. Double-click the left mouse button on the ELAN icon on the Exploded Domain
panel.

Depending on the ELAN polling policy (regular or on request) the ELAN content polling
is done at regular intervals or on request.

To poll an ELAN, click on the Refresh ELAN pushbutton.

To refresh the LECs displayed in the LECs section, click on the Refresh LEC
pushbutton.

Figure 19 on page 55 shows a sample Exploded ELAN panel.
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Control View Panel

The Control View panel displays a list of all ATM devices that are being used and those
that can be used for LAN emulation. This allows you to estimate the load of any ATM
device in the network. You can filter the list by clicking on the Filter pushbutton and
selecting one of the following filter options:

Figure 19. Exploded ELAN Panel
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v All Boxes

v LECS

v LES

v BUS

v Proxy LECs

The number of instances of LECSs, LESs, BUSs, and LECs active on each ATM device
is displayed as well as the number of LECs registered to the LESs active on a ATM
device. Figure 20 shows a sample Control View panel.

FaultBuster

FaultBuster provides:

v A graphical representation of the problem context.

v The reasons for the current status of the selected resource.

v The ability to investigate a problem by:

– Recursively calling FaultBuster on one subcomponent of the selected resource.

Figure 20. Control View Panel
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– Displaying additional information on the selected resource, such as received
events.

– Running explicit tests, such as sanity checks, ping, or trace.

v Customization, allowing you to specify your own list of troubleshooting functions.

v Integrated scenario for LAN emulation path tracing.

FaultBuster allows you to diagnose problems with:

v PNNI peer groups

v Clusters

v ATM devices

v ATM interfaces

v LAN emulation resources, that is, domains, ELANS LECs LES/BUSs, and LECSs.

and problems between:

v Two ATM interfaces

v Two LAN emulation resources.

FaultBuster Panel

The FaultBuster panel displays allows you to diagnose problems with the selected
resource or resources.

To display the FaultBuster panel do one of the following:

v Select the resource or resources on the FaultBuster Selection panel. See figure 22
for a sample panel.

v Select a logged call on the Call Logging panel and choose FaultBuster from the
menu bar.

v Select the ATM device on the ATM Device submap and choose CMA -> FaultBuster
from the menu bar or from the contect menu that is displayed when you click the
right mouse button on an ATM device icon in the ATM Device submap

v Select an ATM device on the ATM View panel and select CMA - > FaultBuster from
the context menu displayed when you click the right mouse button on the selected
icon. To open the ATM View panel, do one of the following on the ATM Device
submap:

– Double-click on the ATM switch icon.

– Select an ATM switch icon, and choose CMA -> Open ATM View from the menu
bar or from the context menu that is displayed when you click the right mouse
button on the ATM switch icon.

Figure 21 on page 58 shows a sample FaultBuster panel.
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FaultBuster Selection Panel

The FaultBuster Selection panel allows you to select:

v The type and identity (for example, IP address, name, or interface index) of a
resource whose abnormal status you want diagnosed.

v Select the type and identity of the from to resource, to diagnose a connectivity
problem.

To display the FaultBuster Selection panel do one of the following:

v Select CMA -> FaultBuster from the menu bar of the Campus Manager - ATM
submaps.

v Select Navigation -> FaultBuster from the menu bar of a LAN Emulation panel.

v Select Navigation -> FaultBuster from the menu bar of an ATM Manager end-user
interface panel.

Figure 22 on page 59 shows a sample FaultBuster Selection panel.

Figure 21. FaultBuster Panel
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When you click on the OK pushbutton, on the FaultBuster Selection panel, the
FaultBuster panel similar to that shown in Figure 21 on page 58 is displayed.

Figure 22. FaultBuster Selection Panel for Connectivity Problem
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Chapter 7. Managing Physical Resources

There are two types of ATM resources:

v Physical

v Logical.

This chapter describes how to manage ATM physical resources for ATM devices For
details about managing logical resources, see “Chapter 8. Managing Logical Resources”
on page 87.

Managing ATM Devices

Global parameters for an ATM device which do not belong to a specific interface or
logical resource, are grouped into profile and configuration panels which are called
when an ATM device icon is selected.

Displaying the Profile of an ATM Device

Non-ATM-specific information about an ATM device is grouped together and stored in a
node profile. This node profile can be used to identify a resource quickly.

To display the Node Profile panel for an ATM device, select the ATM device in the ATM
Device submap and choose CMA -> Profile from the menu bar or the context menu
that is displayed when you click the right mouse button on the ATM device icon.

You can modify the administrative information for an ATM device on the Node Profile
panel by typing in new values in the fields and clicking on the Apply pushbutton: The
following can be modified:

v Contact Person

v Administratively-assigned Name

v Location.

Figure 23 on page 66 shows a sample Node Profile panel.
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To display the node profile for a different ATM device, click on the Reselect pushbutton,
and enter the required information on the panel that is displayed.

Displaying the Profile of an Interface in an ATM Device

Non-ATM-specific information about an ATM device interface is grouped together in an
interface profile. The interface profile can be used to identify a resource quickly. The
ATM Interface Profile panel can be used to:

v Display the interface information.

v Enable and disable the selected interface.

To display the ATM Interface Profile panel, select the ATM interface on the ATM View
panel and select Profile from the context menu that is displayed when you click the
right mouse button on the ATM interface icon.

Figure 24 on page 67 shows a sample Interface Profile panel.

Figure 23. Node Profile Panel
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To display the interface profile for a different ATM device, click on the Reselect
pushbutton, and enter the required information on the panel that is displayed.

Displaying the Configuration of an ATM Device

The configuration of an ATM device consists of the overall characteristics of the ATM
subsystem. This includes a list of all the ATM interfaces in the ATM device and a brief
status for each interface.

The configuration panel for an ATM device can be used to:

v Display configuration information about the selected ATM device.

v List the interfaces on the selected ATM device.

v In the case of an ATM switch, lock and unlock the selected ATM switch. See “Locking
and Unlocking an ATM Switch” on page 72.

To display the configuration panel for an ATM device, select the ATM device in the ATM
Device submap and choose CMA -> Configuration from the menu bar or from the
context menu that is displayed when you click the right mouse button on the ATM
device icon.

Figure 24. Interface Profile Panel
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To display the ATM configuration for a different ATM device, click on the Reselect
pushbutton, and enter the required information on the panel that is displayed.

The Configuration pushbutton is grayed out until you select one of the ATM interfaces
displayed in the list of interfaces. When you select an ATM interface and click on the
Configuration pushbutton, the ATM Interface Configuration panel for the selected
interface is displayed. See “Displaying the Configuration of an Interface in an ATM
Device” for details about using this panel.

If the panel has a Stop Query pushbutton, you can click on it while the interfaces are
being discovered and displayed to stop the query and display of additional interfaces.
When all the interfaces are displayed in the list, the Stop Query pushbutton is grayed
out and cannot be selected.

Displaying the Configuration of an Interface in an ATM Device

The configuration of an ATM interface consists of the physical characteristics of the
corresponding ATM port and the ATM characteristics of the ATM sub-layer running on
this port.

The ATM Interface Configuration panel can be used to:

v Display the configuration information.

v Enable and disable the selected interface.

v In the case of an ATM switch, configure the type of ATM access (UNI, NNI, or SSI).

The ATM Interface Configuration panel can be displayed in either of the following ways:

v From a Configuration panel for the ATM device (see “Displaying the Configuration of
an ATM Device” on page 67).

Select the interface in the list of ATM interfaces on the Configuration panel for the
ATM device and click on the Configuration pushbutton.

v From the ATM View panel by selecting the ATM interface and choosing
Configuration from the context menu that is displayed when you click the right
mouse button on the ATM interface icon.

Figure 25 on page 69 shows a sample ATM Interface Configuration panel.
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To display the ATM interface configuration for a different ATM device, click on the
Reselect pushbutton, and enter the required information on the panel that is displayed.

Enabling and Disabling an Interface in an ATM Device

To be operational, an ATM interface in an ATM device must be enabled. However, an
ATM interface can be disabled, for example, for security reasons, trouble-shooting, or in
the case of an ATM switch, to change the access type of the interface (see “Changing
the Interface Access Type for an ATM Switch” on page 71 for details).

Note: When an ATM interface in an ATM switch is disabled:

v All the SVCs are torn down

v All the PVCs are deleted

An ATM interface can be disabled from either:

v The Interface Configuration panel for the ATM device. See “Displaying the
Configuration of an Interface in an ATM Device” on page 68.

v The Interface Profile panel. See “Displaying the Profile of an Interface in an ATM
Device” on page 66.

On the Interface Configuration panel, set the Administrative State field to Enabled or
Disabled (Up or Down in the case of an ATM bridge).

On the Interface Profile Panel, set the Administrative State field to Up (enabled) or
Down (disabled).

Figure 25. ATM Interface Configuration Panel
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Disabling an interface may be rejected by the ATM agent (see “Locking and Unlocking
an ATM Switch” on page 72). In the case of rejection, the status may be forced to
unlock by Nways Manager-ATM automatically unlocking the node temporarily.

Displaying the PNNI Configuration of an ATM Switch

The configuration of an ATM switch supporting the PNNI protocol can be displayed by
clicking on the PNNI Configuration pushbutton on the Configuration panel for the ATM
switch.

To display the ATM Switch Configuration panel, select the ATM switch in the ATM
Device submap and choose CMA -> Configuration from the menu bar or the context
menu that is displayed when you click the right mouse button on the ATM switch icon.

Figure 26 shows a sample PNNI Configuration panel.

Displaying the PNNI Configuration of an Interface in an ATM Switch

The configuration of an interface in an ATM switch supporting the PNNI protocol can be
displayed by clicking on the PNNI Configuration pushbutton on the Configuration panel
for the ATM switch.

Figure 27 on page 71 shows a sample PNNI configuration.

Figure 26. PNNI Logical Node Panel
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Changing the Interface Access Type for an ATM Switch

An ATM interface for an ATM switch can be configured as:

v A private UNI (user-to-network interface). ILMI can be run on this port.

v A private network (IISP or PNNI interface). ILMI can run on this port, and a VP tunnel
can be created on the port.

v A public UNI (public user-to-network interface). ILMI can run on this port, and a VP
tunnel can be created on the port.

v Void (public user-to-network interface without signaling and ILMI). A VP tunnel can be
created on this port.

Changing the access type of an interface requires the interface to be disabled first. See
“Enabling and Disabling an Interface in an ATM Device” on page 69 for details.

When an ATM interface is disabled all the PVCs that were defined (if any) on the
interface become inoperative and all SVCs (if any) are torn down.

The ATM Interface Configuration panel is used to change the interface access type. The
ATM Interface Configuration panel can be displayed in either of the following ways:

v From an ATM Switch Configuration panel:

1. Select the ATM switch in the ATM Device submap and choose CMA ->
Configuration from the menu bar or the context menu that is displayed when
you click the right mouse button on the ATM switch icon.

2. Select the interface in the list of ATM interfaces on the ATM Switch Configuration
panel and click on the Configuration pushbutton.

Figure 27. ATM Interface Configuration Panel
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v From the ATM View panel, by selecting the ATM interface and choosing
Configuration from the context menu that is displayed when you click the right
mouse button on the ATM interface icon.

To change the access type of an interface, set the ATM Access Type field on the
Interface Configuration panel to UNI, SSI, or NNI.

Locking and Unlocking an ATM Switch

Network management data exchanged between the network management station
(NMS) and the ATM switch is transported using an SVC (inband SNMP) that is set up
on one of the ATM ports in the ATM switch.

Due to the nature of ATM, namely the dynamic routing of SVCs, the ATM port used by
network management data to reach the node at any given time is usually unknown to
the operator.

If the operator disables the port being used or isolates the ATM module containing the
port, network management communication is lost. To prevent this from happening, the
ATM switch can be secured so that it rejects disable port commands or isolate ATM
Module commands that are received on that port.

The ATM switch can be locked and unlocked using the Lock Status option on the
Configuration panel for the ATM switch. See “Displaying the Configuration of an ATM
Device” on page 67.

The recommended setting for the lock status is Secured. In this case, when an ATM
switch receives a command to disable a port or to isolate the ATM module, it checks
whether the command was received through this port. If it was, the command is
ignored.

To temporarily disable the lock status, set it to Unlock. Checking is disabled for 30
seconds, after which the port becomes secured again.

To permanently disable the lock status, set it to Disabled.

Note: This setting is not recommended.

Testing an ATM Interface in an ATM Switch

Note: The following applies only to IBM ATM switches.

ATM interfaces in ATM switches can be tested on the ATM Interface Test panel. You
can run wrap tests on the ATM interfaces to verify that they function correctly before
you connect cables to the ATM modules.

The ATM Interface Test panel can be used to:

v Do the following wrap tests:
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– Internal Wrap Test - Only for ATM 155–Mbps interfaces. Runs an internal test to
see if the module functions correctly.

– External Wrap Test - For all ATM interfaces. Place a wrap plug in the interface you
want to test. Runs an external test to see if the ATM interface functions correctly.

– Remote Wrap Test - Only for ATM 155–Mbps connections between two ports on
interfaces in different ATM switches. Tests to see that the connection between two
ATM 155–Mbps interfaces functions correctly. No wrap plug is used.

v Display a list of events that preceded an interface failure.

v Display a list of unsuccessful calls attempted over the interface.

To display the ATM Interface Test panel:

1. Select the ATM switch in the ATM Device submap and select CMA ->
Configuration from the menu bar or the context menu that is displayed when you
click the right mouse button on the ATM switch icon.

2. On the ATM Switch Configuration panel, select the interface to be tested in the list
of ATM interfaces and click on the Configuration pushbutton.

3. Select Navigation -> Test on the ATM Interface Configuration panel.

Figure 28 on page 74 shows a sample ATM Interface Test panel.
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When you select the type of wrap test, a graphical view of the ATM interface and port is
displayed showing how the interface is physically connected to either an ATM switch, an
ATM concentrator, an ATM bridge, an ATM station,or an end point.

To display bad calls, click on the Bad Calls pushbutton. This displays the Call Logging
panel shown in Figure 49 on page 113

Managing Attached ATM Devices

Information obtained on attached ATM device is displayed in panels associated with the
Interface Configuration panel.

Figure 28. ATM Interface Test Panel
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Displaying Basic Information about the Device

Information about an ATM device attached to the ATM interface can be obtained if the
device is another ATM device or if it supports the ILMI protocol (for UNI attachment
only).

In this case, the information can be displayed to help identify the type of device that is
connected to a given ATM port on the ATM device.

To display the ATM Interface Attached Device Information panel:

1. Select the ATM interface on the ATM View panel and choose CMA ->
Configuration from the menu bar or the context menu that is displayed when you
click the right mouse button on the ATM interface icon.

2. Click on the Attached Device Information pushbutton in the ATM Interface
Configuration panel.

Figure 29 on page 76 shows a sample ATM Interface Attached Device Information
Panel.
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The Primary ATM Address is the first address registered (if any) on this port. A list of all
registered addresses can be displayed in the Registered ATM Addresses panel (see
“Listing the ATM Addresses Registered by the Device”).

To display the interface-attached device information for a different ATM device, click on
the Reselect pushbutton, and enter the required information on the panel that is
displayed.

Listing the ATM Addresses Registered by the Device

A device that uses SVCs must have its ATM Address registered to the ATM switch or
ATM concentrator through an ATM interface. This is usually done through the ILMI
protocol.

Figure 29. ATM Interface Attached Device Information Panel
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The list of ATM devices registered to (that is, known by) an ATM switch or ATM
concentrator can be listed for trouble-shooting purposes or to help identify the device.

Note: If an ATM concentrator is connected to an ATM port of the 8250 Multiprotocol
Intelligent Hub, the list of ATM addresses registered on this port and thus known
by the node, will include the address of the concentrator itself and all the
addresses of the ATM devices attached to the concentrator.

The ATM Interface Registered Addresses panel can be displayed in either of the
following ways:

v From the Configuration panel for the ATM device:

1. Select the ATM switch or ATM concentrator in the ATM Device submap and select
CMA -> Configuration from the menu bar or the context menu that is displayed
when you click the right mouse button on the ATM switch or ATM concentrator
icon.

2. Select the interface from the interface list and click on the Configuration
pushbutton.

3. Click on the Registered ATM Addresses pushbutton in the corresponding
Configuration panel.

v By selecting the interface on the ATM View panel:

1. Double-click on the ATM switch or ATM concentrator in the ATM Device submap.

2. Select the ATM interface on the ATM View panel and select Configuration from
the context menu that is displayed when you click the right mouse button on the
ATM interface icon.

3. Click on the Registered ATM Addresses pushbutton on the corresponding
Configuration panel.

A panel similar to that shown in Figure 30 on page 78 is displayed.
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Note: The Slot.Port field is not shown on the ATM concentrator Interface Registered
ATM Addresses panel.

To display the interface registered ATM addresses for a different ATM device, click on
the Reselect pushbutton, and enter the required information on the panel that is
displayed.

Managing ATM Connections

The ATM Connection Configuration panel displays information about a selected
connection between two end-points.

Use the ATM Connection Configuration panel to manage the ATM physical connections.
To display the ATM Connection Configuration panel, select a connection between two
ATM devices in the ATM Device submap and choose CMA -> Configuration from the
menu bar or the context menu that is displayed when you click the right mouse button
on the connection.

Figure 30. ATM Interface Registered ATM Addresses Panel
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Note: If the ATM Configuration menu is grayed out, this means that this connection is a
meta-connection. You must first explode the connection before you can access
the ATMC configuration menu.

Figure 31 shows a sample ATM Connection Configuration panel.

You can navigate to the ATM Configuration and ATM Interface Configuration panels for
each of the end-points by using the pushbutton in the Connection Endpoints area.

Managing ATM Modules

Even when IBM Nways Element Manager is not installed, some level of box
management is provided in order to manage ATM modules.

Figure 31. ATM Connection Configuration Panel
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Displaying all ATM Modules

The ATM modules in an ATM Hub, 8265 ATM Switch, or ATM Workgroup Switch can be
displayed:

v As a textual description in a list when Nways Manager-ATM is used standalone
without coupling with Nways Element Manager.

v As a realistic image in a graphical form as part of the ATM Hub or 8265 ATM Switch
expanded view when Nways Manager-ATM is coupled with Nways Element Manager.

Note: An expanded view of an ATM Workgroup Switch is not provided by Nways
Element Manager.

To display a list of ATM modules, use the ATM Device Configuration panel. To display
the ATM Device Configuration panel, select the ATM device icon in the ATM Device
submap and select CMA -> Device from the menu bar or the context menu that is
displayed when you click the right mouse button on the ATM device icon.

Figure 32 shows a sample ATM Device Configuration panel.

The Configuration pushbutton is grayed out until you select one of the ATM modules
displayed in the list of ATM Modules. When you select the ATM module and click on the

Figure 32. ATM Device Configuration Panel
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Configuration pushbutton, the Configuration panel for the selected module is
displayed. See “Displaying the Configuration of an Interface in an ATM Device” on
page 68 for details about using this panel.

You can click on the Stop Query pushbutton while the modules are being discovered
and displayed to stop the query and display of additional modules. When all the
modules are displayed in the list, the Stop Query pushbutton is grayed out and cannot
be selected.

To display the device configuration for a different ATM device, click on the Reselect
pushbutton, and enter the required information on the panel that is displayed.

Attaching an ATM Module

Any modules which have not been attached to the ATM switch are shown as "unknown"
in the list of modules. Select a module in the list and click on the Configuration
pushbutton. A pop-up window allows you to attach the module to the ATM switch.

Click on the Apply pushbutton to attach the module, remove the pop-up window, and
refresh the ATM Device Configuration panel. Click on the Cancel pushbutton to remove
the pop-up window without attaching the module or refreshing the ATM Device
Configuration panel.

Resetting an ATM Module

Resetting an ATM module causes a hardware and software reset of the selected
modules.

When an ATM media module is reset, all the active SVC connections on the module are
lost. Dynamic information such as counters is also cleared.

When the active ATM switch module is reset, the entire ATM subsystem is reset (that is,
all ATM switch modules and all the ATM media modules). If backup mode was specified
for the ATM switch module on the ATM switch Module panel, the active switch will be
re-elected when the ATM subsystem is reset.

Resetting an ATM module is done using the Module Reset pushbutton in the ATM
Device Configuration panel (see Figure 32 on page 80 for an example).

Displaying the Configuration of an ATM Media Module

The configuration of an ATM media module consists of the physical characteristics of
the module.

The ATM Media Module Configuration panel is displayed when you:

1. Select the ATM switch icon in the ATM Device submap and choose CMA -> Device
from the menu bar or the context menu that is displayed when you click the right
mouse button on the ATM switch icon.
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2. Select a media module in the list of modules and click on Configuration
pushbutton.

Figure 33 shows a sample ATM Media Module Configuration panel.

Note: Module 1 in the base unit of the 8285 Nways ATM Workgroup Switch is always
attached.

Isolating and Attaching the ATM Module

In the ATM Hub, 8265 ATM Switch, and ATM Workgroup Switch each ATM media
module is attached to the Control Point through the ATM switch backplane.

Module attachment to the backplane can be controlled. For example, a module can be
physically isolated from the ATM switch for troubleshooting purposes. When isolated, no
ATM ports on the media module can be used until the module is attached again (normal
state).

Figure 33. ATM Media Module Configuration Panel
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When isolating or attaching an ATM module, the ATM Media Module Configuration
panel (see Figure 33 on page 82) is used.

To display the ATM Media Module Configuration panel:

1. Select the ATM device icon in the ATM Device submap and choose CMA -> Device
from the menu bar or the context menu that is displayed when you click the right
mouse button on the ATM device icon.

2. Select a media module in the list of modules and click on Configuration
pushbutton.

Depending on whether you are isolating or attaching the ATM media module, set the
Network State field to either isolated or attached.

Isolating a module may be rejected by the ATM Agent (see “Locking and Unlocking an
ATM Switch” on page 72). In the case of rejection, the status may be forced to Unlock
by Nways Manager-ATM automatically unlocking the node temporarily.

Displaying the Configuration of an ATM Switch Module

The configuration of an ATM switch module consists of the physical characteristics of
the module.

To display the ATM Switch Module Configuration panel:

1. Select the ATM device icon in the ATM Device submap and choose CMA -> Device
from the menu bar or the context menu that is displayed when you click the right
mouse button on the ATM device icon.

2. Select a switch module in the list of modules and click on Configuration
pushbutton.

Figure 34 on page 84 shows a sample ATM Switch Module Configuration panel.
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Managing the Serial Line Internet Protocol Connection

The SLIP Configuration panel displays information about the configuration of the SLIP
(Serial Line Internet Protocol) connection. For information on installing SLIP support,
refer to InfoExplorer.

The SLIP Configuration panel can be displayed:

v From the ATM Device submap in either of the following ways:

– Select the ATM switch and choose SLIP Connection from the CMA menu or the
context menu that is displayed by clicking the right mouse button on the ATM
switch icon.

– Click the right mouse button on an ATM switch, select CMA and choose SLIP
Connection .

v From the Navigation menu on the following panels:

– ATM Switch Profile panel

– ATM Switch Configuration panel

Figure 34. ATM Switch Module Configuration Panel
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– ATM Device Configuration panel

Figure 35 shows a sample SLIP Configuration panel.

Displaying the Configuration of LAN Emulation Components in an ATM Device

The configuration of the LAN emulation components in an ATM device consists of the
overall characteristics of the LAN emulation components in ATM switches, ATM bridges,
and MSS servers.

The LAN Emulation Configuration panel of the LAN Emulation Manager can be used to:

v Display the LAN Emulation Clients (LECs), LAN Emulation Servers (LESs), LAN
Emulation Configuration Servers (LECSs), and Broadcast and Unknown Servers
(BUSs) in the ATM device

v Display the configuration of the LECs, LESs, LECSs, and BUSes

v Display all super ELANs

To display the Device Configuration panel do any of the following:

Figure 35. SLIP Configuration Panel
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v Select an ATM device in the ATM Device submap and choose CMA - > LAN
Emulation from the menu bar or the context menu that is displayed when you click
the right mouse button on the ATM device icon.

v When the Configuration or Profile panel for the ATM device is open, select
Navigatio n - > LAN Emulation from the menu bar.

v On the ATM View panel, select ATM Node -> LAN Emulation or double-click on the
LAN emulation icon in the ATM Node Status section of the panel. To open the ATM
View panel do one of the following in the ATM Device submap:

– Double-click on the ATM device icon.

– Select the ATM device icon, and choose CMA -> Open ATM View from the menu
bar or the context menu that is displayed when you click the right mouse button
on an ATM device icon.

Figure 69 on page 147 shows a sample LAN Emulation Configuration panel.
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Chapter 8. Managing Logical Resources

There are two types of ATM resources:

v Physical

v Logical.

This chapter describes how to manage logical resources. For details about managing
physical ATM resources, see “Chapter 7. Managing Physical Resources” on page 65.

How to Manage SVCs

Note: The following applies only to IBM devices.

Panels related to SVCs are obtained after selecting an ATM interface. The panels are
accessed from options grouped in the menu bar of the Interface Configuration panel.

Note: SVCs are set up at the network boundary (end-user-to-network interface). As
such, they can be selected only on UNI interfaces.

Listing the SVCs

The switched virtual connections (SVCs) currently set up can be listed on a
per-interface basis. SVCs are shown only on user-to-network interfaces (UNIs).

On a given interface, each SVC is uniquely identified by a call reference (negotiated
between the ATM Node and the device that set up the SVC) and a signaling channel
(the virtual channel used to set up the SVC).

A point-to-multipoint SVC is used to connect several remote endpoints (leaves) to a
single root end-point. These connections (root and leaves) share the same call
reference. However, they are listed as separate lines.

Because of the transient nature of SVCs, it is not recommended that you use the SVC
list facility extensively. It can be time-consuming and the accuracy depends on the
duration of the SVCs.

The SVC list should be primarily used to delete an SVC (force deletion as the SVC is
usually cleared by only one of the endpoints) or to track a connection in the network for
trouble-shooting purposes.

You can display the SVC List panel in either of the following ways:

v From the ATM device submap:

1. Select the ATM switch and select Configuration from the context menu that is
displayed when you click the right mouse button on the ATM interface icon.
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2. Select SVC -> List in the menu bar of the ATM Switch Interface Configuration
panel.

v From the ATM View panel:

1. Select the ATM interface on the ATM View panel and select Configuration from
the context menu that is displayed when you click the right mouse button on the
ATM interface icon.

2. Select SVC -> List in the menu bar of the ATM Switch Interface Configuration
panel.

Figure 36 on page 89 shows a sample SVC List panel.
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The list of SVCs actually shown may be filtered based on the signaling channel
identifiers. signaling channels are defined by VPI and VCI values (by default the ATM
switch uses only one signaling channel, defined on VPI=0, VCI=5). Selecting the
signaling channels is done by defining their VPI and VCI values in the signaling channel
VPI and VCI read-write fields (an asterisk convention is allowed):

v VPI=* VCI=* selects all signaling channels. No filtering is done and all SVCs defined
on this interface are listed. This is the default.

Figure 36. ATM SVC List Panel
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v VPI=x VCI=y selects only the signaling channel whose VPI value is x and whose VCI
value is y. Only SVCs set up through this signaling channel are listed.

v VPI=x VCI=* selects all the signaling channels whose VPI value is x, whatever the
VCI value. Only SVCs set up through this signaling channel are listed.

v VPI=* VCI=y selects all the signaling channels whose VCI value is y whatever the
VPI value. Only SVCs that were set up through this signaling channel are listed.

Displaying the Characteristics of an SVC

Detailed information can be displayed for a given SVC at a UNI only.

When the SVC is a point-to-multipoint connection, all the called numbers are listed. The
other parameters of the SVCs are the same for each leaf of the SVC.

When an incoming point-to-multipoint SVC is shown (the interface selected is not the
interface where the call was initiated), the root and the selected leaf are shown but the
other leaves of the SVC are not shown. To obtain information about the other
endpoints, the SVC must be selected on the hub and interface where the SVC was
initiated (the outgoing side).

The ATM SVC Details panel (see Figure 37 on page 91) displays the characteristics of
the SVC. To display the ATM SVC Details panel:

1. Select the ATM interface on the ATM View panel and select Configuration from the
context menu that is displayed when you click the right mouse button on the ATM
interface icon.

2. Select SVC -> List in the menu bar of the ATM Interface Configuration panel.

3. Select an SVC in the SVC List Table and click on the Details pushbutton.
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Deleting an SVC

An SVC is usually deleted by one of its endpoints without requiring any operator
intervention.

Figure 37. ATM SVC Details Panel
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However, in some cases, it may be desirable to force an SVC deletion from the network
management station. For example, this could be used to free a value of VPI/VCI
needed to establish a PVC when none of the endpoints can release the SVC
(unattended endpoints).

Note: In the case of point-to-multipoint SVCs, the endpoints cannot be deleted
selectively. Deleting the SVC deletes all the endpoints.

SVCs are deleted from the ATM SVC List Panel (see Figure 36 on page 89). Select an
SVC in the SVC List Table. Then click on the Delete pushbutton.

How to Manage PVCs

Note: The following applies only to IBM devices.

Panels related to PVCs are obtained after selecting an ATM interface. The panels are
accessed by options grouped together in the menu bar of the ATM Interface
Configuration panel.

Listing PVCs and Endpoints

The Permanent Virtual Connections (PVCs) currently defined in the ATM switch can be
listed on a per-interface basis.

On a given interface, each PVC is uniquely defined by its PVC identifier which is
allocated when the PVC is created.

The PVC end-point associated with the interface where the PVC was first created is the
primary, or root side. The other end-point is the secondary (or leaf) side of the PVC.

The ATM PVC List panel can be displayed in the following ways:

v From the ATM Device submap, by selecting the ATM switch icon, and choosing CMA
-> PVC -> List from the menu bar or the context menu that is displayed when you
click the right mouse button on an ATM switch icon.

v From the ATM View panel:

1. Select the ATM interface on the ATM View panel and select Configuration from
the context menu that is displayed when you click the right mouse button on the
ATM interface icon.

2. Select PVC -> List in the menu bar of the ATM Interface Configuration panel.

Figure 38 on page 93 shows a sample PVC List panel.
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When a PVC is selected you can:

v Filter the PVCs displayed. Select PVC Filtering from the menu bar and select the
filtering option. The value you select is displayed in the Filtering Values field.

Figure 38. ATM PVC List Panel
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v Display additional information about the characteristics of the selected PVC. Select a
PVC in the list, and click on the Details pushbutton. This displays the PVC Endpoint
Details panel (see “Displaying the Characteristics of a PVC or Endpoint”) showing
details of the PVC and its associated endpoint if selected.

v Restart a selected PVC.

v Restart all PVCs.

v Track a PVC if it is active. The Tracking pushbutton is grayed out and cannot be
selected if the selected PVC is not active.

To start tracking, select the PVC and click on the Tracking pushbutton. This displays
the PVC Tracking panel (see “Tracking a PVC” on page 110) for the selected PVC.

v Create a PVC. Click on the Create pushbutton. This displays the PVC Create and
Add Party panel (see “Creating a PVC” on page 96).

v Delete the selected PVC.

When an endpoint is selected you can:

v Display additional information about the characteristics of the selected endpoint.
Select an endpoint in the list, and click on the Details pushbutton. This displays the
PVC Endpoint Details panel (see “Displaying the Characteristics of a PVC or
Endpoint”) showing details of the selected endpoint and PVC.

v Add an endpoint. Click on the Add pushbutton. This displays the PVC Create and
Add Party panel shown in Figure 40 on page 98.

v Restart a selected endpoint.

v Restart all endpoints.

v Delete an endpoint.

Displaying the Characteristics of a PVC or Endpoint

The characteristics of a PVC or endpoint can be displayed at any time, regardless of
whether the PVC or endpoint is active or only defined (that is, failing or not activated
yet).

The characteristics of a PVC and endpoint are displayed on the PVC Endpoint Details
panel. The PVC Endpoint Details panel can be displayed in any of the following ways:

v From the ATM PVC List panel:

1. Select the ATM switch icon on the ATM Device submap, and select CMA -> PVC
-> List from the menu bar or the context menu that is displayed when you click
the right mouse button on the ATM switch icon.

2. Select the PVC or endpoint, and click on the corresponding Details pushbutton.

v From the ATM Interface Configuration panel:

1. Select the ATM interface on the ATM View panel and select Configuration from
the context menu that is displayed when you click the right mouse button on the
ATM interface icon on the ATM View panel.

2. Select PVC -> List in the menu bar of the ATM Interface Configuration panel.
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3. Select a PVC or endpoint and click on the Details pushbutton.

Figure 39 on page 96 shows a sample PVC Endpoint Details panel.

Notes:

1. The Status Cause field in Figure 39 on page 96 shows the PVC failure reason
cause. It has no meaning if the PVC is in the active state.

2. The Q2931 Cause field in Figure 39 on page 96 shows the signaling failure reason
cause. It has no meaning if the PVC is in the active state.
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Creating a PVC

A PVC is created by:

v Specifying a source endpoint (which will become the primary or root side of the PVC)

Figure 39. PVC Endpoint Details Panel
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v Specifying a destination endpoint (the secondary side)

v Providing the PVC characteristics such as the PVC type and the quality of service.

The secondary side of the PVC may be on the same node or on a different node to the
primary side. If the primary and secondary sides do not belong to the same node there
must be at least a physical path between the two nodes. Otherwise, the PVC creation
will fail due to lack of a path.

Note: To set up a PVC connection between two NNI interfaces, you must define a
logical link on each interface. For more information, see 8260 Nways
Multiprotocol Switching Hub, ATM Control Point and Switch Module Installation
and User’s Guide, SA33-0326.

The PVC Create and Add Party panel can be displayed in either of the following ways:

v By selecting CMA -> PVC -> Create from any submap.

v From the ATM Device submap by selecting the ATM switch icon, and choosing CMA
-> PVC -> Create from the menu bar or the context menu that is displayed when you
click the right mouse button on an ATM switch icon.

v From the ATM Interface Configuration panel:

1. Select the ATM switch in the ATM Device submap, and select CMA ->
Configuration from the menu bar or from the context menu that is displayed
when you click the right mouse button on the ATM switch icon.

2. Select an interface in the list of ATM interfaces on the ATM switch Configuration
panel and click on the Configuration pushbutton.

3. Select PVC -> Create from the menu bar of the ATM Interface Configuration
panel.

v From the ATM View panel:

1. Select the ATM interface on the ATM View panel and select Configuration from
the context menu that is displayed when you click the right mouse button on the
ATM interface icon.

2. Select PVC -> Create from the menu bar of the ATM Interface Configuration
panel.

v From the ATM PVC List panel by clicking on the Create pushbutton, or by selecting
Action -> Create PVC from the menu bar (see “Listing PVCs and Endpoints” on
page 92).

A panel, similar to that shown in Figure 40 on page 98 is displayed.

When you create a PVC, the ATM PVC Create and Add Party panel is automatically
configured for creating a PVC. This means that all options not required for creating a
PVC are disabled. The switch IP and ATM address and interface index fields are
automatically filled with values for the selected switch.

Note: If you selected to create a PVC from the CMA menu on a submap, the ATM
Create PVC and Add Party panel fields are not filled in.
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The defaults for Identifier and VPI / VCI fields is Automatic. In this mode, a free
identifier is automatically provided. If you select Manual, you must provide values for
the identifier, VPI, and VCI.

The traffic characteristics are chosen for forward and backward traffic directions.
Forward traffic is from the source endpoint to the destination endpoint. Backward traffic
is from the destination endpoint to the source endpoint.

The quality of service (QOS) can be:

Figure 40. ATM PVC Create and Add Party Panel
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v Unspecified-Unspecified QOS

v Class A-Circuit Emulation, Constant Bit Rate Video

The traffic type is automatically set when you select the quality of service. Best effort is
used if Unspecified is selected. If Class A is selected, the traffic type is peak and you
must specify the backward and forward rate. This is specified in bits per second (bps)
and can take the format 50,000,000, 50,000K, or 50M.

When all the parameters are set, click on the Process pushbutton to start the PVC
create process. PVC creation can be cancelled during the process cycle by clicking on
the Cancel pushbutton. While the process is running its progress is shown in the
Report field.

When a PVC creation process has started, the PVC can be seen in the ATM PVC List
panel and the ATM PVC Endpoint Details panel (depending on the type of PVC) in one
of the following states:

Not Ready The PVC has been locally defined on the primary
side but some parameters are missing to activate it.
No resources are allocated in the network and no
data can flow on the path.

Active The PVC has now been set up end to end.
Resources have been allocated and the PVC can
transmit data.

Not in Service The PVC has been active, or an end-to-end setup
was attempted to activate the PVC, but the PVC
connection failed.

Deleting a PVC or Endpoint

Deleting a PVC or endpoint results in deleting the virtual connection used by the PVC
and freeing all the allocated resources in the network.

A PVC can be deleted only from its primary (root) side.

A PVC can be deleted on the ATM PVC List panel (see “Listing PVCs and Endpoints”
on page 92).

Select the PVC in the list, and click on the Delete pushbutton.

Restarting a PVC or Endpoint

Sometimes, a PVC or endpoint can be in a state other than active, for example not in
service (see “Creating a PVC” on page 96). In this case, no data traffic can take place
over this PVC.
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To be able to use such a PVC you must restart it. This is done using the Restart
pushbutton on the the ATM PVC List Panel (see “Listing PVCs and Endpoints” on
page 92).

Adding a Party

A party can be added only for a primary multipoint PVC. To add a party, select the
primary multipoint PVC on the PVC List panel and click on the Add pushbutton. This
displays the ATM PVC Create and Add Party panel shown in Figure 40 on page 98.

The defaults for Party and VPI / VCI fields is Automatic. In this mode, a free identifier is
automatically provided. If you select Manual, you must provide values for the party, VPI,
and VCI. To start the add party process, click on the Process pushbutton. Add party
creation can be cancelled during the process cycle by clicking on the Cancel
pushbutton. While the process is running its progress is shown in the Report field.

How to Manage Physical Links

Note: The following applies only to IBM devices.

Panels related to physical links are obtained after selecting an ATM interface. They are
grouped in the menu bar of the Interface Configuration panel.

Listing Physical Links

Physical links can be listed on a per-interface basis.

Physical links can be displayed on any type of ATM interface (UNI, SSI, or NNI).

To display the ATM Physical Links List Panel:

1. Double-click on an ATM device icon in the ATM Device submap.

2. Select Configuration from the context menu that is displayed when you click the
right mouse button on an ATM interface icon on the ATM View panel.

3. Select Link -> Physical Links in the menu bar of the ATM Interface Configuration
panel.

Figure 41 on page 101 shows a sample Physical Links List Panel.
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How to Manage Logical Links

Panels related to logical links are obtained after selecting an ATM interface. They are
grouped in the menu bar of the Interface Configuration panel.

Listing Logical Links

Logical links can be listed on a per-interface basis.

Logical links can be displayed on any type of ATM interface (UNI, SSI, or NNI).

To display the ATM Logical Links List Panel:

1. Double-click on an ATM switch icon in the ATM Device submap.

2. Select Configuration from the context menu that is displayed when you click the
right mouse button on an ATM interface icon on the ATM View panel.

3. Select Link -> Logical Links in the menu bar of the ATM Interface Configuration
panel.

Figure 42 on page 102 shows a sample Logical Links List Panel.

Figure 41. 155 Mbps Module Physical Links Panel
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How to Manage Virtual Links for IBM Devices

The following describes how to manage virtual links for IBM devices. For details on
managing virtual links for non-IBM devices, see “How to Manage Virtual Links for
Non-IBM Devices” on page 105.

Figure 42. Logical Links Panel
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Panels related to virtual links are obtained after selecting an ATM interface. They are
grouped in the menu bar of the Interface Configuration panel.

Listing VPLs and VCLs

Virtual path links (VPLs) and virtual channel links (VCLs) can be listed on a
per-interface basis.

Virtual links can be displayed on any type of ATM interface (UNI, SSI, or NNI) as
opposed to SVCs which can be displayed only on UNIs.

To display the ATM Virtual Links panel:

1. Select the ATM interface on the ATM View panel and select Configuration from the
context menu that is displayed when you click the right mouse button on an ATM
interface icon on the ATM View panel.

2. Select Link -> Virtual Links in the menu bar of the ATM Interface Configuration
panel.

Figure 43 on page 104 shows a sample Virtual Links panel.
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The list of virtual links actually shown may be filtered based on the VPI value, the VCI
value, or both. Virtual path links are defined by a VPI value only. Virtual channel links
are defined by VPI and VCI values. Selecting the virtual links is done by defining their
VPI and VCI values in the VPI and VCI read-write fields (an asterisk convention is
allowed) as follows:

v VPI=* VCI=* selects all virtual links. That is, for all path and channel links all the links
defined on this interface are listed. This is the default.

v VPI=x VCI=* selects all the virtual links whose VPI value is x. That is, all the virtual
path links defined with VPI=x or all the virtual channel links defined with VPI=x,
whatever their VCI, are listed.

v VPI=* VCI= selects all the virtual path links.

v VPI=x VCI= selects all the virtual path links whose VPI is x.

v VPI=x VCI=y selects the virtual channel link whose VPI is x and whose VCI value is
y.

Figure 43. Virtual Links Panel
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Showing the Characteristics of a Virtual Link

Detailed information can be shown for a given virtual link.

To display the ATM Virtual Links Configuration panel:

1. Select the ATM interface on the ATM View panel and select Configuration from the
context menu that is displayed when you click the right mouse button on the ATM
interface icon on the ATM View panel.

2. Select Link s - > Virtual Links in the menu bar of the ATM Interface Configuration
panel.

3. Select a virtual link in the Links list, and click on the Configuration pushbutton.

Figure 44 shows a sample Virtual Link Details panel.

How to Manage Virtual Links for Non-IBM Devices

The following describes how to manage virtual links for non-IBM devices. For details on
managing virtual links for IBM devices, see “How to Manage Virtual Links for IBM
Devices” on page 102.

Figure 44. Virtual Link Details Panel
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The panel related to virtual links is obtained after selecting an ATM interface. They are
grouped in the menu bar of the Interface Configuration panel.

To display the ATM Virtual Links panel:

1. Select the ATM interface on the ATM View panel and select Configuration from the
context menu that is displayed when you click the right mouse button on an ATM
interface icon on the ATM View panel.

2. Select Virtual Links -> List in the menu bar of the ATM Interface Configuration
panel.

The list of virtual links actually shown may be filtered based on the VPI value, the VCI
value, or both. Virtual path links are defined by a VPI value only. Virtual channel links
are defined by VPI and VCI values. Selecting the virtual links is done by defining their
VPI and VCI values in the VPI and VCI read-write fields (an asterisk convention is
allowed) as follows:

v VPI=* VCI=* selects all virtual links. That is, for all path and channel links all the links
defined on this interface are listed. This is the default.

v VPI=x VCI=* selects all the virtual links whose VPI value is x. That is, all the virtual
path links defined with VPI=x or all the virtual channel links defined with VPI=x,
whatever their VCI, are listed.

v VPI=* VCI= selects all the virtual path links.

v VPI=x VCI= selects all the virtual path links whose VPI is x.

v VPI=x VCI=y selects the virtual channel link whose VPI is x and whose VCI value is
y.

Detailed information can be shown for a given virtual link.

To display the ATM Virtual Links Traffic Description panel:

1. Select the ATM interface on the ATM View panel and select Configuration from the
context menu that is displayed when you click the right mouse button on the ATM
interface icon on the ATM View panel.

2. Select Virtual Links -> List in the menu bar of the ATM Interface Configuration
panel.

3. Select a virtual link in the Links list. Then click on the Configuration pushbutton.

Figure 45 on page 107 shows a sample Virtual Link Traffic Description panel.
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How to Track a Virtual Connection

Note: The following applies only to IBM devices.

Tracking a connection in the network consists of identifying the endpoints of a
connection and the intermediate nodes used by the connection.

To track a connection, Nways Manager-ATM must be given a connection identifier. The
connection may be a PVC or an SVC and the identifier will be:

Figure 45. Virtual Links Traffic Description Panel
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v For an SVC-An 8260 Hub Node, an interface on this node (defined as the UNI
because SVCs are defined at UNI level only), a signaling channel (generally
corresponding to VPI=0, VCI=5), and a call reference.

v For a PVC-An 8260 Hub Node, an interface on this node, and a PVC identifier.

Because both PVCs and SVCs actually consist of a collection of virtual links, it is also
possible to provide a virtual link identifier (a VPI value for a VPL; a VPI and a VCI value
for a VCL) instead of the SVC call reference or PVC identifier.

Panels for connection tracking are obtained from:

v SVC panels for SVC tracking

v PVC panels for PVC tracking

v Virtual link panels for virtual connection tracking

When the tracking process has completed, the connection is displayed graphically.
Displayed items include:

v ATM nodes: ATM Control Point and Switch Modules, ATM bridges and ATM
concentrators. ATM node icons have context menus used to initiate all basic C ATMC
functions.

v ATM interfaces: ATM interfaces that serve as input and output for ATM Control Point
and Switch Modules. (Slot.Port on an 8260 module.)

Note: An ATM interface icon can be dragged to the ATM Switch Monitor panel.

v ATM endpoints: The ATM devices that are at each end of the connection. (There may
be more than two connection endpoints since connections can be multicast.)

v ATM links: Links between ATM switches and ATM endpoints. The VPI and VCI
identifiers are shown.

Tracking an SVC

When one of the endpoints of an SVC is known, that is, selected in the SVC List
section, it is possible to know the other end-point and all intermediate nodes used by
this SVC.

In the case of a point-to-multipoint SVC, the root of the SVC and all its leaves along
with all the intermediate nodes are found.

An SVC is tracked from the SVC List panel as follows:

1. Select the ATM interface in the ATM View panel, and select CMA -> Configuration
from the menu bar or from the context menu that is displayed when you click the
right mouse button on the ATM interface icon.

2. Select SVC -> List in the menu bar of the ATM Interface Configuration panel.

3. Select an SVC in the SVC List section. Then click on the Tracking pushbutton.

Figure 46 on page 109 shows an example of an ATM SVC Tracking panel.
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The Navigation menu in the menu bar contains one item, Highlight Node , which
highlights the ATM node that contains the selected SVC endpoint. The submap
containing this node is displayed.

Figure 46. ATM SVC Tracking Panel
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Tracking a PVC

When one of the endpoints of a PVC is known, that is, selected in the PVC List section,
it is possible to know the other end-point and all intermediate nodes used by this PVC.

Tracking a PVC can be done from the PVC List panel (see “Listing PVCs and
Endpoints” on page 92). To track a PVC, select it from the list and click on the Tracking
pushbutton.

Figure 47 shows and example of an ATM PVC Tracking panel.

Figure 47. ATM PVC Tracking Panel
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Tracking a Virtual Connection

When one virtual link is known, that is, selected in the Virtual Link section, it is possible
to know the endpoints used by this connection as well as all the intermediate nodes
used by this connection.

If this virtual link belongs to a point-to-multipoint connection, the root of the connection
and all its leaves, along with all the intermediate nodes, are found.

Virtual connections are displayed between ATM switches and ATM Workgroup Switchs
in the same ATM Cluster or Peer Group (NNI connections are not supported).

To display the Connection Tracking Panel:

1. Select the ATM interface on the ATM View panel, and select CMA -> Configuration
from the menu bar or from the context menu that is displayed when you click the
right mouse button on the ATM interface icon.

2. Select Link -> Virtual Links in the menu bar of the ATM Interface Configuration
panel.

3. Select a line in the Link List Table of the ATM Virtual Links panel. Then click on the
Tracking pushbutton.

Figure 48 on page 112 shows an example of an ATM Connection Tracking panel.
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Displaying Logged Calls

To display the Call Logging panel do one of the following:

v Select CMA -> Call Logging from the menu bar of the Campus Manager - ATM
submaps.

v Click the right mouse button on an ATM device icon in the ATM Device submap and
select CMA -> Call Logging from the context menu.

v Select Navigation -> Call Logging from the menu bar of a Campus Manager - ATM
end-user interface panel.

v Click the right mouse button on an icon on the ATM View panel and select CMA ->
Call Logging from the context menu. To open the ATM View panel do one of the
following in the ATM Device submap:

– Double-click on the ATM switch icon.

Figure 48. ATM Connection Tracking Panel
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– Select an ATM switch icon, and select CMA -> Open ATM View from the menu
bar or from the context menu that is displayed when you click the right mouse
button on an ATM switch icon.

The Call Logging panel can be called from the ATM Interface Test panel to display bad
calls for the interface being tested. For further information on testing ATM interfaces,
see “Testing an ATM Interface in an ATM Switch” on page 72.

A sample Call Logging panel is shown in Figure 49.

Note: Only the ESI and selector are displayed for called and calling numbers.

You can filter the logged calls displayed by selecting the filter option. Filtering, can be
by interface, calling number, called number, service category, location, or cause. The
wildcards * (any string), ? (any character), and ! (NOT) can be entered as filter values.

For example, if you want display all calling numbers whose ESI begins with 6 and ends
with 2, and whose selecter has any number followed by 3, do the following:

1. Select Calling Number as the filter option

Figure 49. Call Logging Panel.
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2. Type the following in the Filter Value field:

6*2?3

3. Press the Apply Filter pushbutton.

If you want to display abnormal calls only, you can use !31 as the filter value for the
Cause option.

Click on the Clear pushbutton to remove the contents of the Clear Table listbox section.
To refresh the list to show newly-logged calls, click on the Refresh pushbutton.

You can start FaultBuster to analyze status and connectivity problems, by selecting
Navigation -> FaultBuster from the menu bar.

Displaying Details about a Logged Call

Detailed information can be obtained about a specific call logged in the agent (see
Figure 50 on page 115).

To display the details of a logged call, select the logged call in the list and click on the
Details pushbutton.
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Figure 50. Call Details Panel
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Chapter 9. Managing LAN Emulation Components

The LAN Emulation Manager allows you to control the LAN emulation services of
existing ELANs across an ATM network.

How to Manage a Domain

A domain is a set of LAN emulation resources controlled by one LAN Emulation
Configuration Server (LECS) instance. Managing a domain consists of creating and
deleting the domain.

Displaying the Characteristics of a Domain

The characteristics of domains are displayed on the Exploded Domain panel. These
consist of:

v The emulated LANs (ELANs) defined in the domain.

v The LAN Emulation Configuration Server (LECS) controlling the LAN emulation
resources. Does not apply if it is the default ('unadmin') domain.

v Policing rules and priorities defined by LECSs. Does not apply if it is the default
('unadmin') domain.

v Descriptions of the ELANs in the domain.

To display the Exploded Domain panel double-click on the Domain icon on the VLAN
Broadcast Domain View. The Exploded Domain panel displays the ELANs within the
domain and the LECS associated with the domain.

When you click on an ELAN icon, a description of the ELAN is displayed.

Figure 51 on page 118 shows a sample Exploded Domain panel.
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Creating a Domain

Creating a domain consists of specifying the characteristics of the domain. The Create
Domain panel is used to:

v Specify where to instanciate the new LECS.

You can select a ATM device from the list of proposed ATM devices displayed when
you click on the List pushbutton.

v Specify the IP and ATM address of the LAN Emulation Configuration Server (LECS).
An IP and ATM address might be proposed for the given ATM device but these can
be changed if required to avoid duplication problems.

v Select the type of policing profile.

v Optionally create the first ELAN and policing values within the domain.

Figure 51. Exploded Domain Panel
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The Create Domain panel can be displayed in one of the following ways:

v From the Exploded Domain panel:

1. Double-click the left mouse button on the VLANs icon on the Root submap.

2. Double-click the left mouse button on a Domain icon on the VLAN Broadcast
Domain panel.

3. On the Exploded Domain panel, select Control -> Create Domain or click on the
Create Domain pushbutton on the toolbar.

v From the Exploded ELAN panel:

1. Double-click the left mouse button on the VLANs icon on the Root submap.

2. Double-click the left mouse button on a Domain icon on the VLAN Broadcast
Domain View

3. Double-click the left mouse button on an ELAN icon on the Exploded Domain
panel

4. On the Exploded ELAN panel, select Control -> Create Domain or click on the
Create Domain pushbutton on the toolbar.

v From the Control View panel:

1. Double-click the left mouse button on the VLANs icon on the Root submap.

2. Select Control -> Control View or click on the Control View pushbutton on the
toolbar.

3. On the Control View panel, select Control -> Create Domain or click on the
Create Domain pushbutton on the toolbar.

Figure 52 shows a sample Create Domain panel.

Figure 52. Create Domain Panel
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If you want to view all LAN emulation ATM devices in the network that can support
LECS instances, click on the View Devices Load pushbutton. This displays the Control
View panel shown in Figure 67 on page 141 filtered for ATM devices capable of
supporting LECS instances only.

To specify the type of policing profile, click on the View Devices Load pushbutton and
select one of the following:

By ATM Address

By ELAN Name

By LAN Type

By MAC Address

By Maximum Frame Size

By ATM Address first and by ELAN Name next

By ATM Address first and by LAN Type next

By ELAN Name first and by LAN Type next

By ATM Address first and by Maximum Frame Size next

By ELAN Name first and by Maximum Frame Size next

By ATM Address first, by ELAN Name and LAN Type next

By ATM Address first, by ELAN name and Maximum Frame Size next

By ATM Address first, by ELAN Name next and then by LAN Type

By ATM Address first, ELAN Name next then by Maximum Frame Size.

When the domain has been created, you can create an ELAN in the domain. To do this,
click on the Create ELAN in this Domain pushbutton.

Deleting a Domain

The following describes how to delete a domain. A domain can be deleted only when no
ELANs exist within the domain.

To delete a domain, do the following:

1. Select the Domain icon on the Broadcast Domain panel, and select Delete from the
context menu that is displayed when you click the right mouse button on the
Domain icon.

2. Click on the Apply pushbutton to confirm the delete.

Figure 53 on page 121 shows a sample Delete Domain panel.
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How to Manage an Emulated LAN

Managing an Emulated LAN (ELAN) consists of creating, moving, deleting, and
performing administration on ELANs.

Displaying the Characteristics of an Emulated LAN

The characteristics of ELANs are displayed on the Exploded Domain panel when you
select an ELAN icon (see Figure 51 on page 118), and on the Exploded ELAN panel.
The characteristics consist of the:

v LAN Emulation Clients (LECs) connected to the ELAN.

v LAN Emulation Configuration Server (LECS) managing the ELAN.

v LAN Emulation Servers defined in the ELAN.

v Broadcast and Unknown Server (BUS) defined in the ELAN.

v Information about the ELAN polling, such as:

– How often the ELAN is polled.

– The time and date the ELAN was last polled.

– The polling policy.

To display the Exploded ELAN panel either:

v Double-click the left mouse button on the Domain icon on the Broadcast Domain
panel.

v Double-click the left mouse button on the ELAN icon on the Exploded Domain panel.

Depending on the ELAN polling policy (regular or on request) the ELAN content polling
is done at regular intervals or on request.

To poll an ELAN, click on the Refresh ELAN pushbutton.

To refresh the LECs displayed in the LECs section, click on the Refresh LEC panel.

Figure 54 on page 122 shows a sample Exploded ELAN panel.

Figure 53. Delete Domain Panel
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Creating an Emulated LAN

Creating an ELAN consists of:

v Specifying the name, type, and maximum frame size of the ELAN and the name of
the domain in which it resides.

Figure 54. Exploded ELAN Panel
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v Providing the IP address of the ATM device in which the LAN Emulation Server
(LES) and the Broadcast and Unknown Server (BUS) are to reside.

The IP and ATM address of the physical ATM device might be proposed for the LES
to be created, but these can be changed to avoid duplication problems. The same
ATM address is used for the BUS (for MSS server ATM devices only).

Note: LES/BUS instances are already created in the ATM Control Point and Switch
Module in 8260 Nways Multiprotocol Switching Hubs and the Control Point in
8285 Nways ATM Workgroup Switches, and their administrative state need
only be set to Up. This can be done on the LES Configuration panel. See
“Displaying the Configuration of a LAN Emulation Server” on page 127.

v Configuring policies.

The Create ELAN panel can be displayed from the following panels by selecting
Control -> Create ELAN from the menu bar or by clicking on the Create ELAN
pushbutton on the toolbar:

v LAN Emulation

v Exploded Domain

v Exploded ELAN

v Control View

If you want to view all LAN emulation ATM devices in the network that can support LES
instances, click on the View Devices Load pushbutton in the LES Information section.
This displays the Control View panel shown in Figure 67 on page 141 filtered for ATM
devices capable of supporting LES instances only.

If you want to view all LAN emulation ATM devices in the network that can support BUS
instances, click on the View Devices Load pushbutton in the BUS Information section.
This displays the Control View panel shown in Figure 67 on page 141 filtered for ATM
devices capable of supporting BUS instances only. Figure 55 on page 124 shows a
sample Create ELAN panel.
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Emulated LAN administration

The administration an Emulated LAN (ELAN) consists of:

v Displaying the configuration of the associated LECS.

v Creating and deleting redundant LAN Emulation Servers (LESs). This is valid for
MSS servers only.

v Modifying the type of ELAN and the maximum frame size of the ELAN.

The ELAN Administration panel can be used to:

v Display configuration information about the selected ELAN.

v Display the configuration of the LECS.

Figure 55. Create ELAN Panel
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v Display the type, length, value (TLV) parameters for the LECS. This is for MSS
servers only.

v List the LESs defined to the LECS and allows you to delete them and to display their
configuration.

v Enable and disable LES redundancy.

v Show the details of policies related to the LESs.

v Create a redundant LES. This is for MSS servers only.

The ELAN Administration panel can be displayed in one of the following ways:

v From the Exploded Domain panel:

1. Double-click the left mouse button on the ELAN icon on the Exploded Domain
panel.

2. Select the ELAN icon and select Administration from the context menu that is
displayed when you click the right mouse button on the ELAN icon.

v From the LECS Configuration panel:

1. Double-click the left mouse button on the ELAN icon on the Exploded Domain
panel.

2. Double-click on the LECS icon, or select the LECS icon and select
Configuration from the context menu that is displayed when you click the right
mouse button on the LECS icon.

3. On the LECS Configuration panel, select the ELAN from the ELAN list and click
on the Administration pushbutton.

Figure 56 on page 126 shows a sample ELAN Administration panel.
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v To display the configuration of the LECS, click on the LECS Configuration
pushbutton. This displays the LECS Configuration panel shown in Figure 62 on
page 135.

v To display the configuration of the type, length, and value (TLV) parameters for the
LECS, click on the Show TLVs pushbutton. This displays the TLV Configuration
panel shown in Figure 63 on page 136.

v To display the configuration of the LES, click on the LES Configuration pushbutton.
This displays the LES Configuration panel shown in Figure 58 on page 129.

v To display the policy details of a LES, select it from the list and click on the Policy
Details pushbutton. This displays the Policy Rule panel shown in Figure 65 on
page 138.

Deleting an Emulated LAN

To delete an ELAN, do the following:

Figure 56. ELAN Administration Panel
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1. Double-click the left mouse button on the Domain icon on the Broadcast Domain
panel.

2. Select the ELAN and select Delete from the context menu that is displayed when
you click the right mouse button on the ELAN icon.

3. Click on the Apply pushbutton to confirm the delete.

Figure 57 shows a sample Delete ELAN panel.

How to Manage a LAN Emulation Server

Managing a LAN Emulation Server (LES) consists of displaying the configuration of a
LES, and creating and deleting redundant LESs.

Displaying the Configuration of a LAN Emulation Server

The LES Configuration panel can be used to:

v Display the configuration of the LES

v Display the associated BUSs

v Enable and disable security and redundancy (valid for MSS servers only)

v Specify the number of control distribute VCCs

v Show the details of registered LECs. This is valid only for ATM devices supporting
the required MIB variables

v Unregister LECs

v Starting and stopping a LES instance in an ATM switch in an ATM Hub, 8265 ATM
Switch, or ATM Workgroup Switch.

To display the configuration of a LAN Emulation Server (LES) do one of the following:

1. Double-click the left mouse button on a Domain icon on the Broadcast Domain
panel.

2. On the Exploded Domain panel, double-click the left mouse button on the LES icon
or select the LES icon and select Configuration from the context menu that is
displayed when you click the right mouse button on the LES icon.

Figure 57. Delete ELAN Panel
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1. Double-click the left mouse button on a Domain icon on the Broadcast Domain
panel.

2. Select the ELAN on the Exploded Domain panel and select Administration from
the context menu that is displayed when you click the right mouse button on the
ELAN icon.

3. Select the LES in the Defined LES for LECS list and click on the LES
Configuration pushbutton.

1. On the Control View panel take one of the following actions:

v Double-click on the icon at the left of the ATM device in the list.

v Click on the icon at the left of the ATM device in the list, and select
Configuration from the context menu that is displayed when you click the right
mouse button on the ATM device icon.

2. On the LAN Emulation Configuration panel, select the LES from the list and click on
the Configuration pushbutton.

Figure 58 on page 129 shows a sample LES Configuration panel.
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LES instances are already created in ATM switches in ATM Hubs, 8265 ATM Switches,
and 8285 Nways ATM Workgroup Switches. To start or stop a LES instance, its
administrative state must be set to 'Up' or 'Down' respectively.

Figure 58. LES Configuration Panel
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To start a LES instance:

1. Specify the ELAN name.

2. Set the Max Frame Size.

3. Set the Administrative State to Up

4. Click on the Apply pushbutton.

If at first the operational state of the LES instance does not change to 'Up', retry the
operation. When the LES has started the ELAN appears on the Exploded Domain
panel.

To stop the LES instance, set the Administrative state to 'Down' and click on the Apply
pushbutton.

Creating a Redundant LAN Emulation Server

To create a redundant LES, do the following:

1. On the Exploded Domain panel, select the ELAN icon and select Administration
from the context menu that is displayed when you click the right mouse button on
the ELAN icon.

2. On the ELAN Administration panel, click on the Create Redundant LES
pushbutton.

3. Enter the LES information on the Create Redundant LES panel and click on the OK
pushbutton.

Figure 59 shows a sample Create a Redundant LES panel.

Figure 59. Create a Redundant LES Panel
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Displaying the Configuration of a Broadcast and Unknown Server

To display the configuration of a Broadcast and Unknown Server (BUS),

1. Double-click the left mouse button on a Domain icon in the Domains area on the
Broadcast Domain panel.

2. On the Exploded Domain panel, double-click the left mouse button on the BUS icon
or select the BUS and select Configuration from the context menu displayed when
you click the right mouse button on the BUS icon.

1. On the Control View panel take one of the following actions:

v Double-click on the icon at the left of the ATM device in the list.

v Click on the icon at the left of the ATM device in the list, and select
Configuration from the context menu that is displayed when you click the right
mouse button on the ATM device icon.

2. On the LAN Emulation Configuration panel, select the BUS from the list and click on
the Configuration pushbutton.

Figure 60 on page 132 shows a sample BUS Configuration panel.
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BUS instances are already created in ATM switches in ATM Hubs, 8265 ATM Switches,
and 8285 Nways ATM Workgroup Switches.

To start or stop a BUS instance, its administrative state must be set to 'Up' or 'Down'
respectively.

To start a BUS instance:

1. Specify the ELAN name.

2. Set the Max Frame Size.

Figure 60. BUS Configuration Panel
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3. Set the Administrative State to Up

4. Click on the Apply pushbutton.

If at first the operational state of the BUS instance does not change to 'Up', retry the
operation. When the BUS has started the ELAN appears on the Exploded Domain
panel.

To stop the BUS instance, set the Administrative state to 'Down' and click on the Apply
pushbutton.

Important: To allow you to display statistics for BUSs, you must specify a sample rate
and set the BUS Monitor to On.

To enable Broadcast Manager for the selected BUS (in MSS server only), click on the
BCM pushbutton. This displays the BCM Configuration panel, where you can specify
the configuration of the Broadcast Manager.

A sample BCM Configuration panel is shown in Figure 61 on page 134.
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How to manage a LAN Emulation Configuration Server

Managing a LAN Emulation Configuration Server (LECS) consists of creating and
deleting policing profiles, creating and deleting policy values, and performing
administration on ELANs in the domain.

Note: Creating a domain creates a LECS instance, and deleting a domain deletes a
LECS instance.

Displaying the Configuration of a LAN Emulation Configuration Server

The LAN Emulation Configuration Server panel can be displayed in one of the following
ways:

v From the Exploded Domain panel:

1. Double-click the left mouse button on the Domain icon on the Broadcast Domain
panel.

Figure 61. BCM Configuration Panel
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2. On the Exploded Domain panel, double-click the left mouse button on the primary
or redundant LECS icon, or select the LECS icon and select Configuration from
the context menu that is displayed when you click the right mouse button on the
ATM device icon.

v From the Exploded ELAN panel:

1. Double-click the left mouse button on the Domain icon on the VLAN Domain
View panel.

2. Double-click the left mouse button on the ELAN icon on the Exploded Domain
panel.

3. On the Exploded Domain panel, double-click the left mouse button on the primary
or redundant LECS icon, or select the LECS icon and select Configuration from
the context menu that is displayed when you click the right mouse button on the
ATM device icon.

Figure 62 shows a sample LECS Configuration panel.

Figure 62. LECS Configuration Panel
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Displaying the Configuration of Type, Length, and Value (TLV) Parameters

To display the configuration of the type, length, and value (TLV) parameters for the
LECS associated with an ELAN:

1. Select the ELAN from the ELAN list and click on the Administration pushbutton.

2. On the ELAN Administration panel (see Figure 56 on page 126), click on the Show
TLV pushbutton.

Figure 63 shows a sample ELAN Administration panel.

Creating a Policing Profile

A policy is used by a LECS when a LEC asks for registration. The LECS finds the
ELAN it will become a member of using the LEC registration parameters.

To create a policing profile for a LECS, do the following:

1. Double-click the left mouse button on the Domain icon on the Broadcast Domain
panel.

2. On the Exploded Domain panel, double-click the left mouse button on the LECS
icon or select the LECS and select Configuration from the context menu that is
displayed when you click the right mouse button on the LECS icon.

3. Click on the Create pushbutton in the Policing Profile section on the LECS
Configuration panel.

The following policy types are available:

v By LAN Type

v By MAC Address

v By ELAN Name

v By Route Descriptor

v By ATM Address

v By Packet Size.

For each policy used, a LECS tries to find a value defined for an ELAN that matches
the LEC parameters.

Figure 63. TLV Configuration Panel
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Note: Changing the policing profile for a LECS can lead to domain inconsistency, that
is, this could prevent some LECSs from joining their previous target ELAN.

Figure 64 shows a sample Create Policy panel.

Displaying the Details of a Policy

You can display the details of a policy from the ELAN Administration panel shown in
Figure 56 on page 126.

To display the policy details, select the LES from the list of LESs defined in LECS on
the ELAN Administration panel and click on the Policy Details pushbutton.

A sample Policy Rule panel is shown in Figure 65 on page 138.

Figure 64. Create Policy Panel
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To display the configuration of a policing profile, select the profile from the list and click
on the Show pushbutton. You can also display the Policy Configuration panel after an
ELAN has been created, by clicking on the Configure Policy pushbutton on the Create
ELAN panel. See “Creating an Emulated LAN” on page 122.

The Policy Configuration panel can be used to:

v Save policy values to a file

v Load policy values from a file

v Add an ELAN entry to the policy

v Delete an ELAN entry from a policy

A sample Policy Configuration panel is shown in Figure 66 on page 139.

Figure 65. Policy Rule Panel
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To load policy values from a file, the file must have the following format, which is the
format the save to file function uses:

v Each comment line must start with a # character.

v Each policy value line must have the format

policy name policy value 1 policy value 2

where policy name can be one or a mixture of the following:

ByAtmAddr Policy value 1 is the ATM address, and policy
value 2 is the ATM address mask.

ByMacAddr Policy value 1 is the MAC address. Policy value 2
is not used.

ByRouteDescriptor Policy value 1 is the Segment ID, and policy
value 2 is the bridge number.

ByElanName Policy value 1 is the ELAN name. Policy value 2
is not used.

ByPktSize Policy value 1 is the maximum frame size. Policy
value 2 is not used.

Here are two examples:

Figure 66. Policy Configuration Panel
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Example 1

# Policy configuration file for:
# - ELAN: MoveLec2
# - And policy: ByAtmAddr
ByAtmAddr 39.99.99.99.99.99.99.00.00.99.99.03.02.60.00.00.00.87.17.01
FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF

Example 2

# Policy configuration file for:
# - ELAN: MoveLec2
ByAtmAddr 39.99.99.99.99.99.99.00.00.99.99.03.02.60.00.00.00.87.17.01
FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF.FF
ByMacAddr 01.02.05.04.08.09
ByMacAddr 01.02.05.04.08.AA
ByRouteDescriptor 0 1
ByRouteDescriptor 10 5
ByElanName Titi
ByElanName Toto
ByPktSize 1516
ByPktSize 9234

Deleting a Policing Profile

To delete a policing profile for a LECS, do the following:

1. On the Exploded Domain panel, double-click the left mouse button on the LECS
icon or select the LECS icon and select Configuration from the context menu that
is displayed when you click the right mouse button on the LECS icon.

2. Select the policing profile in the Policing Profile list on the LECS Configuration panel
and click on the Delete pushbutton in the Policing Profile section on the LECS
Configuration panel.

3. Click on the OK pushbutton to confirm the delete.

Using the Control View

The Control View panel displays a list of all ATM devices that are being used and those
that can be used for LAN emulation. This allows you to estimate the load of any ATM
device in the network. You can filter the list by clicking on the Filter pushbutton and
selecting one of the following filter options:

v ALL Boxes

v LECS

v LES
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v BUS

v Proxy LECs

The number of instances of LECSs, LESs, BUSs, and LECs active on each ATM device
is displayed as well as the number of LECs registered to the LESs active on a ATM
device. Figure 67 shows a sample Control View panel.

To display the configuration of a LAN emulation component in the ATM device, take one
of the following actions:

v Double-click on the icon at the left of the ATM device in the list.

v Click on the icon at the left of the ATM device in the list, and select Configuration
from the context menu that is displayed when you click the right mouse button on the
ATM device icon.

This displays the LAN Emulation Configuration panel shown in Figure 69 on page 147.

Figure 67. Control View Panel
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Moving a LEC from One ELAN to Another

You can move a LEC from one ELAN to another by drag and drop. To do this, do the
following:

1. On the Exploded Domain panel, double-click on the icon of the ELAN from which
the LEC is to be moved.

2. On the Exploded ELAN panel, click the middle mouse button on the LEC icon and
drag it to and drop it on the target ELAN icon on the Exploded Domain panel.

The Move LEC panel is displayed which allows you to specify to reset the LEC
immediately or at the LEC restart.

Figure 68 shows a sample Move LEC panel.

Navigating Between Applications

When using the LAN Emulation Manager you can navigate between the ATM view, LAN
Network Manager (LNM) view, and the BOX (HubManager) view.

Note: The Nways Element Manager application (including LNM) must be installed to
enable navigation between the LNM and BOX views.

Figure 68. Move LEC Panel
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Displaying the Campus Manager-ATM View

You can display the ATM view of the ATM device containing the LAN emulation
components. The ATM device is shown highlighted on the ATM Device submap.

You can display the ATM view in any of the following ways:

v From the Exploded Domain panel:

1. Double-click on a Domain icon on the LAN Emulation panel.

2. On the Exploded Domain panel, select a LECS icon and click on the ATM View
pushbutton on the toolbar or select Open View -> ATM View from the context
menu displayed when you click the right mouse button on the LECS icon.

v From the Exploded ELAN panel:

1. Double-click on a Domain icon on the LAN Emulation panel.

2. Double-click on a ELAN icon on the Exploded Domain panel.

3. On the Exploded ELAN panel, select a LECS, LES, BUS, or LEC icon and click
on the ATM View pushbutton on the toolbar or select Open View -> ATM View
from the context menu that is displayed when you click the right mouse button on
the icon.

Displaying the LAN Network Manager View

You can display the LAN Network Manager (LNM) view to display the ATM device
containing the LAN emulation components. The ATM device is highlighted in the LNM
view.

This is valid only when the ATM device containing the instance of a LAN emulation
component is an 8281 ATM LAN Bridge or an MSS server with bridge enabled.

You can display the LNM view in any of the following ways:

v From the Exploded Domain panel:

To switch to the LNM view do the following:

1. Double-click on a Domain icon on the LAN Emulation panel.

2. Do one of the following on the Exploded Domain panel:

– Select a LECS, LES, BUS, or LEC icon and click on the LAN View
pushbutton on the toolbar or select Open View -> LNM View from the context
menu displayed when you click the right mouse button on the icon.

– Select an ELAN icon and do one of the following:

- Select Open View -> LNM View from the context menu displayed when
you click the right mouse button on the ELAN icon.

- Click on the LAN View pushbutton on the toolbar.

v From the Exploded ELAN panel:

To display the LNM View, do the following:

1. Double-click on a Domain icon on the LAN Emulation panel.

2. Double-click on a ELAN icon on the Exploded Domain panel.
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3. Do one of the following on the Exploded ELAN panel:

– Select a LECS or BUS icon and select Open View -> LNM View from the
context menu displayed when you click the right mouse button on the LECS
icon.

– Select a LECS or BUS icon and click on the LAN View pushbutton on the
toolbar.

Displaying the Device View

You can display the Device view in any of the following ways:

v From the Exploded Domain panel:

To display the Device view, do the following:

1. Double-click on a Domain icon on the LAN Emulation panel.

2. Do one of the following on the Exploded Domain panel:

– Select a LECS icon and select Open View -> Device View from the context
menu displayed when you click the right mouse button on the LECS icon.

– Select a LECS icon and click on the Device View pushbutton on the toolbar.

v From the Exploded ELAN panel:

To display the Device View, do the following:

1. Double-click on a Domain icon on the LAN Emulation panel.

2. Double-click on a ELAN icon on the Exploded Domain panel.

3. Do one of the following on the Exploded ELAN panel:

– Select a LECS, LES, LEC, or BUS icon and select Open View -> Device
View from the context menu displayed when you click the right mouse button
on the icon.

– Select a LECS, LES, LEC, or BUS icon and click on the Device View
pushbutton on the toolbar.

Displaying the LAN Emulation Manager from the LAN Network Manager

ATM devices containing LAN emulation components are shown in the LAN Network
Submap and LAN Subnet Submap connected to the VLANs icon. See the books “User
Interface” and “Coupling and Autodiscovery” in the online documentation for Nways
Element Manager, for details about using the LAN Network Manager component.

You can switch to LAN Emulation Manager in one of the following ways:

v From the LAN Network Submap:

Do one of the following:

– Double-click on the VLANs icon.

– Select CMA -> LAN Emulation from the context menu displayed when you click
the right mouse button on the VLANs icon.

v From the LNM Subnet submap

Do the following:

1. Double-click on the ATM bridge icon on the LNM Network submap
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2. On the LNM Subnet submap, select the VLANs icon and select CMA -> LAN
Emulation from the context menu displayed when you click the right mouse
button on the VLANs icon.

Displaying the LAN Emulation Manager from the HubManager Box View

ATM devices containing LAN emulation components are shown in the box view
connected to the VLAns icon. See the chapters “User Interface” and “Coupling and
Autodiscovery” in the online documentation for Nways Element Manager for details
about using the HubManager component.

To switch to LAN Emulation Manager, do the following:

1. Double-click on the ATM device in the box view.

2. Double-click on the VLANs icon or select the icon and select CMA -> LAN
Emulation from the context menu that is displayed when you click the right mouse
button on the VLANs icon.

Displaying the LAN Emulation Components in an ATM Device

The LAN emulation components configured on an ATM device are displayed on the
LAN Emulation Configuration panel.

The LAN Emulation Configuration panel can be displayed in any of the following ways:

v Select an ATM device in the ATM Device submap and select CMA -> LAN
Emulation from the menu bar or the context menu that is displayed when you click
the right mouse button on the ATM device.

v When the Configuration panel for the ATM device is open, select Navigation - >
LAN Emulation from the menu bar.

v Select ATM View -> LAN Emulation on the ATM View panel. To open the ATM View
panel do one of the following in the ATM Device submap:

– Double-click on the ATM device icon.

– Select the ATM device icon, and select CMA-> Open ATM View from the menu
bar or the context menu that is displayed when you click the right mouse button
on an ATM device icon.

v On the ATM View panel, select ATM Node -> LAN Emulation or double-click on the
LAN emulation icon in the ATM Node Status section of the panel.

v On the Control View panel double-click on the icon at the left of the ATM device in
the list, or click on the icon and select Configuration from the context menu that is
displayed when you click the right mouse button on the ATM device icon.

LES and BUS instances that are not active are shown as not ready. To start a LES or
BUS instance:

1. Click on the LES or BUS in the list, and click on the Configuration pushbutton.

2. On the appropriate Configuration panel, set the administrative state to Up.
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For further information, see “Displaying the Configuration of a LAN Emulation Server”
on page 127 and “Displaying the Configuration of a Broadcast and Unknown Server”
on page 131.

Note: An individual LAN Emulation Configuration panel is opened for each selected
ATM device on which LAN emulation components are supported. However, if the
panel has been opened for an ATM device which has no associated object in
ObjectStore (that is, no instances exist) and you then select an ATM device
which has an associated object in ObjectStore, no new panel will be displayed.
In this case, the existing opened panel is updated with the LAN emulation
configuration for the selected ATM device.

Figure 69 on page 147 shows a sample LAN Emulation Configuration panel.
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Figure 69. LAN Emulation Configuration Panel
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Chapter 10. Locating Network Resources

This chapter describes the search and locate functions provided by Nways
Manager-ATM.

Using the Search Function

The search function allows you to locate a user or workstation connected to a network
using a variety of search criteria. You can then use the search results to diagnose and
solve problems in network communication. For example, when there are network
problems concerning TCP/IP devices, you can use the Search function to display the IP
addresses of the devices, the corresponding MAC addresses, and the port on the hub
to which each device is attached. From the Search panel, you can open the Hub Level
view and troubleshoot the problem using the Configuration and Statistics functions.

The Search panel can be displayed in any of the following ways:

v By selecting NwaysCampus -> Search on from the menu bar of NetView for AIX or
HP OpenView Windows submaps.

v From any of the following LAN Emulation panels by selecting Control -> Search
from the menu bar, or by clicking on the Search icon on the toolbar.

– LAN Emulation

– Exploded Domain

– Exploded ELAN

Figure 70 on page 150 shows a sample Search panel.
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Selecting the Search Criteria

The type of search criteria can be specified by selecting values in the Search for By
fields. The search criteria you can specify are:

v User information

To search for user information, select User and one of the following:

– Name

– First name

– Address

– Location (office number, building, and so on)

– Miscellaneous parameters that you enter as a text string

v Station or device information

To search for station or device information, select Station / Device and one of the
following:

– Address

Figure 70. Search Panel
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To search for LAN stations, enter a MAC address in the text field; for ATM
stations, enter the 6-byte End System Identifier (ESI) of an ATM address. To
search for LEC stations, enter the 6-byte End System Identifier (ESI) and the
1-byte Selector of an ATM address.

– Address type

For example, to search for all LEC stations you can enter LEC as the search
criteria.

– IP address

– ATM address

– Host name (logical name associated with the IP address)

– Location (office number, building, and so on)

– Wiring information (where station is connected to the wiring closet)

– Group (name of work group that you define, for example, Development,
Accounting, Sales)

– Function (for example, workstation, bridge LEC, LES, router)

– ELAN (for ATM stations, the logical name of an ELAN)

– Polling information:

- Last poll older than (number of days)

- Last poll within (number of days)

– MAC displayed inverted-lists all stations that have been configured with the
Inverted Display Mode flag set to Yes. This flag toggles the display of the station’s
MAC address from canonical to non-canonical, or from non-canonical to canonical
format.

– Miscellaneous parameters that you enter as a text string.

v ATM interface

To search for an ATM interface, select Port / Interface and one of the following:

You can use SMIT to specify whether or not external stations are to be shown.

– Identifier-The format is: ATM_Device_Label interface_index

– Type of box (for example, ATM Hub, 8265 ATM Switch, ATM Workgroup Switch,
ATM bridge).

– Physical segment (to which the port or interface is assigned).

– Logical segment (the logical name assigned to the physical segment).

– Delete flag YES-searches for ports and interfaces that have the Delete flag set to
Yes. This happens when a hub is removed from the IBM Hubs Topology or when
a module is removed from a hub.

Information on the object is kept in the search database until you manually delete
it. This allows the information to be reported in search results. For information on
how to delete a database object, see “Maintaining Information in the Search
Database” on page 153.

– Delete flag NO-searches for all ports and interfaces that are connected to the
network.
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– Freeze connection YES - searches for ports and interfaces that have the Freeze
flag set to Yes. When this flag is set to Yes, the list of stations connected to the
port is frozen and is not updated.

This is useful when, for example, a bridge is connected to a port and reports all
connected stations as also being physically connected to the port. To avoid having
all connected stations appear in the search results and to have only the MAC
address of the ATM bridge, do the following:

1. Select the line on which the port appears in the search results and click on the
Port / Interface pushbutton.

2. Select Yes in the Freeze Connection field.

3. In the Connections Stations field, erase the MAC addresses of all stations
connected to the ATM bridge and leave only the MAC addresses of the ATM
bridge.

4. Click on the Apply pushbutton.

– Freeze connection NO-searches for all ports and interfaces that have the Freeze
flag set to No.

– Miscellaneous parameters that you enter as a text string.

When you have set the search parameters, enter the search text string to be used,
including wildcard characters (*). You can enter text in the following ways:

v Type it in the field.

v Cut and paste the string using the mouse.

To start the search, click on the Search pushbutton. All objects that meet the specified
search criteria are displayed in the search results.

One of the following parameters appears to the left of each station address and
represents the address type:

v MAC for the MAC address of LAN stations

v ESI for the ESI part of the ATM address of ATM stations

v LEC for the ESI.SELECTOR part of the ATM address of LEC stations

v N/A for ATM stations whose address is not known.

To refresh the search results, click on the Refresh pushbutton. If the same search
results are displayed, this means that device has not been polled since the last time
you performed a search. Wait until the next polling is done and try again.

Using Search Results

You can perform the following operations on the search results:

v Sort the order in which the columns of search results are displayed. To do this, click
on the Sort By pushbutton and field and select the type of information.

v Display more information about one of the users or stations in the search results. To
do this, select the line on which the user or station appears and click on the Port /
Interface , Station , or User pushbutton.
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To modify any of the information about the user or station that is stored in the search
database:

1. Enter a new value in any of the read-write fields in the dialog box.

2. Click on the Apply pushbutton.

v Open the Hub Level view in which an ATM device is displayed, or the ATM View in
which an ATM interface is displayed. To do this, select the port (or interface) and
click on the Show pushbutton.

v Display the Exploded ELAN panel for the ATM station in which an ELAN resides. To
do this, select the station and click on the Show ELAN pushbutton.

v Open a Telnet session and log on to a module. To do this, select the module and
click on the Telnet pushbutton.

v To ping a module and open an Emulator window that shows the ping taking place,
select the module and click on the Ping pushbutton.

Maintaining Information in the Search Database

You can maintain the objects in the search database in the following ways:

v Create and delete user entries.

v Create and delete station entries.

v Delete interface entries.

v Update the database from a formatted file.

v Save the contents of the database to a formatted file.

Creating and Deleting User Entries

To create a new user in the search database:

1. Open the Search panel.

2. Select Administer -> Create New User from the menu bar. The User Information
panel is displayed.
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3. Enter values in the fields. Do not leave blank spaces.

When entering a user name, be sure to enter a unique value. If necessary, enter the
first initial of the first name to distinguish users. For example, to create entries for
two users called Bill Smith and Dick Smith, you could enter Smith_B and Smith_D.

4. Click on the Apply pushbutton.

5. Click on the Yes pushbutton to confirm. This creates a new user in the search
database.

To delete a user from the search database:

1. Open the Search panel.

2. In the search results, click on the user to want to delete. Click on the Select All
pushbutton to select all users in the search results.

3. From the menu bar, select Administer -> Delete Selected Users from Database .

4. Click on the Yes pushbutton to confirm.

Creating and Deleting Station Entries

To create a new station in the search database:

1. Open the Search panel.

2. Select Administer -> Create New Station from the menu bar. The Station
Information panel is displayed.

Figure 71. User Information in Search Database
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3. Enter values in the fields. Do not leave blank spaces. To get help, click on a field to
display information in the Description box.

4. Click on the Apply pushbutton.

5. Click on the Yes pushbutton to confirm. This creates a new station in the search
database.

To delete a station from the search database:

1. Open the Search panel.

2. In the search results, click on the station you want to delete. To delete all stations in
the results list, click on the Select All pushbutton.

3. From the menu bar, select Administer -> Delete Selected Stations from
Database .

4. Click on the Yes pushbutton to confirm.

Deleting Interface Entries

To delete an interface from the search database:

1. Open the Search panel.

Figure 72. Station Information in Search Database
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2. In the Search Results list, click on the interface you want to delete. To delete all
interface entries in the results list, click on the Select All pushbutton.

3. From the menu bar, select Administer -> Delete Selected Interfaces from
Database .

4. Click on the Yes pushbutton to confirm.

Updating the Search Database from a Formatted File

Sometimes you may want to update the search database with data stored in a server
file (such as /etc/hosts), a phone directory, or another database. To do so, you must
translate the data into the syntax recognized by the search database. You can then use
the file containing the formatted data to update the search database.

To prepare the formatted file, enter data about users, stations, and ports (interfaces)
using the following grammar:

USER
NAME "Durand"
FIRSTNAME "Pierre"
TELEPHONE "(01) 99.99.99.99"
ADDRESS "18 rue Rivoli Paris-France"
LOCATION "B1 1N23 PARIS"
MISC "Development Manager"
MACLIST "420202020202 "
;

STATION
MACADDRESS "420202020202"
ATMADDRESS "010203040506070809101112131415161718192021"
IPADDRESS "9.100.108.97"
HOSTNAME "server1"
WIRE "C1 YZ234"
LOCATION "B1 1N23 PARIS"
GROUP "Development"
FUNCTION "Server"
DOMAIN "LAN3"
MISC "AIX Version 4.1.4"
;

INTERFACE
IDENTIFIER "9.100.107.10 S07 P01"
TYPE "8260"
MACLIST "002035E10CD1 "
MISC "Development hub"
;

To update the search database from the formatted file:

1. Open the Search panel.

2. From the menu bar, select Administer -> Update database from formatted file .

3. In the Filter field, enter all or part of the pathname of the directory where the file is
stored. Click on the Filter pushbutton.
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4. In the Directories box, click on the directory.

5. In the Files box, click on the file name.

6. Click on the Update database from file pushbutton.

Making a Backup of the Search Database

Sometimes you may want to make a backup of the search database or edit it by
removing old data and making global changes to existing data. To do so, copy the
search database to a file. Then if you want to modify any of the data in the search
database, you will need to:

1. Edit the file as needed using a standard text editor.

2. Reload the database using the file as described in “Updating the Search Database
from a Formatted File” on page 156.

To copy the search database to a file:

1. From the Search panel, select Administer -> Save Database to File .

2. In the Filter field, enter all or part of the pathname of the file. Click on the Filter
pushbutton.

3. In the Directories box, click on the directory.

4. Enter the name of the file in which you want to save the search database.

5. Click on the Save database to file pushbutton.

You can edit the file and use it to update the search database.

Printing the Contents of the Search Database

To print the contents of the Search database, follow these steps:

1. Open the Search panel.

2. Select File -> Print Command from the menu bar.

3. Enter the print command you want to use. Click on the OK pushbutton to confirm.

4. Select File -> Print from the menu bar.

Using the Locate Function

The locate function allows you to find a specific network device that is managed by
Nways Manager-ATM or Nways Element Manager. The located device is displayed in
the IP Internet submap.

The Locate function is useful when it is difficult to find the device you want to manage,
because there are to many network objects displayed (for example, in the ATM Device
submap) and the IP address of the ATM device is too small to read. The Locate
function is similar to the NetView for AIX or HP OpenView Windows Locate function,
except that it only functions for ATM devices managed by Nways applications.
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To use the Locate function:

1. Select NwaysCampus -> Locate from the menu bar of the Root submap, ATM
Campus submap, or ATM Device submap.

A sample Nways Device Inventory panel is shown in Figure 73.

2. On the Nways Device Inventory panel:

a. Select either IP Address or Host Name for the type of list criteria. The host
name is the logical name associated with the IP address.

b. Enter the text string to be used in uppercase or lowercase. The text field is not
case-sensitive and wildcard characters (*) can be used. You can enter the text in
any of the following ways:

v Type it in the field.

v Cut and paste the string using the mouse.

v Use drag and drop. For example, you can drag the text from a Configuration
panel and drop it in the field.

3. Click on the Go pushbutton. All ATM devices meeting the locate citeria are listed in
the Results box.

Figure 73. Nways Device Inventry Panel
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4. Select the ATM device you want to locate and click on the Locate pusbutton. The IP
Internet submap is displayed with the the ATM device highlighted.
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Chapter 11. Managing Changes

When required, the microcode of the ATM Agent can be upgraded by downloading a
new version to the ATM switch.

The microcode is downloaded in a flash RAM. It does not override the operational code
until the node is reset.

Downloading Microcode

The download function allows you to simultaneously save and restore the configuration
of ATM switches using configuration files and to download code updates for ATM
devices from the end-user interface or via a flat file using a single command. The
Download panel is displayed in one of the following ways:

v By selecting one or more ATM switches, ATM Workgroup Switches, ATM
concentrators, or ATM bridges in the ATM Device submap and selecting CMA ->
Download from the menu bar or from the context menu that is displayed when you
click the right mouse button on any of the selected devices.

v Selecting CMA -> Download from the context menu that is displayed when you click
the right mouse button on an icon on the ATM View panel. To display the ATM View
panel, do one of the following in the ATM Device submap:

– Double-click on the ATM switch icon.

– Select the ATM switch icon, and choose CMA -> Open ATM View from the menu
bar or from the context menu that is displayed when you click the right mouse
button on the ATM switch icon

Note: If several devices are selected, they must be of the same type, for example, all
ATM switches.

If no ATM device is selected, you can load ATM devices from a flat file which is
customizable. This flat file must have the form: one IP address by line (and all IP
addresses of same ATM kind), such as the SeedFile of NetView.

Figure 74 on page 162 shows a sample Download panel.
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Swapping Code

To make your downloaded microcode active, you must swap the current version of
microcode with the downloaded microcode (backup version) in the flash. After the swap,
an automatic reset is performed and the downloaded microcode is copied to the RAM.

To initiate a swap, on the Download panel select the one or several devices whose
microcode is to be swapped and click on the Swap pushbutton.

Figure 74. Download Panel
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Chapter 12. Managing Events

How to Display Events

The Nways Manager-ATM program’s Events application displays events detected by
NetView for AIX or HP OpenView Windows, by Nways Manager-ATM, or by both.

Events are messages about what is happening on the network and are sent to Nways
Manager-ATM by ATM agents. Conditions that cause an event to be generated include:

v An ATM device is showing inconsistent or unexpected behavior.

v The status of an ATM device changed in some way (for example, from up to down).

v The configuration of an ATM device changed (for example, a new interface or
connection has been added to or deleted from the network).

Displaying Events

Nways Manager-ATM provides two ways to display event information.

1. Display events in a card format.

This is the default method. The card format displays complete information about an
event. Event cards are a convenient way to display important information about
what is happening on the network. Each event card has a window that contains the
following information about an event:

v Date and time the event occurred.

v Name of the ATM device generating the event.

v Which part of Nways Manager-ATM or the network sent the event.

v A summary description of the event.

v A more detailed description of the event.

v A description of the device as obtained from the device MIBs and the NetView for
AIX or HP OpenView Windows object database.

v The severity assigned to the event.

v Notes.

2. Display events in a list.

The event list format provides a summary of events and contains the following
information:

v Date and time the event occurred.

v Name of the ATM device generating the event.

v Which part of Nways Manager-ATM or the network sent the event.

v Description of the event.

Note: When you select CMA -> Events from the NetView for AIX or HP OpenView
Windows menu bar or from the context menu that is displayed when you click
the right mouse button on an object and:
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v The workspace is not already open, two windows are displayed:

– One for all general events

– One with filtering done on the selected object.

v The workspace is already open, the window specific to the selected object is
displayed.

When you select File -> Exit from the menu bar of the general events window all the
other open event windows are also closed.

The events received are saved in a log file. You can use the NetView for AIX or HP
OpenView Windows program’s Event History application to display events from the log
file. This application displays logged events for a selected ATM network device.

Understanding Traps

Some of the events listed in the event list (see Figure 75) are directly received from the
ATM switch (SNMP traps). The following traps are generated by the ATM agent:

v Generic traps. These are standard traps defined in SNMP:

– Coldstart-Sent by the ATM switch at power-on or after a reset.

– LinkUp-Sent by the ATM switch when one of its interfaces becomes operational.
The criterion used to show an interface as operational depends on the type of
interface:

- A UNI-type interface is considered operational when ILMI polling is
acknowledged by the remote device attached to this interface.

- An SSI-type interface is considered to be operational when switch-to-switch
polling across this interface is acknowledged by the switches.

- An NNI-type interface is considered operational when physical activity is
detected (the physical layer is up) from the remote device attached to this
interface.

Figure 75. Faults Display Panel
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– LinkDown-Sent by the ATM switch when one of its interfaces is no longer up.

– AuthenticationFailure - Sent when authentication (invalid community name, IP
Address, or access mode) failed on SNMP messages received by the ATM switch
ATM agent.

v ATM switch-specific traps:

– Hello-Sent every time the ATM switch re-initializes (power-on or reset). It is sent
once each minute until the node is polled or for 255 minutes. It is automatically
restarted if no activity is detected for six hours. This allows the discovery
mechanism to be speeded up on the network management stations. It is also sent
(once only) when one of the IP configuration parameters of the node changes (IP
address, subnet mask, default gateway IP address, or IP ARP server ATM
address).

– Lock Trap-Sent when the ATM switch receives a request to disable a port or
isolate a module, and the request is received on the same port and module.

– Change Trap-Sent by the ATM switch when one of its main configuration
parameters is altered: the date and time, system parameters (name, contact, or
location), or administrative state of an interface (enabled or disabled) or a module
(isolated or attached).

– ModuleUp-Sent by the ATM switch when a new ATM module is detected by the
ATM switch (new module inserted).

– ModuleDown-Sent by the ATM switch when an ATM module is no longer detected
by the ATM Switch module (module removed).

– pvcFailure trap-Sent by the ATM switch when a PVC created in this node
becomes inoperational.

– callLogOverflow-Sent by the ATM switch when the log of completed calls is about
to wrap.

How to Use Traces and Dumps

Traces and dumps are facilities provided for servicing the ATM switch. Related panels
are obtained from the Switch Configuration panel.

Displaying the Trace and Dump Status

For troubleshooting purposes, it is possible to trace and dump the microcode of the
Control Point in the 8260 ATM Control Point and Switch and an 8285 Nways ATM
Workgroup Switch.

To display the traces and dumps:

1. Double-click on the ATM Campus icon in the Root submap.

2. Double-click on an icon in the ATM Campus submap.

3. Select an ATM switch in the ATM Device submap.

4. Select CMA -> Configuration from the menu bar or the context menu that is
displayed when you click the right mouse button on an ATM switch icon in the ATM
Device submap.
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5. Select Services -> Trace and Dumps from the menu bar of the ATM switch
Configuration panel.

A panel, similar to that shown in Figure 76, is displayed.

Figure 76. Traces and Dumps Panel
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Starting and Stopping Traces

When a trace is active, trace messages are stored in a flat (ASCII) file in the ATM
switch. The file can be retrieved using Trivial File Transfer Protocol (TFTP).

Traces can be interpreted by IBM Service Support and should be taken only when
requested by IBM Service Support.

Traces are started and stopped from the Trace and Dump panel (similar to that shown
in Figure 76 on page 166) which is accessed when you:

1. Double-click on the ATM Campus icon in the Root Submap.

2. Double-click on an icon in the ATM Campus Submap.

3. Select an ATM switch in the ATM Device submap.

4. Select CMA -> Configuration from the menu bar or from the context menu that is
displayed when you click the right mouse button on an ATM device icon in the ATM
Device submap.

5. Select Services -> Trace and Dumps from the menu bar of the ATM switch
Configuration panel.

The traces can be started and stopped by setting the value of the Trace Control to On
and selecting active for the type of trace to be taken. Click on the Apply pushbutton to
start the trace.

Taking Program Dumps

When dumps are taken, the requested microcode is stored in a flat (ASCII) file in the
ATM switch. This file can be retrieved using Trivial File Transfer Protocol (TFTP).

Dumps can be interpreted by IBM Service Support and should be taken only when
requested by IBM Service Support.

Dumps are started from the Trace and Dump panel (similar to that shown in Figure 76
on page 166) which is accessed when you:

1. Double-click on the ATM Campus icon in the Root Submap.

2. Double-click on an icon in the ATM Campus Submap.

3. Select an ATM switch in the ATM Device submap.

4. Select CMA -> Configuration from the menu bar or from the context menu that is
displayed when you click the right mouse button on an ATM switch icon in the ATM
Device submap.

5. Select Services -> Trace and Dumps from the menu bar of the ATM switch
Configuration panel.
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Transferring Files

To initiate file transfer:

1. Double-click on the ATM Campus icon in the Root Submap.

2. Double-click on an icon in the ATM Campus Submap.

3. Select an ATM switch in the ATM Device submap.

4. Select CMA -> Configuration from the menu bar or from the context menu that is
displayed when you click the right mouse button on an ATM switch icon in the ATM
Device submap.

5. Select Services -> File Transfer from the menu bar of the ATM switch
Configuration panel.

A panel, similar to that shown in Figure 77 on page 170, is displayed.

6. Set the Action field to Download and enter a file name, a file type, and a server IP
Address. Then click on the Apply pushbutton.

File transfer requires configuring the ATM switch with parameters such as the address
of the file server and the name of the file to be transferred. These parameters, along
with the date and status of the last file transfer are kept in the ATM switch and can be
displayed at any time. When the address of the file server, or the name of the file to be
transferred, is changed, the date and status of the last file transfer are reset.

Note: When the Trivial File Transfer Protocol (TFTP) is not active on the file server, the
Download result is no-response-from-host .

Configuring AIX for TFTP Inband Download

You can use the following to configure AIX for TFTP inband download if the Download
function is not available.

1. Check the /etc/inetd.conf file in AIX and make sure that the TFTP line is not
commented out.

2. Start the TFTP subserver using the following commands:

a. smit

b. Processes & Subsystems

c. Subservers

d. Start a Subserver

Select TFTP from the list. The command is startsrc -t’tftp’

You must be a root user to be able to do this.

Displaying Information on the File Transfer

Files can be transferred both ways between the ATM switch and a file server:

v File transfer from the ATM switch is used to retrieve error logs, or trace or dump files
(file upload).
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v File transfer to the ATM switch can be used to upgrade the ATM switch microcode
(code download). However, it is recommended that microcode be downloaded using
the Download panel, which allows you to download microcode from one or several
devices simultaneously. Refer to the chapter titled “Managing ATM Resources”.

File transfer requires configuring the ATM switch with parameters such as the address
of the file server and the name of the file to be transferred. These parameters, along
with the date and status of the last file transfer are kept in the ATM switch and can be
displayed at any time. When the address of the file server or the name of the file to be
transferred is changed, the date and status of the last file transfer are reset.

To initiate file transfer:

1. Double-click on the ATM Campus icon in the Root Submap.

2. Double-click on an icon in the ATM Campus Submap.

3. Select an ATM switch in the ATM Device submap.

4. Select CMA -> Configuration from the menu bar or from the context menu that is
displayed when you click the right mouse button on an ATM switch icon in the ATM
Device submap.

5. Select Services -> File Transfer from the menu bar of the ATM switch
Configuration panel.

A panel, similar to that shown in Figure 77 on page 170, is displayed.
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Note: When TFTP is not active on the file server, the Download result is
no-response-from-host .

See “Configuring AIX for TFTP Inband Download” on page 168 for details on
transferring files if the Download function is not available.

Figure 77. File Transfer Panel
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Uploading Error Logs, Traces, and Dumps

Error logs, trace information, and dumps can be uploaded from the ATM switch to a file
server.

The error log file is stored permanently in the ATM switch. The trace and dump files are
flat (ASCII) files filled with the last traces started and the latest dumps taken. These
files are empty if no traces and dumps have been done.

File transfer is initiated from the File Transfer Panel (see Figure 77 on page 170) when
you:

1. Double-click on the ATM Campus icon in the Root Submap.

2. Double-click on an icon in the ATM Campus Submap.

3. Select an ATM switch in the ATM Device submap.

4. Select CMA -> Configuration from the menu bar or from the context menu that is
displayed when you click the right mouse button on an ATM device icon in the ATM
Device submap.

5. Select Services -> File Transfer from the menu bar of the ATM switch
Configuration panel.

Set the Action field to Upload and configure the ATM switch with the following
parameters for the file transfer:

v Server IP Address-The address of the file server.

v File Name-The name of the file to be transferred.

v File Type-The type of file to be transferred.

Note: Files must be uploaded to a directory where the user 'nobody' has write access.

Initiate the file transfer by clicking on the Apply pushbutton. The status of the file
transfer is displayed in the panel.

LAN Emulation Manager Fault Management

Fault management consists of the detection, analysis, correction of problems caused by
the failure of network elements.

LES Fault Management

LES fault management consists of isolating problems within servers, clients, or both and
analyzing and correcting the problem on the suspected instance or device. This applies
only when the LES is in an MSS server.

To display faults, the value for Administrative State panel must be set to Enable .

To display the LES Fault Management panel:
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1. Double-click the left mouse button on the Domain icon on the LAN Emulation panel.

2. Select the LES and select Fault from the context menu displayed when you click
the right mouse button on the LES icon.

BUS Fault Management

BUS fault management consists of isolating, analyzing, and correcting problems
between LECS instances, LECS devices, and LECs using the LECSs. This applies only
when the BUS is in an MSS server.

To display faults, the value for Administrative State must be set to Enable .

To display the BUS Fault Management panel:

1. Double-click the left mouse button on the Domain icon on the LAN Emulation panel.

2. Select the BUS and select Fault from the context menu displayed when you click
the right mouse button on the BUS icon.

Figure 78 shows a sample BUS Fault Management panel.

Figure 78. BUS Fault Management Panel
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LECS Fault Management

LECS fault management consists of isolating, analyzing, and correcting problems
between LECS instances, LECS devices, and LECs using the LECSs.

To display faults, the value for Administrative State must be set to Enable .

To display the LECS Fault Management panel:

1. Double-click the left mouse button on the Domain icon on the LAN Emulation panel.

2. Select the LECS and select Fault from the context menu displayed when you click
the right mouse button on the LECS icon.

Figure 79 shows a sample LECS Fault Management panel.

Figure 79. LECS Fault Management Panel

Chapter 12. Managing Events 173



174 Nways Manager-ATM User’s Guide



Part 4. Displaying Statistics
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Chapter 13. Displaying Statistics

Using the statistics facilities of Nways Manager-ATM, it is possible to collect and
graphically display statistical data about critical resources of an ATM device. The
Statistics Selection panel allows you to select the statistical information.

You can display the Statistics Selection panel in one of the following ways:

v From the Interface Configuration panel:

1. Double-click on the ATM Campus icon in the Root Submap.

2. Double-click on the ATM Cluster or Peer Group icon in the ATM Campus
submap.

3. Select the ATM device in the ATM Device submap and select CMA ->
Configuration from the menu bar or from the context menu that is displayed
when you click the right mouse button on the ATM device icon.

4. On the configuration panel for the ATM device, select an interface from the list of
interfaces and click on the Configuration pushbutton.

5. On the Interface Configuration panel, select Navigation -> Statistics from the
menu bar.

v From the ATM View panel:

1. Open the ATM View panel in one of the following ways:

– Double-click on the ATM device icon in the ATM Device submap.

– Select the ATM device icon, and select CMA -> Open ATM View from the
menu bar or from the context menu that is displayed when you click the right
mouse button on the ATM device icon

2. On the configuration panel for the ATM device, select an interface from the list of
interfaces and click on the Configuration pushbutton.

3. On the Interface Configuration panel, select Navigation -> Statistics from the
menu bar.

v From the LAN Emulation Manager:

1. Start the LAN Emulation Manager by doing one of the following:

– Double-click the left mouse button on the VLANs icon in the Root submap.

– Select Navigatio n - > LAN Emulation on any Campus Manager - ATM
end-user interface panel.

– Select an ATM device in the ATM Device submap and select CMA -> LAN
Emulation from the menu bar or from the context menu that is displayed
when you click the right mouse button on the ATM device.

2. On either the LAN Emulation, Exploded Domain, or ELAN Administration panel,
click on the Statistics pushbutton on the toolbar.

Note: You can also select an icon on any panel and select Statistics from the
context menu that is displayed when you click the right mouse button on
the icon.
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Figure 80 shows a sample Statistics Selection panel.

On the panel, you can:

v Select one of the categories in the Category option menu.

Important: The BUS Monitor must be enabled for statistics to be displayed for BUS
categories. On the BUS Configuration panel, set the BUS Monitor to On
and specify the sample rate.

v Select one or more of the counters available for that category in the Counters field.
By default, all available counters are selected; to deselect a counter, click on its
name in the list.

v Change the units (cells, bytes, or bits)

v Enter some indexes that are required to gain access to the category counts. For
example, if you select the option ATM Saal, you must specify the signaling channel
VPI and VCI. By default, the application will use 0 and 5 respectively.

v Change the polling interval (minimum is 5 seconds).

v Specify the directory and filename of the log file.

v Specify whether to log the results in a file.

If this field is set to Off, the results are not saved and are shown only on the screen.

Figure 80. Statistics Selection Panel
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After you have entered parameters in the Statistics Selection panel, click on the Apply
pushbutton to close the panel and display the Statistics Display panel. Figure 81 shows
a sample Statistics Display panel.

On the Statistics Display panel, you can:

v Select the following types of values to be displayed in the list of statistics:

Current Current values

Marker Values pointed to by the marker (available if the display is a plot
display).

Peak Peak values since the beginning of the polling or from the last
reset.

Reset Resets the peak values.

Note: The marker is shown in the graphic area, only for specific categories, when
there is a plot display. It is a red vertical line that you can move by clicking the
mouse at the position where you want the marker to appear. If the marker is
outside of the plotted area, the values are filled by *********.

v Select the type of display:

– Plot (available only for some categories)

– Bar

– Pie

Figure 81. Statistics Display Panel
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Note: If you select the Pie display type but all values are equal to zero, the
graphic area on the right remains empty.

v Invert the display for plot or bar display.

v Print the panel.

v Call the Control panel.

On the right of the Statistics Selection panel, a plot, bar, or pie graph is displayed. The
terms used on the vertical axis have the following meanings:

Units The real values of the MIB variables.

Units/PollInt The difference in the values of the MIB variables between two polls.

Units/s The difference in the values of the MIB variables between two polls,
divided by the polling interval value.

% The percentage of use according to media capacity, or for Power
Budget, according to power availability.

At the same time, the Statistics Control panel is displayed (see Figure 82 on page 181).
This panel gives you a list of all the statistics that you have already started. When you
have selected a statistics entry, you can use the:

v Stop pushbutton to stop the polling of the selected statistic. The Statistics Display
panel is frozen.

v Restart pushbutton to continue polling the selected statistic. The contents of the
Statistics Display panel are cleared and new values are displayed.

v Front pushbutton to bring the associated Statistics Display panel to the foreground.

v Modify pushbutton to modify the parameters for the selected statistic. The Statistics
Attributes panel (see Figure 83 on page 182) is displayed.

v Delete pushbutton to delete the associated Statistics Display panel.

When you click the Exit pushbutton at the bottom of the panel, a confirmation dialog
box is displayed before all the statistics panels are deleted.
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Multiple requests for statistics can be started on different resources and will display
separate display panels for each resource.

Note: Multiple requests for the same resource and category will result in any existing
panel being brought to the front.

Specifying Statistics Attributes

The Statistics Attributes panel (see Figure 83 on page 182) is displayed when you click
on the Modify pushbutton in the Statistics Control panel. You can modify the following
parameters in this panel:

v Polling Interval

v File Logging:

– You can enter a new directory or file

– You can specify whether or not to activate file logging.

Figure 82. Statistics Control Panel
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Printing Statistics Information

The graphic part of the contents of the Statistics Display panel can be printed by
clicking on the Print Graph button.

The Statistics Print panel, as shown in Figure 84 on page 183, is displayed allowing you
to set the destination. If you do not specify a printer, the default printer is used.

Figure 83. Statistics Attributes Panel
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Replaying Statistics Information

Note: This section applies only to AIX.

Data that has been collected and that you have requested to be logged can be viewed
(played back) at any time.

The replay is similar to real-time graphing except that only the plot display is available
and the Print pushbutton is not available.

You can monitor multiple sets of data which have been recorded in the same log file.

A Zoom function expands a selected part of the displayed graph.

The replay can be started from SMIT as follows:

1. Select Campus Manager SMIT from the Administer pull-down menu.

2. Select Statistics on the SMIT main menu.

3. Select Replay .

Figure 84. Statistics Print Panel
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4. Enter the name of the file in the filename field. You can also click on the List
pushbutton and select the file from the list. Click on the OK pushbutton.

5. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Replay can be stopped by clicking on the Close pushbutton in the replay window.

Statistics Categories

The following tables list the categories for each resource and the counters for each
category. Not all devices implement all counters.

Depending on the resources available, the counters can be enabled or disabled as
required. For example, the BUS Monitor must be enabled for BUS_TOP_N_Contributors
counters.

Table 1. Statistics Categories: ATM Bridge

ATM_Bridge_Traffic

Table 1. Statistics Categories: ATM Bridge

Received_cells The accumulated number of ATM cells received
on this UNI which were assigned and not
dropped.

Dropped_received_cells The accumulated number of ATM cells which
were dropped for the reasons defined in section
4.4.4.2.

Transmitted_cells The accumulated number of assigned ATM
cells which were transmitted across this
interface.

Table 2. Statistics Categories: ATM Switch, ATM Concentrator, ATM Device

ATM_Traffic

Table 2. Statistics Categories: ATM Switch, ATM Concentrator, ATM Device

ifInUcastPkts The number of subnetwork-unicast packets
delivered to a higher-layer protocol.

ifInErrors The number of inbound packets that contained
errors preventing them from being deliverable
to a higher-layer protocol.

ifInUnknownProtos The number of packets received via the
interface which were discarded because of an
unknown or unsupported protocol.

ifOutUcastPkts The total number of packets that higher-level
protocols requested be transmitted to a
subnetwork-unicast address, including those
that were discarded or not sent.

Table 3. Statistics Categories: ATM Switch

ATM_Bandwidth
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Table 3. Statistics Categories: ATM Switch

Allocated_bandwidth For a UNI or a NNI port: the bandwidth, in bits
per second, currently used by the reserved
bandwidth connections on this port. For a SSI
port: the bandwidth, in bits per second,
currently reserved on this port.

Available_bandwidth For a UNI or a NNI port: the current bandwidth
available for the reserved bandwidth
connections on this port. For a SSI port: the
current bandwidth available on this port. It is in
bits per second.

Media_speed The speed of this interface, in bits per second.

Table 3. Statistics Categories: ATM Switch

ATM_Q2931_Errors

Table 3. Statistics Categories: ATM Switch

Out_call_attempts This is the number of outgoing call attempts on
this interface, including accepted as well as
rejected calls.

Out_call_failures This is the number of outgoing calls that were
cleared for a reason other than a DTE or
operator initiated action.

In_call_attempts This is the number of incoming call attempts on
this interface, including accepted as well as
rejected calls.

In_call_failures This is the number of calls that were rejected
by the receiver.

Table 3. Statistics Categories: ATM Switch

ATM_Q2931_Calls

Table 3. Statistics Categories: ATM Switch

In_call_in_progress This is the current number of incoming calls in
progress on this interface.

Out_call_in_progress This is the current number of outgoing calls in
progress on this interface.

Table 3. Statistics Categories: ATM Switch

ATM_Saal

Table 3. Statistics Categories: ATM Switch

Unexpect_pdus Error conditions A to M, as defined in the
Q.2110 Specification. This is the number of
received unsolicited or or inappropriate PDUs.

Unsuccess_pdus Error condition O as defined in the Q.2110
Specification. This is the number of failing
retries.
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Table 3. Statistics Categories: ATM Switch (continued)

Failed_establish Error condition P as defined in the Q.2110
Specification. This is the number of failing polls.

Table 4. Statistics Categories: LECS

LECS_Generic_Errors

Table 4. Statistics Categories: LECS

config_requests_OK The number of CONFIGURE requests
successfully granted since the agent was last
initialized.

insufficient_resources The number of CONFIGURE requests rejected
due to the insufficient resources to grant
request error.

access_denied The number of CONFIGURE requests rejected
due to the access denied error.

Table 4. Statistics Categories: LECS

LECS_Bad_Requests_Errors

Table 4. Statistics Categories: LECS

config_requests_OK The number of CONFIGURE requests
successfully granted since the agent was last
initialized.

bad_frames The number of malformed CONFIGURE
requests dropped by the LECS.

invalid_parameters The number of CONFIGURE requests rejected
due to the invalid request parameters error.

invalid_request_id The number of CONFIGURE requests rejected
due to the invalid requester-id error.

invalid_destination The number of CONFIGURE requests rejected
due to the invalid destination error.

invalid_ATM_address The number of CONFIGURE requests rejected
due to the invalid ATM address error.

Table 4. Statistics Categories: LECS

LECS_Undefined_Configuration_Errors

Table 4. Statistics Categories: LECS

config_requests_OK The number of CONFIGURE requests
successfully granted since the agent was last
initialized.

no_configuration The number of CONFIGURE requests rejected
due to the LE Client is not recognized error.

insufficient_info The number of CONFIGURE requests rejected
due to the insufficient information error.

configuration_error The number of CONFIGURE requests rejected
due to the LE_CONFIGURE error.
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Table 5. Statistics Categories: LES

LES_Traffic

Table 5. Statistics Categories: LES

total_join_OK Number of successful Join responses sent out
by the LAN Emulation Server.

total_ARP_in_req The total number of LE_ARP_REQUEST
frames the LES has accepted since its last
initialization.

total_ARP_forward_req The number of LE_ARP_REQUESTs that the
LES forwarded onto the clients (either via the
control distribute or individually over each
control direct) rather than answering directly.
This may be due to implementation decision
(forward all requests) or because the resolution
to the request did not reside in the LES’s LE
ARP cache.

insufficient_resources Number of insufficient resources to grant errors.
All the errors for Join and Register are included
in this counter.

access_denied Number of access denied for security reasons
errors. All the errors for Join and Register are
included in this counter.

Table 5. Statistics Categories: LES

LES_Network_Configuration_Errors

Table 5. Statistics Categories: LES

total_join_OK Number of successful Join responses sent out
by the LAN Emulation Server.

total_ARP_in_req The total number of LE_ARP_REQUEST
frames the LES has accepted since its last
initialization.

duplicate_LAN_dest Number of duplicate LAN destination errors. All
the errors for Join and Register are included in
this counter.

duplicate_ATM_address Number of duplicate ATM address errors. All
the errors for Join and Register are included in
this counter.

version_not_supported Number of version not supported errors. All the
errors for Join, Register, and Unregistered are
included in this counter.

Table 5. Statistics Categories: LES

LES_Device_Configuration_Errors

Table 5. Statistics Categories: LES

total_join_OK Number of successful Join responses sent out
by the LAN Emulation Server.
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Table 5. Statistics Categories: LES (continued)

total_ARP_in_req The total number of LE_ARP_REQUEST
frames the LES has accepted since its last
initialization.

invalid_request_param Number of invalid request parameters errors. All
the errors for Join, Register, and Unregistered
are included in this counter.

invalid_request_id Number of invalid LEC ID errors. All the errors
for Join, Register, and Unregister are included
in this counter.

bad_packets Number of mal formed ATM ARP requests
received by the LES.

Table 6. Statistics Categories: BUS and BCM

BUS_Traffic

Table 6. Statistics Categories: BUS and BCM

in_unicast_frames The number of frames that the BUS has
received which were unicast data frames
including all control frames (i.e. they were
flooded from the client).

in_multicast_frames The number of frames that the BUS has
received which were multicast frames.

discarded_frames The number of frames discarded due to
resource error.

Table 6. Statistics Categories: BUS and BCM

BUS_Errors

Table 6. Statistics Categories: BUS and BCM

in_unicast_frames The number of frames that the BUS has
received which were unicast data frames
including all control frames (i.e. they were
flooded from the client).

in_multicast_frames The number of frames that the BUS has
received which were multicast frames.

dropped_for_time_out The number of frames dropped by the BUS due
to time out.

refused_VCC_requests The number of multicast send VCC request the
BUS has refused for any reason from clients.

unsuccessfull_VCC_req The number of multicast forward VCC requests
has refused by the LEC for any reasons from
this BUS.

Table 6. Statistics Categories: BUS and BCM

BUS_TOP_N_Contributors
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Table 6. Statistics Categories: BUS and BCM

Frames Number of frames sampled from this host
during last complete sample interval.

Table 7. Statistics Categories: BCM

BCM_Traffic

Table 7. Statistics Categories: BCM

frames_received Total number of frames received by BCM for all
protocols.

frames_returned Total number of frames, for all protocols, not
managed by BCM and returned to BUS for
transmission.

frames_discarded Total number of frames discarded (filtered) by
BCM for all protocols.

frames_transmitted Total number of frames transmitted by BCM for
all protocols.

frames_in_error Total number of frames, for all protocols, that
the BCM could not sent due to an error.

Table 8. Statistics Categories: BCM_IP Traffic

BCM_IP_Traffic

Table 8. Statistics Categories: BCM_IP Traffic

frames_received Total number of IP frames received by BCM.

frames_returned Total number of IP frames not managed by
BCM and returned to BUS for transmission.

frames_discarded Total number of IP frames discarded (filtered)
by BCM.

frames_transmitted Total number of IP frames transmitted by BCM.

frames_in_error Total number of IP frames the BCM could not
could not send due to some error.

Table 9. Statistics Categories: IPX Traffic

BCM_IPX_Traffic

Table 9. Statistics Categories: IPX Traffic

frames_received Total number of IPX frames received by BCM.

frames_returned Total number of IPX frames not managed by
BCM and returned to BUS for transmission.

frames_discarded Total number of IPX frames discarded (filtered )
by BCM.

frames_transmitted Total number of IPX frames transmitted by
BCM.

frames_in_error Total number of IPX frames the BCM could not
send due to some error
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Table 10. Statistics Categories: BCM NetBios Traffic

BCM_NetBIOS_Traffic

Table 10. Statistics Categories: BCM NetBios Traffic

frames_received Total number of NetBIOS frames received by
BCM.

frames_returned Total number of NetBIOS frames not managed
by BCM and returned to BUS for transmission.

frames_discarded Total number of NetBIOS frames discarded
(filtered) by BCM.

frames_transmitted Total number of NetBIOS frames transmitted by
BCM.

frames_in_error Total number of NetBIOS frames the BCM
could not send due to some error.

Table 11. Statistics Categories: LEC

LEC_Traffic

Table 11. Statistics Categories: LEC

unicast_frames_in The number of subnetwork-unicast packets
delivered to a higher-layer protocol.

multicast_frames_in The number of non-unicast (i.e., subnetwork-
broadcast or subnetwork-multicast) packets
delivered to a higher-layer protocol.

unicast_frames_out The total number of packets that higher-level
protocols requested be transmitted to a
subnetwork-unicast address, including those
that were discarded or not sent.

multicast_frames_out The total number of packets that higher-level
protocols requested be transmitted to a non-
unicast (i.e., a subnetwork-broadcast or
subnetwork-multicast) address, including those
that were discarded or not sent.

frames_discarded The number of inbound packets which were
chosen to be discarded even though no errors
had been detected to prevent their being
deliverable to a higher-layer protocol. One
possible reason for discarding such a packet
could be to free up buffer space.

frames_in_error The number of inbound packets that contained
errors preventing them from being deliverable
to a higher-layer protocol.

frames_forwarded_by_BUS Number of Multicast, Broadcast and Unknown
Forward requests forwarded by the BUS from
this LEC. The value of this object indicate how
many requests have been forwarded by the
BUS.
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Table 11. Statistics Categories: LEC (continued)

frames_received_by_LES Number of requests received from this LEC.
This includes all control frames as well as
LE-ARP requests.

frames_forwarded_by_LES Number of requests or responses sent to the
LEC entry from this LES. This number includes
NARP requests, Topology Change requests and
LE-ARP responses.

Displaying the Load of an ATM Subsystem

The ATM Monitor Panel displays an overview of the load of a selected ATM subsystem
(ATM switch and ATM ports) as shown in Figure 85 on page 192.

To display the ATM Monitor Panel:

1. Double-click on the ATM Campus icon in the Root Submap.

2. Double-click on a ATM Cluster or Peer Group icon in the ATM Campus Submap.

3. Select an ATM device in the ATM Device submap.

4. Select CMA -> Monitor from the menu bar or from the context menu that is
displayed when you click the right mouse button on an ATM device icon in the ATM
Device submap.
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Monitoring is automatic but three selection modes are available:

1. Top 5 In Traffic-The total load for the ATM Switch is monitored as well as the five
ports that receive the most traffic.

2. Top 5 Out Traffic-The total load for the ATM Switch is monitored as well as the five
ports that transmit the most traffic.

Figure 85. ATM Monitoring Panel
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3. User Drag and Drop-The total load of the ATM Switch is monitored and you can
additionally select:

v Which ports to monitor

v Which counter to display for a given port.

User Drag and Drop mode allows you to press the middle mouse button while the
cursor is over an ATM interface (ATM port) listed on the ATM Node Configuration Panel,
and drag the selected object into the Drop Area at the bottom of the ATM Monitor
Panel. The available counters for the selected port are displayed in the Drop Area. Drag
the counters to be monitored from the Drop Area into the Monitoring Area to start
monitoring.

Note: The counter text is grayed out when the counter is being retrieved or the counter
value is not significant (for example, when the port is disabled).

The polling interval for this panel can be adjusted by selecting a value from the
drop-down list that is displayed when you click on the Polling Interval pushbutton.

Drag a port or a counter from the Monitoring Area to the Trash basket at the bottom
right of the ATM Monitoring Panel to stop monitoring the selected object.
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Chapter 14. Using FaultBuster

The following describes how to use FaultBuster to diagnose status and connectivity
problems. Diagnosis is done by calling recursively the FaultBuster panel on
subresources, higher level resources or related resources. This mechanism is referred
to as the investigation path.

To reselect FaultBuster on another resource on the FaultBuster panel, double-click on
the corresponding icon or select it on the selection area and click on the Apply
pushbutton.

FaultBuster provides many links to ATM Manager, LAN Emulation Manager, NetView or
system functions. FaultBuster can also be customized (in a configuration file) to add
your own diagnostics or tools.

Note: When using FaultBuster, it is recommended that you select connection
persistence. See the online book Administration, which explains how to use
SMIT to select this option.

Investigating the Reason for the Status of a Resource

To investigate the reason for the status of an ATM resource, do any of the following:

v From a submap, select the ATM device and select CMA -> FaultBuster from the
menu bar or from the context menu that is displayed when you click the right mouse
button on the ATM device icon.

If you do not select an ATM device, and select CMA -> FaultBuster from the menu
bar the FaultBuster Selection panel is displayed where you can provide information
about the ATM device you want to investigate the status of.

v From a LAN Emulation Manager panel, select the LAN emulation device and select
Navigation -> FaultBuster from the menu bar.

v From an ATM Manager panel:

1. Select Navigation -> FaultBuster from the menu bar.

2. On the FaultBuster Selection panel, select the type of device using the Type
option pushbutton and enter its identity in the required fields.

The FaultBuster panel shown in Figure 86 on page 199 is displayed.

Investigating Connectivity Problems

To investigate connectivity problems, do any of the following:,

v From a submap, select CMA -> FaultBuster from the menu bar

v From an ATM Manager or LAN Emulation Manager panel, select Navigation ->
FaultBuster from the menu bar
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The FaultBuster Selection panel is displayed. On the FaultBuster Selection panel:

1. Click on the Connectivity pushbutton

2. Select the type of resources whose connectivity you want checked, using the Type
option pushbuttons.

3. Enter the identity of the resources in the corresponding fields.

4. Click on the OK pushbutton.

The FaultBuster panel shown in Figure 86 on page 199 is displayed.

The FaultBuster Panel

For both symptoms (for status and connectivity), the FaultBuster panel displays the
selected resource (both resources in case of a connectivity problem) within the
investigation context. This resource (or resources) is represented along with other
resources that may be related to the problem. For example, ATM devices are
represented with their management station. Interfaces are represented with the device
that houses the interface, including the remote interface and remote device. A LES is
represented with the device that houses this LES, the interface that this LES is using to
access the Network, the ELAN and LANE domain it belongs to, and so on.

This investigation context provides a first investigation path from a selected resource to
related resources.

Directly associated with the investigation context, FaultBuster displays all the reasons
for the status of the selected resource. All the resources that participate actively to the
status of the selected resource are listed with their own status. To display the status of
related resources, click on the corresponding icons within the investigation context. The
reasons for status provide the second investigation path (resource to subresource). Also
associated with the investigation context, FaultBuster proposes a list of investigation
actions (listed in the Investigation are). Each time an Action is selected, a description of
the action appears in the bottom part of the panel, and a list of possible choices is
proposed in the Selection area. The Action/Selection areas provide the third
investigation path (resource to subresources). In addition, the Action/Selection areas
provide links to ATM Manager, LAN Emulation Manager, NetView, System and user
functions whenever it is needed.

FaultBuster keeps track of all investigation contexts in the History area. To return to a
previous context, select the corresponding icon in the History Area.

A sample FaultBuster panel is shown in Figure 86 on page 199.
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Figure 86. FaultBuster Panel
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Chapter 15. Troubleshooting

The following provides troubleshooting information.

Error in NetView for AIX or HP OpenView Windows Log

One type of error is logged in the NetView for AIX or HP OpenView Windows log as a
message with one of the following forms:

v Internal program error number: xxxx. Line llll of file ffff

v Internal program error number: xxxx. P1: yyy Line llll of file ffff

v Internal program error number: xxxx. P1: yyy P2: zzz ... Line llll of file ffff

The error number (xxxx) is given in the errors listed in the following with an explanation
related to the error.

Line llll or File fff is the line number and file name where the error was detected.

The other parameters and their values may help in determining what the problem is.

All this information must be reported to IBM Service Support. The errors are as follows:

Application exit:
1 Fatal error. ATMC Manager is exited.
2 Impossible to clean OVwDb/GTM from topology objects. ATMC Manager is exited.
3 Impossible to create OVwDb/GTM with topology objects. ATMC Manager is exited.
4 Unable to communicate with ovspmd. ATMC Manager is exited.
5 Unable to Connect to OvwDatabase. ATMC Manager is exited.
6 Unable to initialize GtmDatabase. ATMC Manager is exited.

10 No existing NLS reference.
11 No matching for name: P1.
12 No matching for OID: P1.
13 P1.tbl syntax error.
14 Value: P1 is not in the range allowed for the MIB variable: P2.
15 Unable to open the file: P1.

20 Internal error. No process killed.
21 Unknown error P1.

30 Unregistered menu P1. Check registration file.
31 Field Id not found in OVW database. Check registration file.

40 NV6000 API P1 failed. Reason: P2.
41 Unable to open fault panel for IP address: P1. Reason: P2.

50 OVW database problem.
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Application exit:
51 OVW field missing. Run ovw -fields, then check P1 field presence.
52 ahmtopod process not present. Check ahmtopod is running.
53 Unable to Connect to OvwDatabase.
60 Panel help access problem. Reinstall?
61 Registration file corrupted.

70 PVC creation problem. Check ATM agent MIB level. Check only one NMS tries to create a PVC
at a time. PVC handler can be rebooting. Retry later.

80 SNMP session problem. IP address: P1. Check community, Check level of microcode.
81 Unable to open an SNMP session with IP Address: P1.

90 Load font error.
91 Unable to open catalog file P1.

100 Unable to write file P1. Check permissions.
101 Unable to remove file P1, return code=P2. Check permissions.
102 Unable to read file P1. Check permissions.

Nways Manager-ATM—Specific Problems

The following provides information on Nways Manager-ATM—specific problems.

What to Do if an ATM Campus Icon Status Remains Blue

If the color of the ATM Campus icon remains blue, even though some ATM devices
have been discovered in the IP Internet topology, clear the ATM topology, then stop and
restart the cmld daemon.

For information on clearing the ATM topology and starting and stopping daemons, see
the online book Administration.

What to Do if an ATM Device Does Not Appear in the ATM Topology

If an ATM device does not appear in the ATM topology, check that:

1. The cmld , cmldiscd , and ahmtopod daemons are running. You can do this by:

a. Entering the ovstatus command.

b. Restarting the daemons if they are not running. For information on starting
daemons, see the online book Administration.

2. The IP address of the ATM device is defined in the NetView seed file and the ATM
device appears in the IPMap submap. If the ATM device is displayed in the IPMap
submap and not in an ATM Cluster or Peer Group do the following:

Check whether a filter file exists (/usr/CML/data/cml.discovery.filter) and whether
the IP address of the ATM device, is defined in this filter file. If not, add the IP
address of the ATM device to the filter file and stop and restart the cmld
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daemon. For information on defining ATM devices in the filter file and stopping
and starting daemons, see the online book Administration.

3. Check the NetView for AIX or HP OpenView Windows log to see if the following
message appears:

"Not completed merge process for ATM Node xxxx IP Address xxxx."

If it does:

a. Delete the ATM device object specified in the message from all submaps.

b. Ping the IP address to rediscover the ATM device.

LES ATM Address Not Updated After Changing the ATM Address of an ATM
Switch

After changing the ATM address of the ATM switch the LES is connected to, all ELANs
and LESs managed by the LECS have the status ”unknown" (blue). The LES ATM
addresses in the LESconftable are updated, but not in the ElanLesconftable.

In this case, the LES representation of the LES (that is, the elanLesAtmAddress) is not
updated. This means that no LEC can connect to this LES because the associated ATM
address is incorrect (true only for LECs using the LECS).

When you configure the LES (lesAtmAddrActual) you do not specify the network prefix,
just the ESI and Selector via T6. For SNMP, you can specify the network prefix, but it is
not required because the ATM switch’s network prefix is used. In the case of the ELAN
definition, you must configure the LES ATM address for the ELAN, which could be
anywhere in the network. If you change the location of the LES, you must change the
ELAN configuration, which is resident where the LECS is located and not necessarily
where the LES is located.

To rectify this, either change the elanLesAtmAddress using the MIB browser
(recommended), or delete the ELAN and re-create it.
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Part 6. Administration
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Chapter 16. Using SMIT or the Command Line for Administration

The following describes how to do various administration tasks. using SMIT or SAM.
You must be logged in as a root user to carry out any of the tasks.

Note: All references to SMIT apply only to the AIX platform.

Changing the Default Polling Interval

By default, the polling interval is 10 minutes. To change the default polling interval, do
the following:

1. Select Campus Manager SMIT from the Administer pull-down menu in the NetView
for AIX Root submap.

2. In SMIT, select Configure -> Campus Manager - ATM configuration -> Set the
default polling interval .

3. Enter the default polling interval in minutes in the Polling Interval field and click on
the OK pushbutton.

4. On the confirmation panel, click on the OK pushbutton.

5. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Changing the LAN Emulation Polling Policy

By default, the polling policy is automatic. You can obtain a different polling policy on
request. To do this, do the following:

1. Select Campus Manager SMIT from the Administer pull-down menu in the NetView
for AIX Root submap.

2. In SMIT, select Configure -> Campus Manager - ATM configuration -> Set LAN
Emulation polling policy .

3. Set the value in the Polling Policy field to On Request. You can also click on the
List pushbutton and select On Request from the list. Click on the OK pushbutton.

4. On the confirmation panel, click on the OK pushbutton.

5. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Deregistering the ahmtopod Daemon from the cmld Startup File

To stop ahmtopod from being automatically started at the same time as the NetView
for AIX daemons, delete the ahmtopod daemon from the NetView for AIX cmld startup
file, by doing the following:

1. Select Campus Manager SMIT from the Administer pull-down menu in the NetView
for AIX Root submap.

2. In SMIT, select Configure -> Nways Campus Manager general configuration ->
Capabilities to be started when Nways Campus Manager starts .
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3. Change the value in the Campus Manager - ATM capability field to No and click
on the OK pushbutton.

4. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Registering the ahmtopod Daemon in the cmld Startup File

To ensure that ahmtopod is automatically started at the same time as the NetView for
AIX daemons, add the ahmtopod daemon to the NetView for AIX cmld startup file, by
doing the following:

1. Select Campus Manager SMIT from the Administer pull-down menu in the NetView
for AIX Root submap.

2. In SMIT, select Configure -> Nways Campus Manager general configuration ->
Capabilities to be started when Nways Campus Manager starts .

3. Change the value in the Campus Manager - ATM capability field to Yes and click
on the OK pushbutton.

4. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Starting the ahmtopod Daemon

If the ahmtopod daemon has been stopped and you want to restart it, then enter the
following command on the AIX or HP-UX command line:

cmlstart ahmtopod

Stopping the ahmtopod Daemon

To stop the ahmtopod daemon enter the command

cmlstop ahmtopod

at the AIX or HP-UX command line.

Note: After stopping the ahmtopod daemon, the ATM and LAN Emulation topology
represents the topology that was built before the cmlstop command was issued
(that is, the topologies are no longer updated).

Displaying ahmtopod Daemon Status

To display the status of the ahmtopod daemon, enter the command

cmlstatus ahmtopod

at the AIX or HP-UX command line. The status can also be displayed by using SMIT by
doing the following:

1. Select Campus Manager - SMIT from the Administer pull-down menu in the
NetView for AIX Root Submap.
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2. In SMIT, select Diagnose -> Display Nways Campus Manager general status

3. Select Exit SMIT from the Exit pull-down menu.

Starting the cmld Daemon

To start the cmld daemon, do one of the following:

v From the AIX or HP-UX command line, enter the command:

/usr/OV/bin/ovstart cmld

The status can also be checked on NetView for AIX using SMIT. Access SMIT and
complete the following actions:

v Access SMIT from the AIX command line and execute the following steps:

1. Select Communications Applications and Services -> Nways Campus
Manager -> Control -> Start cmld daemon

2. When the action is completed, select Exit SMIT from the Exit pull-down menu.

v Access SMIT from the NetView for AIX Root Submap and execute the following
steps:

1. Select Administer -> Campus Manager SMIT from the menu bar.

2. In SMIT, select Control -> Start cmld daemon

3. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Stopping the cmld Daemon

To stop the cmld daemon, do one of the following:

v From the AIX or HP-UX command line, enter the command:

/usr/OV/bin/ovstop cmld

The status can also be checked on NetView for AIX using SMIT. Access SMIT and
complete the following actions:

v Access SMIT from the AIX command line, and select Communications
Applications and Services -> Nways Campus Manager -> Control -> Stop cmld
daemon .

v Access SMIT fron the AIX Root submap, and complete the following steps:

1. Select Administer -> Campus Manager SMIT from the menu bar.

2. In SMIT, select Control -> Stop cmld daemon

Checking the Status of the cmld Daemon

To check the status of the cmld daemon, do one of the following:

v From the AIX or HP-UX command line, enter the command:

/usr/OV/bin/ovstatus cmld

Chapter 16. Using SMIT or the Command Line for Administration 209



The status can also be checked on NetView for AIX using SMIT. Access SMIT and
complete the following actions:

v Access SMIT from the AIX command line, and select Communications
Applications and Services -> Nways Campus Manager -> Diagnose -> Display
Nways Campus Manager general status .

v Access SMIT from the AIX Root submap and complete the following steps::

1. Select Administer -> Campus Manager SMIT from the menu bar.

2. In SMIT or SAM, select Diagnose -> Display Nways Campus Manager general
status .

Starting the ahmclp Daemon

To start the ahmclp daemon, enter the following command:

/usr/OV/bin/ovstart ahmclp

Stopping the ahmclp Daemon

To stop the ahmclp daemon, enter the following command:

/usr/OV/bin/ovstop ahmclp

Checking the Status of the ahmclp Daemon

To check the status of the ahmclp daemon, from the AIX or HP-UX command line,
enter the command:

/usr/OV/bin/ovstatus ahmclp

The status can also be checked on NetView for AIX using SMIT. Access SMIT and
complete the following actions:

v When using NetView for AIX Version 4.0, select Communications Applications and
Services -> NetView for AIX -> Control -> Display NetView for AIX status ->
Display status of daemons

v When using NetView for AIX Version 5.0, select Communications Applications and
Services -> TME 10 NetView -> Control -> Display TME 10 NetView status->
Display status of daemons

Starting the ahmdbserver Daemon

To start the ahmdbserver daemon from the AIX or HP-UX command line, enter the
following command:

/usr/OV/bin/ovstart ahmdbserver
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Stopping the ahmdbserver Daemon

To stop the ahmdbserver daemon, enter the following command:

/usr/OV/bin/ovstop ahmdbserver

Checking the Status of the ahmdbserver Daemon

To check the status of the ahmdbserver daemon enter the command:

/usr/OV/bin/ovstatus ahmdbserver

from the AIX or HP-UX command line. The information can also be accessed on AIX
using SMIT by executing the following steps:

v When using NetView for AIX Version 4.0, access SMITfrom the command line and
select Communications Applications and Services - >NetView for AIX - >
Control -> Display NetView for AIX status -> Display status of daemons .

v When using NetView for AIX Version 5.0, access SMITfrom the command line and
select Communications Applications and Service s - > TME 10 NetView - >
Control -> Display TME 10 NetView status -> Display status of daemons .

Stopping all Campus Manager - ATM Daemons

To stop all daemons, do the following:

1. Select Campus Manager SMIT from the Administer pull-down menu in the NetView
for AIX Root Submap.

2. In SMIT or SAM, select Control -> Stopping NCMA daemons . Click on the OK
pushbutton.

3. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Restarting all Campus Manager - ATM Deamons

To restart all daemons, do the following:

1. Select Campus Manager SMIT from the Administer pull-down menu in the NetView
for AIX Root Submap.

2. In SMIT, select Control -> Starting NCMA daemons . Click on the OK pushbutton.

3. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Adding an ATM Device to the Topology

ATM devices that support AToMMIB (RFC1695) are automatically discovered by Nways
Manager-ATM. You can add devices to the ATM topology that do not support this MIB
by doing the following:
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1. Select Campus Manager SMIT from the Administer pull-down menu in the SMIT
Root Submap.

2. In SMIT, select Configure -> Nways Campus Manager general configuration ->
Add an IP address for forced discovery

3. Enter the IP address of the ATM device in the IP address or host name field and
ATM in the Agent Identifier field and click on the OK pushbutton.

4. When the action is completed, select Exit SMIT from the Exit pull-down menu.

This allows you to manage the ATM device and its ATM interface that have a MIBII
ifType equal to 37 (ATM) and 80 (logical link). If the device supports the PNNI MIB, the
topology shows all connections with neighbor devices.

Changing the Default Node Label for ATM Devices

The label for ATM devices shown in the ATM Manager submaps when Nways
Manager-ATM starts is IP Address. This can be change to the ATM ESI if required.

To change the default node label do the following:

1. Select Administer -> Campus Manager SMIT from the NetView menu bar.

2. In SMIT, select Configure -> Campus Manager - ATM Configuration -> Set the
default for node label .

3. Set the value in the Default node label format field to ATM ESI and click on the
OK pushbutton.

4. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Clearing the ATM Topology

To clear the ATM Topology, do the following:

1. Select Campus Manager SMIT from the Administer pull-down menu in the NetView
for AIX Root Submap.

2. In SMIT, select Maintain ->Campus Manager-ATM maintenance -> Clear the ATM
Topology

3. On the confirmation panel, click on the OK pushbutton.

4. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Note: After clearing the ATM topology, the ATMC and LAN Emulation icons will be
removed from the NetView for AIX root submap and the ATM topology daemon
is stopped. You must then close the NetView root submap by selecting the
File→Exit menu, then enter the command ovstop. When the command has
completed, enter the command ovstart to restart NetView.

Clearing the Statistics Files

To clear the statistics information, do the following:
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1. Select Campus Manager - SMIT from the Administer pull-down menu in the
NetView for AIX Root Submap.

2. In SMIT, select Statistics -> Remove Statistics files

3. Enter the filename of the statistics file to be removed. You can also click on the List
pushbutton and select the file from the list. Click on the OK pushbutton.

4. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Increasing Disk Space for Multiple End-user Interfaces

When starting multiple NetView for AIX or HP OpenView Windows sessions on a
management station, you may find that you cannot start more than two sessions. This
limitation is caused by insufficient disk space in the file system used to store the cache
for ObjectStore. The size of the file system must be increased by 5.5 MB for each
additional EUI that can be started.

To increase the file system, do the following:

1. In SMIT, select System Storage Management (Physical & Logical Storage) ->
File Systems -> ADD/Change/Show/Delete File Systems -> Journaled File
Systems -> Change/Show Characteristics of a Journaled File System

2. From the displayed list, select /usr/CML/OStrore/cache

3. Enter the increased size of the file system in the SIZE of file system (in 512-byte
blocks) field and click on the OK pushbutton.

Note: You must enter 11 000 (11 000 x 512 bytes = 5.5 MB) for each additional
NetView for AIX session you want to run.

4. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Changing the Persistence of Topology Objects

By default, the persistence of topology objects is set to No. This means that a broken
connection is automatically deleted. You can set the persistence of broken connections
to Yes so that all broken links can be seen. You can then delete these connections if
you want to.

To set the persitance to Yes, do the following:

1. Select Campus Manager SMIT from the Administer pull-menu menu in the Netview
for AIX Root Submap.

2. In SMIT, select Configure -> Campus Manager-ATM Configuration -> Set the
persistence of topology objects

3. Set the value in the Persistence of connections field to Yes. You can also click on
the List pushbutton and select Yes from the list. Click on the OK pushbutton.

4. On the confirmation panel, click on the OK pushbutton.

5. When the action is completed, select Exit SMIT from the Exit pull-down menu.

Chapter 16. Using SMIT or the Command Line for Administration 213



Note: You cannot change the value of peristence of interfaces. When an interface with
a connection is deleted, the connection is also deleted even if the Persistence of
connections field is set to Yes. If you want to automatically delete all broken
connections (the value of persistence of connections is set to Yes), you can set
first the value of persistence of connections to No, and then reset the value to
Yes.

Loading MIBs

Several MIBs are installed in the NetView/6000 MIB repository directory

/usr/OV/snmp_mibs/

If you need to load standard MIBs, load them in the order given here.

af-FORUM-TC.mib ATM Forum generic definitions.
af0044-LEC.mib ATM Forum LEC MIB, Version 1.
af1129-LES.mib ATM Forum LES MIB, Version 1.
af1129-BUS.mib ATM Forum BUS MIB, Version 1.
af1129-ELANLECS.mib ATM Forum ELAN/LECS MIB, Version 1.
af0055-PNNI.mib ATM Forum PNNI MIB.
af0066-SPVC.mib ATM Forum Smart PVC MIB.
af0417v40-ILMI.mib ATM Forum ILMI MIB.
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Chapter 17. Nways Manager-ATM Processes and Daemons

The following provides information on the processes and daemons used by Nways
Manager-ATM.

Processes and Daemons

The following processes and daemons are used by Nways Manager-ATM

cmld daemon

The cmld daemon is common to both Nways Manager-ATM and Nways Element
Manager. In Nways Manager-ATM, the cmld daemon makes the link between Nways
Manager-ATM and the NetView for AIX or HP OpenView Windows background
daemons. The cmld daemon is automatically started and stopped when the NetView for
AIX or HP OpenView Windows daemons are started and stopped.

cmldiscd process

The cmldiscd process is common to Nways Manager-ATM and Nways Element
Manager and is the basic topology discovery mechanism. It provides the daemons with
the LAN resources discovered by NetView for AIX or HP OpenView Windows. cmldiscd
is started and stopped when cmld is started and stopped.

ahmtopod daemon

The ahmtopod daemon is the ATM and LAN Emulation topology discovery and
maintenance daemon. It is automatically started and stopped by the cmld daemon.

cmlsm process

The cmlsm process is common to Nways Manager-ATM and Nways Element Manager.
cmlsm is the process that runs Symbols Manager. cmlsm makes the link between the
NetView for AIX or HP OpenView Windows user interface and the ahmeui process and
is automatically started and stopped when NetView for AIX or HP OpenView Windows
starts and stops.

iubsearch process

The iubsearch process is common to Nways Manager-ATM and Nways Element
Manager and is the process that provides the user interface with a repository of stations
and devices found and managed by Nways Manager-ATM and Nways Element
Manager. iubsearch is automatically started and stopped when the NetView for AIX or
HP OpenView Windows user interface is started and stopped.
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nwsstatif/iubstat processes

The nwstatif and iubstat processes are common to Nways Manager-ATM and Nways
Element Manager. They control the user interface of the Statistics application that
provides graphical information on all counters and values of resources managed by
Nways Manager-ATM and Nways Element Manager. They are automatically started and
stopped when the NetView for AIX or HP OpenView Windows user interface is started
and stopped.

ahmclp daemon

The ahmclp daemon is a Campus Manager - ATM daemon. It is used to issue SNMP
requests for some ATM panels. The ahmclp daemon is automatically started and
stopped when the NetView for AIX daemons are started and stopped.

Campus Manager - ATM Start and Stop Process

Important: If for any reason you need to stop NetView for AIX or HP OpenView
Windows daemons, IBM strongly recommends that you enter the
/usr/CML/bin/cmlovstop command instead of ovstop . The cmlovstop
command stops NetView for AIX or HP OpenView Windows and Nways
Manager-ATM daemons in a safe way so that the NetView for AIX or HP
OpenView Windows topology database maintains consistent data in all
network views.

Nways Manager-ATM is automatically started under the control of the NetView for AIX
or HP OpenView Windows program. The ahmtopod daemon is started through the
nv6000 shell script. The nv6000 shell script first executes the netnmrc shell script,
then the ovw command. The netnmrc shell script starts all the daemons registered in
the ovsuf file. Each entry in the ovsuf file is created from information in the local
registration file (.lrf) in the /usr/OV/lrf directory. There is one .lrf file for each daemon.

The cmld.lrf file is placed in the/usr/OV/lrf directory by the installation process, and the
ovsuf file is updated at the same time to reflect the startup behavior of the daemon.
The .lrf file is used to tell the ovstart command what process to start, what the
dependencies are, and what the arguments are.

The NetView for AIX or HP OpenView Windows startup file starts all the daemons
registered in the ovsuf file. However, before you start Nways Manager-ATM, you might
want to check the status of the cmld daemon and start it if necessary. You do not have
to be a root user to check the status of the cmld daemon, but you must be a root user
to start it. Use the ovstatus command or use SMIT to check the status of the cmld
daemon. Use the ovstart and ovstop commands or use SMIT to start and stop the
cmld daemon. See “cmld daemon” on page 215 for any action on the cmld daemon.
The cmld daemon automatically starts the cmldiscd and ahmtopod daemons. The
status of these daemons can be checked using the cmlstatus command.
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The end user interface parts of Nways Manager-ATM (including panels, configuration,
faults, and statistics) are started through NetView for AIX or HP OpenView Windows
icons and menu items, either in the menu bar or through context menus, at object level.
All the Nways Manager-ATM end-user interface panels are controlled by the ahmeui
process. The LAN Emulation Manager topology and end-user interface panels are
controlled by the ahmledisplay process. The statistics graphing interface is controlled
by the nwsstatif and iubstat processes. As these processes are standalone, no
information is provided through the ovstatus command.

Note: If the nvot_server daemon stops, ensure that the /var directory is not more than
70% full.
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Chapter 18. Coupling between Nways Manager-ATM and Nways
Element Manager

Important
The following chapter applies only to the AIX platform. The information contained
is not currently supported on the HP-UX platform.

The following applies only to IBM devices.

Nways Manager-ATM and Nways Element Manager can be coupled to provide full
management of the ATM modules in ATM Hubs and 8265 ATM Switches. Coupling
involves integrating the topologies used by each product.

Coupling between Nways Manager-ATM and Nways Element Manager is automatically
started when Nways Element Manager is started.

Overview of Coupling between the Two Products

When coupling is operational between Nways Manager-ATM and Nways Element
Manager, objects which appear in both topologies can be accessed from either
program.

The Nways Element Manager Hub Level view can be displayed from Nways
Manager-ATM in one of the following ways:

v From the ATM Device submap

– Select the ATM device and select CMA -> Device from the menu bar or CMA ->
Device from the context menu that is displayed when you click the right mouse
button on the ATM device icon.

v From the ATM View panel

1. Open the ATM View panel on one of the following ways:

– Click the left mouse button on the ATM device in the ATM Device submap and
select CMA -> Open ATM View from the menu bar or CMA -> Open ATM
View from the context menu that is displayed when you click the right mouse
button on the ATM device icon.

– Double click on the ATM device icon in the ATM Device submap.

2. Select the ATM device and select ATM Manager -> Open Device View from the
context menu that is displayed when you click the right mouse button on the ATM
device icon.

If the ATM Device Configuration panel appears instead of the Nways Element Manager
Hub Level View, possibly due to temporary unavailability of the hardware, retry the
operation after a short interval.
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The Nways Element Manager Hub Level View displays an expanded view of the hub
with the installed modules. Using this view, the Nways Manager-ATM functions are
accessed from the ATM option in the context menu that is displayed when you click the
right mouse button on a module or port icon.

You can expand modules shown in the Hub level view to display the Module level view
which provides specific module information plus some information about the devices
attached to the module and contains:

v A background picture of the selected module which occupies the whole window but
which does not have an icon on the top.

v Icons representing the ports belonging to the module.

These ports are the same as those shown in the unexpanded view of the module
including the same port menu structure and the same status.

v Icons representing devices (switches) that are connected to the module ports.

Note: If two ATM switch modules are located in the ATM Hub or 8265 ATM Switch, one
module being the backup for the other, only the active ATM switch module can
be expanded.

Using Nways Element Manager functions, you can manage the ATM modules displayed
in the Module Level view as follows:

v Reset the ATM module (Reset)

v Show ATM modules in the module list (Show Module)

v Highlight ATM modules connected to the network (Show Network)

v Display ATM modules in the inventory list (Show Inventory)

v Display ATM switch modules in the list of modules supporting Telnet and Ping

v Perform power management for the ATM modules

See the the online documentation for Nways Element Manager, for details about using
the Nways Element Manager application.

Decoupling the Two Products

To stop the coupling between Nways Manager-ATM and Nways Element Manager, do
the following:

1. From NetView for AIX, select Campus Manager SMIT from the Administer
pull-down menu in the NetView for AIX Root submap.

2. Select Control .

3. Select Coupling between Hub Manager and Nways Manager-ATM .

4. Set the value in the Action on coupling field to Stop.

This stops the coupling between the two products (that is, integration of the two
topologies) and the Nways Manager-ATM options on the menus for the ATM and Switch
modules in the ATM Hub, 8265 ATM Switch, or ATM Workgroup Switch can no longer
be selected.
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Recoupling the Two Products

To start the coupling between Nways Manager-ATM and Nways Element Manager, do
the following:

1. From NetView for AIX, select Campus Manager SMIT from the Administer
pull-down menu in the NetView for AIX Root submap.

2. Select Control .

3. Select Coupling between Hub Manager and Nways Manager-ATM .

4. Set the value in the Action on coupling field to Start.

This starts the coupling between the two products (that is, integration of the two
topologies) and the Nways Manager-ATM options on the menus for the ATM and Switch
modules in the ATM Hub, 8265 ATM Switch, or ATM Workgroup Switch can be selected.

Resynchronizing Coupling

If ATM and Switch modules remain blue in Nways Element Manager views because
many changes have been made in the network since the two topologies were coupled,
you may need to resynchronize the coupling between Nways Manager-ATM and Nways
Element Manager.

To resynchronize the two topologies:

1. Select Campus Manager SMIT from the Administer pull-down menu in the NetView
for AIX Root submap.

2. Select Control .

3. Select Coupling between Hub Manager and Nways Manager-ATM .

4. Set the value in the Action on coupling field to Re-sync.

Showing the Coupling Status

To show the current status of the coupling between Nways Manager-ATM and Nways
Element Manager, do one the following:

1. Select Campus Manager SMIT from the Administer pull-down menu in the NetView
for AIX Root submap.

2. Select Control

3. Select Coupling between Hub Manger and Nways Manager-ATM and set the
value in the Action on coupling field to Show Status.
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Displaying Device-Specific Information Using JMAs

If a Product Specific Module (PSM) for an 8285 Nways ATM Workgroup Switch an ATM
bridge, an ATM concentrator, or an MSS server has been installed, you can use the
NetView for AIX Application Transporter function to display a graphical view of the
device and access device-specific management options for the device. Typically, JMA
graphical views represent the main control panel of the device and can include interface
cards, ports, power receptacles, switches, fans, and appropriate manufacturing
labelling. You can select components within the view and perform management
operations on them or update the view to reflect the current device configuration. JMA
applications contain the configuration and management options particular to managing
an ATM device, as well as functions that allow you to view performance and fault data.

To create a managed device on your network, the appropriate JMA must be installed
with your system. PSMs are provided with the IBM Nways Element Manager. To install
a JMA, follow the instructions that accompany the Nways program.

Open the ATM device JMA by following these steps:

1. Select the ATM device from the graphical view.

2. Do one of the following:

v Select Tools -> Application Transporter from the NetView for AIX menu and
then select Open Subsystem from the Application Transporter cascade menu.

v Select CMA -> Device from the CMA menu.

The ATM device window for the selected device is displayed, as shown in Figure 87 on
page 223.
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You can select components within the JMA graphical view and perform management
operations on them using the management menus provided by the PSM. See the PSM
documentation for more information.

Figure 87. ATM Device Window for ATM Workgroup Switch Product Specific Module
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Chapter 19. Autodiscovery of Network Agents

This section describes the autodiscovery feature of Nways Manager-ATM for monitoring
and receiving information from your ATM Campus network. Each installed component
allows Nways Manager-ATM to communicate with agent programs in network devices to
gather configuration, fault, and statistics data.

Agents Discovered by Installed Components

Nways Manager-ATM discovers different network devices according to the components
you install and have running, and the agents installed in each device. A Nways
Manager-ATM component is installed or not installed depending on the SMIT options
you selected when installing the product.

When you enter ovstart cmld to start Nways Manager-ATM, each installed component
is started by default.

v To stop the component and change its status from started to not running, enter the
command:

cmlstop daemon

where daemon is the name of the daemon used by the installed component.

v To restart the component, enter the command:

cmlstart daemon

v To change the default setting, do one of the following:

– In SMIT, select Communications Applications and Services -> Nways Campus
Manager -> Configure -> Nways Campus Manager general configuration ->
Capabilities to be started when Campus Manager starts .

– From the menu bar in the Root submap, select Administer -> Campus Manager
SMIT. Then from the SMIT main menu, select Configure -> Nways Campus
Manager general configuration -> Capabilities to be started when Campus
Manager starts .

In the dialog box displayed, select Yes for the capabilities that you want to automatically
start when the cmld daemon is started.

Methods of Discovery

Information supplied by agents is discovered by Nways Manager-ATM components in
the following ways:

v Automatic discovery of the NetView for AIX or HP OpenView Windows topology
database and traps (node added, node deleted, and sysobjectid changed)

v Persistent discovery using SMIT and the Known Agents file, the dedicated
configuration file used by all Nways Manager-ATM components.

v Temporary discovery by selecting menu options from the SMIT user interface.
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Persistent Discovery Using the Known Agents File

The Known Agents file provides a method to persistently discover agents that are not
automatically discovered by Nways Manager-ATM. This file is used by each component
and contains:

v IP addresses (or host names) of the devices from which agents respond

v IDs of the agents supported by each device (optional)

Each record in the file appears as an IP address, optionally followed by a series of
agent IDs in the format:

ip1 <id1 id2 id3 ...>
ip2 <id1 id2 id3 ...>

Each agent ID in a record appears in the format <sysObjectID>/<MIB variable> where:

v sysObjectID is the MIB II variable defined in the device.

v MIB variable is the MIB variable to be discovered.

An example of an agent ID appears in the Known Agents file is shown below:

1.3.6.1.4.1.49.2.3.5/1.3.6.1.2.1.17.1.1.0

Nways Manager-ATM uses the list of agent IDs to discover:

v Each agent, even when an agent does not respond

v LNM OS/2® agents

Defining an Alias for an Agent ID

To define an alias for an agent ID that you can use to modify the Known Agents file, do
one of the following:

v From SMIT, do the following:

1. Select Communications Applications and Services and then choose Nways
Campus Manager

2. Select Configure choose Campus Manager general configuration and then
choose Define an agent ID .

v From the menu bar, select Administer -> Campus Manager SMIT . Then from the
SMIT main menu, select Configure choose Nways Campus Manager general
configuration and then choose Define an agent ID .

In the dialog box displayed, enter the agent ID in the format

<sysObjectID>/<MIB variable>

as described in the preceding section. In the Agent Identifier field, enter the alias to be
used instead of the agent ID. You can also enter a text description of the alias.

To remove an alias that you defined for an agent ID, do one of the following:
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v From SMIT, select Communications Applications and Services -> Nways
Campus Manager -> Configure -> Nways Campus Manager general
configuration -> Undefine an agent ID .

v From the menu bar, select Administer -> Campus Manager SMIT . Then from the
SMIT main menu, select Configure -> Nways Campus Manager general
configuration -> Undefine an agent ID .

Modifying the Known Agents File

To modify the Known Agents file, use the SMIT interface to add and remove IP
addresses and agent IDs.

To add an IP address or an agent ID, do one of the following:

v From SMIT, select Communications Applications and Services -> Nways
Campus Manager -> Configure -> Nways Campus Manager general
configuration -> Add an IP address for forced discovery .

v From the menu bar, select Administer -> Campus Manager SMIT . Then from the
SMIT main menu, select Configure -> Nways Campus Manager general
configuration -> Add an IP address for forced discovery .

In the dialog box displayed, enter the IP address or the host name of the device. Then
enter the agent ID supported by the device. To display the list of existing agent IDs,
click the List button.

To remove an IP address or an agent ID, do one of the following:

v From SMIT, select Communications Applications and Services -> Nways
Campus Manager -> Configure -> Nways Campus Manager general
configuration -> Remove an IP address for forced discovery .

v From the menu bar, select Administer -> Campus Manager SMIT . Then from the
SMIT main menu, select Configure -> Nways Campus Manager general
configuration -> Remove an IP address for forced discovery .

Editing the Known Agents File

When you edit the Known Agents file, follow these conventions:

v The file name is /usr/CML/data/cml.discovery.agents

v Any line beginning with # is a line of comments and can be inserted anywhere in the
file.

v Any line that is not a line of comments must contain either one IP address or
hostname, optionally followed by a list of agent_ids, optionally followed by a # and
comments

v All the agent_ids for a given IP address (if any exist) must be entered on the same
line; duplicate IP address and hostname entries are not allowed.
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Temporary Discovery

To temporarily modify the agents that are discovered (if the discovery process is
running), use the SMIT interface to find and delete an SNMP agent. The changes you
make are only valid during the current Nways Manager-ATM session. When you stop
and restart Nways Manager-ATM, only the information supplied by automatic and
persistent discovery is used.

To find an SNMP agent, do one of the following:

v From SMIT, select Communications Applications and Services -> Nways
Campus Manager -> Control -> Find SNMP Agent .

v From the menu bar, select Administer -> Campus Manager SMIT . Then from the
SMIT main menu, select Configure -> Nways Campus Manager general
configuration -> Control -> Find SNMP Agent .

To delete an SNMP agent, do one of the following:

v From SMIT, select Communications Applications and Services -> Nways
Campus Manager -> Control -> Delete SNMP Agent .

v From the menu bar, select Administer -> Nways Campus Manager . Then from the
SMIT main menu, select Configure -> Nways Campus Manager general
configuration -> Control -> Delete SNMP Agent .

The Known Agents File is not changed.

Agents Filter File

The Agents Filter file allows you to determine what agents are discovered by Nways
Manager-ATM components. To create or modify the file, you use a standard ASCII text
editor.

The Agents Filter file contains the ip_address_wildcard field. This field limits agent
discovery according to the range of IP addresses you specify. Enter parameters in the
same format as in NetView for AIX or HP OpenView Windows.

You can filter the automatic discovery of agents for NetView for AIX or HP OpenView
Windows.

To determine if an agent is to be discovered, the discovery process checks the agents
using information from:

1. NetView for AIX or HP OpenView Windows

2. Persistent discovery

3. Temporary discovery

Note that even if an agent is listed on more than one method to be discovered, Nways
Manager-ATM only discovers and receives information from it once.
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It is recommended that you clear the ATM topology before defining a filter file and
restarting the cmld daemon. If you do not do this, and the ATM topology has already
been built, objects that are not defined in the filter file will no longer be managed. The
status will remain the same as when the ahmtopod daemon was stopped.

The conventions used for the Agents Filter file are as follows:

v The file name is: /usr/CML/data/cml.discovery.filter .

v The format of the file is similar to the NetView for AIX or HP OpenView Windows
seed file.

v Any line beginning with # is a line of comments and can be inserted anywhere in the
file.

v Any line that is not a line of comments can contain one IP address or hostname and
is optionally followed by a # and comments

v Wildcards in IP addresses are allowed (for example, 9.*, 9.100.*, 9.100.*.*,
9.100.*.66, and so on).

v Ranges are specified using the - separator (for example, noumea.lagaude.ibm.com-
9.100.*).
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Chapter 20. Command-line Interface for LAN Emulation Manager

The following describes the command line interface for LAN Emulation Manager.

Command Overview for LAN Emulation Manager

The command line interpreter ahmlecmd is located in directory /usr/CML/bin. Most of
the functions available from the LAN Emulation Manager graphical user interface are
also available from the command line. A list of available commands can be obtained by
issuing the command:

/usr/CML/bin/ahmlecmd -help

The following table lists the commands available in the command line interface.

Table 12. Command Line Interface Commands

Command Description

CreateDomain Create a domain

CreateElan Create an ELAN

CreateElanInstance Create an ELAN instance

CreateLecs Create a LECS instance

CreateLes Create a LES instance

CreateBus Create a BUS instance

CreateSinglePolicy Create a single policy

CreatePolicyValue Create a single (or multiple, via file) policy value

DeleteElan Delete an ELAN

DeleteElanInstance Delete an ELAN instance

DeleteDomain Delete a domain

DeleteLes Delete a LES instance

DeleteBus Delete a BUS instance

DeleteLecs Delete a LECS instance

DeleteSinglePolicy Delete a single policy

DeleteSinglePolicyValue Delete a single policy value

DeleteAllPolicyValue Delete all policy values for an ELAN and LES

AddLesToElan Add a LES instance to an ELAN (ElanLesTable)

AddElanToLecs Add an ELAN instance to a LECS (LecsElanTable)

UnassignLesFromElan Unassign a LES from an ELAN (ElanLesTable)

UnassignElanFromLecs Unassign an ELAN from a LECS (ElanLecsTable)

UnassignLecFromLes Unassign a LEC from a LES (LesLecTable)

AdminElan Move an ELAN from the Unadmin domain to a LECS
domain
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Table 12. Command Line Interface Commands (continued)

Command Description

UnadminElan Move an ELAN from a LECS domain to the 'unadmin'
domain

MoveLec Move an existing LEC into a new ELAN

ListDomain List Domains information

ListLecs List LAN Emulation Configuration Server information

ListElan List Emulated LAN information

ListLes List LAN Emulation Server information

ListBus List Broadcast Unknown Server information

ListLec List LAN Emulation Client information

ListBox List boxes (devices) information

GetLecsConfTable Get LECS Configuration Table values

GetNextLecsConfTable Get Next on LECS Configuration Table values

GetLecsErrCtlTable Get LECS Error Control Table values

GetElanConfTable Get ELAN Configuration Table values

GetNextElanConfTable Get Next on ELAN Configuration Table values

GetLesConfTable Get LES Configuration Table values

GetNextLesConfTable Get Next on LES Configuration Table values

GetLesErrCtlTable Get LES Error Control Table values

GetBusConfTable Get BUS Configuration Table values

GetBcmCacheInfo Get BCM cache value (for all protocols)

GetNextBusConfTable Get Next on BUS Configuration Table values

GetBusErrCtlTable Get BUS Error Control Table values

GetLecConfTable Get LEC Configuration Table values

GetNextLecStatusTable Get Next on LEC Configuration Table values

GetLecStatusTable Get LEC Status Table values

GetSystemGroup Get MIB II System Group values

GetIfTable Get MIB II Interface Table values

GetGeneric Get a given value

GetNextLecsErrLogTable Get LECS Error Log Table values

GetNextLesErrLogTable Get LES Error Log Table values

GetNextLecsTlvTable Get LECS TLV table values

GetNextBusErrLogTable Get BUS Error Log Table values

GetNextBcmStaticTargetTable Get BCM static target table values

GetNextLesBus Get Next on LES BUS table

GetNextLesLec Get Next on LES LEC table

GetNextLesArpMac Get Next on LesArpMac table

GetNextLesArpRd Get Next on LesArpRd table
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Table 12. Command Line Interface Commands (continued)

Command Description

GetNextBusLec Get Next on BUS LEC table

GetNextConf Get Next on 8260/8285 private MIB Interface table

GetNextSvc Get Next on 8260/8285 private MIB SVC table

GetNextOid Get Next on a table and give the Oid of each line

GetNextElanPolicy Get Next on ELAN Policy table

GetNextElanLes Get Next on ELAN LES table

GetNextPolicyValue Get Next on Policy table for a given ELAN and LES

GetNextLecAtmAddressTable Get Next on LecAtmAddress table

GetNextLecMacAddressTable Get Next on LecMacAddress table

GetNextLecRdTable Get Next on LecRouteDescr table

SetGeneric Set MIB II System Group values

Command Syntax Overview

All commands have the same syntax:

/usr/CML/bin/ahmlecmd command parameters

where: command is one of the commands listed in Table 12 on page 233, and
parameters is one or more parameters for the command. Depending on the command,
there are mandatory and optional parameters.

All commands accept the following optional parameters:

Parameter Description

-help Displays help for the command.

-out filename Allows the command text output to be re-directed to the specified file.

-err filename Allows the command text error output to be re-directed to the
specified file.

Many commands accept the following parameters:

Parameter Description

-server server IP address The IP address/hostname of the station that hosts the 'ahmtopod'
(ATM and LAN Emulation Manager topology daemon) daemon. This
is usually the station on which NetView/6000 runs (the server part if
NetView/6000 V4).

-MaxFrameSize Maximum frame size for a resource. This value can be max1516,
max4544, max9234, or max18190
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Parameter Description

-PolicyType Policy type for a resource. This value can be one of the following:

v ByAtmAddr

v ByMacAddr

v ByLanType

v ByPktSize

v ByRouteDescriptor

v ByElanName.

Command Parameters and Examples of Using the Commands

The following describes each command and the parameters asscociated with the
command Examples of using the commands are also provided. The commands are
listed in alphabetical order. A parameter designated M is mandatory.

AddElanToLecs

The AddElanToLecs command is used to add an ELAN instance to a LECS in the
LECS Elan table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address/hostname of the device where the LECS is
defined.

-LecsIndex (M) The LECS Configuration table entry index.

-ElanIndex (M) The ELAN index of the ELAN to be added to the LECS.

The following shows an example of using the command.

AddLesToElan

The AddLesToElan command is used to add a LES instance to an ELAN in the ELAN
LES table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address/hostname of the device where the ELAN is
defined.

-LesAtmAddress (M) The ATM address of the LES to add.

-ElanIndex (M) The ELAN index where to add the LES.

/usr/CML/bin/ahmlecmd AddElanToLecs \
-BoxIpAddress 9.100.87.16 \
-LecsIndex 1 \
-ElanIndex 85 \
-server gascogne
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The following shows an example of using the command.

AdminElan

The AdminElan command is used to move an ELAN from an unadministered domain to
a LECS domain. The command has the following parameters:

Parameter Description

-ElanLabel (M) The ELAN label of the ELAN to administrate.

-DomainLabel (M) The domain label of the domain where the ELAN is to be
administrated.

The following shows an example of using the command.

CreateBus

The CreateBus command is used to create a BUS instance. The command has the
following parameters:

Parameter Description

-BoxIpAddress (M) The IP address/hostname of the device where the BUS is to be
created.

-BusAtmAddress (M) The specified ATM address to be used to create the BUS.

-BusAtmAddressMask (M) The ATM address mask to be used to create the BUS.

-ElanLabel (M) The ELAN name to be used to create the BUS.

-BusMaxFrameAge (M) The maximum frame age for the new BUS.

-AdminStatus (M) (Up │ Down) The new BUS desired state.

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd AddLesToElan \
-BoxIpAddress 9.100.87.16 \
-LesAtmAddress 39.99.99.99.99.99.99.00.00.99.99.03.02.14.15.16.17.18.19.22 \
-ElanIndex 24 \
-server gascogne

/usr/CML/bin/ahmlecmd AdminElan \
-ElanLabel Pierdo004 \
-DomainLabel 9.100.87.16-1 \
-server gascogne

/usr/CML/bin/ahmlecmd CreateBus \
-BoxIpAddress 9.100.87.16 \
-BusAtmAddress 01.02.03.04.05.06.07.08.09.10.11.12.13.14.15.16.17.18.19.20 \
-BusAtmAddressMask ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff \
-ElanLabel Essai_a_Pierdo_Create_Bus \
-BusMaxFrameAge 50 \
-AdminStatus Up \
-server gascogne
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CreateDomain

The CreateDomain command is used to create a domain. The command has the
following parameters:

Parameter Description

-BoxIpAddress (M) The IP address/hostname of the device where the domain (the
LECS instance) is to be created.

-LecsAtmAddress (M) The specified ATM address of the device where the domain
(LECS instance) is to be created.

-LecsAtmAddressMask (M) The ATM address mask of the device where the domain (LECS
instance) is to be created.

-IfIndex (M) The interface index of the ATM adapter to be used by the new
LECS in the device that will host this LECS.

-PolicyTypeN (M) (N is 1 to 6) The Nth policy type to be used in this new domain.

-PolicyPriorityN (M) (N is 1 to 6) The Nth policy priority to be used in this new
domain.
Note: Only PolicyType1 and PolicyPriority1 parameters are
mandatory.

The following shows an example of using the command.

CreateElan

The CreateElan is used to create an ELAN/ The command has the following
parameters:

Parameter Description

-ElanLabel (M) The name of the new ELAN.

-ElanType (M) (Ethernet │ TokenRing) The type of the new ELAN.

-MaxFrameSize (M) The maximum frame size for the new ELAN.

-DomainLabel (M) The new ELAN domain name (this can be 'unadmin').

-LesIpAddress (M) The IP address/hostname of the device where to create the LES
associated to the ELAN.

-LesAtmAddress (M) The specified ATM address of the LES.

-LesAtmAddressMask (M) The ATM mask of the LES.

-LesControlTimeOut (M) The LES control time out value.

/usr/CML/bin/ahmlecmd CreateDomain \
-BoxIpAddress 9.100.87.16 \
-LecsAtmAddress 01.02.03.04.05.06.07.08.09.10.11.12.13.14.15.16.17.18.19.20 \
-LecsAtmAddressMask ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff \
-IfIndex 0 \
-PolicyType1 ByAtmAddr \
-PolicyPriority1 1 \
-server gascogne
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Parameter Description

-BusIpAddress (M) The IP address/hostname of the device where to create the BUS
associated to the ELAN.

-BusAtmAddress (M) The specified ATM address of the BuS.

-BusAtmAddressMask (M) The ATM mask of the BUS.

-BusMaxFrameAge (M) The BUS maximum frame age.

The following shows an example of using the command.

CreateElanInstance

The CreateElanInstance command is used to create and ELAN instance. The command
has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address/hostname of the device where the domain (the
LECS instance) is to be created.

-ElanLabel (M) The name of the new ELAN.

-ElanType (M) (Ethernet|TokenRing) The type of the new ELAN.

-MaxFrameSize (M) The maximum frame size for the new ELAN.

The following shows an example of using the command.

CreateLecs

The CreateLecs command is used to create a LECS instance. The command has the
following parameters:

/usr/CML/bin/ahmlecmd CreateElan \
-ElanLabel Essai_a_Pierdo \
-ElanType Ethernet \
-MaxFrameSize max1516 \
-DomainLabel 9.100.87.16-1 \
-LesIpAddress 9.100.87.16 \
-LesAtmAddress 01.02.03.04.05.06.07.08.09.10.11.12.13.14.15.16.17.18.19.20 \
-LesAtmAddressMask ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff \
-LesControlTimeOut 120 \
-BusIpAddress 9.100.87.16 \
-BusAtmAddress 01.02.03.04.05.06.07.08.09.10.11.12.13.14.15.16.17.18.19.21 \
-BusAtmAddressMask ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff \
-BusMaxFrameAge 50 \
-server gascogne

/usr/CML/bin/ahmlecmd CreateElanInstance \
-BoxIpAddress 9.100.87.16 \
-ElanLabel Essai_a_Pierdo_bis \
-ElanType Ethernet \
-MaxFrameSize max1516 \
-server gascogne
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Parameter Description

-BoxIpAddress (M) The IP address/hostname of the device

-LecsIndex (M)

-LecsAtmAddress (M) The specified ATM address of the LECS

-LecsAtmAddressMask (M) The desired ATM address mask

-IfIndex (M)

-AdminStatus (M) (Up|Down) The new LECS desired state.

The following shows an example of using the command.

CreateLes

The CreateLes command is used to create a LES instance. The command has the
following parameters:

Parameter Description

-BoxIpAddress (M) The IP address/hostname of the device where the LES is to be
created.

-LesAtmAddress (M) The specified ATM address of the new LES

-LesAtmAddressMask (M) The specified ATM address mask of the new LES

-ElanLabel (M) The specified ELAN name

-ElanType (M) The specified ELAN type

-MaxFrameSize (M) The maximum frame size for the new LES.

-LesControlTimeOut (M) The control timeout for the new LES.

-AdminStatus (M) (Up|Down) The new LES desired state.

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd CreateLecs \
-BoxIpAddress 9.100.87.16 \
-LecsIndex 2 \
-LecsAtmAddress 1.2.3.4.5.6.7.8.9.10.11.12.13.14.15.16.17.18.19.20 \
-LecsAtmAddressMask ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff \
-IfIndex 0 \
-AdminStatus Up \
-server gascogne

/usr/CML/bin/ahmlecmd CreateLes \
-BoxIpAddress 9.100.87.16 \
-LesAtmAddress 01.02.03.04.05.06.07.08.09.10.11.12.13.14.15.16.17.18.19.20 \
-LesAtmAddressMask ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff \
-ElanLabel Essai_a_Pierdo_Create_Les \
-ElanType Ethernet \
-MaxFrameSize max1516 \
-LesControlTimeOut 120 \
-AdminStatus Up \
-server gascogne
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CreatePolicyValue

The CreatePolicyValue command is used to create either a single policy or a multiple
policies from a file. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The LECS IP address/hostname where the ELAN is registered.

-LesIndex (M) The index in the ELAN table of the desired LES.

-ElanIndex (M) The desired ELAN index.

-InputFileName Name of the input file name where Policy Type and parameters are
described. This file is not mandatory if the syntax shown in the
following example is used.

-PolicyType (M) The desired policy type. The possible values are:

v ByElanName

v ByPktSize

v ByRouteDescriptor

v ByMacAddr

v ByAtmAddr

-PolicyValue (M) The desired policy value. Policy value is:

v -LecAtmAddress and -LecAtmMask for ByAtmAddr Policy

v -LecMacAddre for ByMacAddr Policy

v -LecRdSegId and -LecRdBridgeNum for ByRouteDescriptor Policy

v -LecFrameSize for ByPktSize Policy

v -LecElanName for ByElanName Policy

The following show examples of using the command.

/usr/CML/bin/ahmlecmd CreatePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 4 \
-InputFileName essaiPdo \
-server gascogne

/usr/CML/bin/ahmlecmd CreatePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 4 \
-PolicyType ByMacAddr \
-LecMacAddress 1.2.3.4.5.6 \
-server gascogne
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DeleteAllPolicyValue

The DeleteAllPolicyValue command is used to deleete all policy values for an ELAN
and a LES. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The LECS IP address/hostname where the ELAN is registered.

-LesIndex (M) The index in the ELAN table of the desired LES.

-ElanIndex (M) The desired ELAN index.

/usr/CML/bin/ahmlecmd CreatePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 4 \
-PolicyType ByRouteDescriptor \
-LecRdSegId 1111 \
-LecRdBridgeNum 2222 \
-server gascogne

/usr/CML/bin/ahmlecmd CreatePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 4 \
-PolicyType ByPktSize \
-LecFrameSize max4544 \
-server gascogne

/usr/CML/bin/ahmlecmd CreatePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 4 \
-PolicyType ByElanName \
-LecElanName PoilDeCarotte \
-server gascogne

/usr/CML/bin/ahmlecmd CreateSinglePolicy \
-BoxIpAddress 9.100.87.16 \
-PolicyType ByAtmAddr \
-PolicyPriority 222 \
-PolicySelectorIndex 1 \
-PolicyIndex 4 \
-server gascogne
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Parameter Description

-MibVarToSet (M) The desired MIB variable to delete. This can be one of the
following:

v elanLecAtmRowStatus

v elanLecMacRowStatus

v elanLecRdRowStatus

v elanLecPktSizeRowStatus

v elanLecNameRowStatus.

The following shows an example of using the command.

DeleteSinglePolicyValue

The DeleteSinglePolicyValue is used to delete a single policy value. The command has
the following parameters:

Parameter Description

-BoxIpAddress (M) The LECS IP address/hostname where the ELAN is registered.

-ElanIndex (M) The desired ELAN index.

-LesIndex (M) The index in the ELAN table of the desired LES.

-PolicyType (M) The desired policy type. The possible values are:

v ByElanName

v ByPktSize

v ByRouteDescriptor

v ByMacAddr

v ByAtmAddr

-Policy Value (M) The desired policy value. The Policy valueis one of the following:

v -LecAtmAddress and -LecAtmMask for ByAtmAddr Policy

v -LecMacAddre for ByMacAddr Policy

v -LecRdSegId and -LecRdBridgeNum for ByRouteDescriptor Policy

v -LecFrameSize for ByPktSize Policy

v -LecElanName for ByElanName Policy

The following show examples of using the command.

/usr/CML/bin/ahmlecmd DeleteAllPolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 21 \
-MibVarToSet elanLecAtmRowStatus \
-server gascogne
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DeleteBus

The DeleteBus command isused to delete a BUS instance. The command has the
following parameters:

Parameter Description

-BusIndex (M) The BUS index.

-BoxIpAddress (M) The BUS IP address/hostname.

/usr/CML/bin/ahmlecmd DeleteSinglePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 21 \
-PolicyType ByAtmAddr \
-LecAtmAddress 1.2.3.4.5.6.7.8.9.10.11.12.13.14.15.16.17.18.19.20 \
-LecAtmMask ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff.ff \
-server gascogne

/usr/CML/bin/ahmlecmd DeleteSinglePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 21 \
-PolicyType ByMacAddr \
-LecMacAddress 1.2.3.3.2.1 \
-server gascogne

/usr/CML/bin/ahmlecmd DeleteSinglePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 21 \
-PolicyType ByRouteDescriptor \
-LecRdSegId 11 \
-LecRdBridgeNum 22 \
-server gascogne

/usr/CML/bin/ahmlecmd DeleteSinglePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 21 \
-PolicyType ByPktSize \
-LecFrameSize max4544 \
-server gascogne

/usr/CML/bin/ahmlecmd DeleteSinglePolicyValue \
-BoxIpAddress 9.100.87.16 \
-LesIndex 1 \
-ElanIndex 21 \
-PolicyType ByElanName \
-LecElanName MyLecElan \
-server gascogne
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The following shows an example of using the command.

DeleteElan

The DeleteElan command is used to delete an ELAN. The command has the following
parameters:

Parameter Description

-DomainLabel (M) The label of the desired domain where are the ELANs to delete.

-ElanLabel (M) The label of the desired ELAN.

The following show examples of using the command.

DeleteElanInstance

The DeleteElanInstance command is used to delete an ELAN instance. The command
has the following parameters:

Parameter Description

-ElanIndex (M) The index of the desired ELAN.

-BoxIpAddress (M) The IP address of the desired ELAN.

DeleteLecs

The DeleteLecs command is used to delete a LECS instance. The command has the
following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired LECS.

-LecsIndex (M) The index of the desired LECS.

/usr/CML/bin/ahmlecmd DeleteBus \
-BusIndex 12 \
-BoxIpAddress 9.100.87.16 \
-server gascogne

/usr/CML/bin/ahmlecmd DeleteElan \
-DomainLabel 9.100.87.16-1 \
-server gascogne

/usr/CML/bin/ahmlecmd DeleteElan \
-ElanLabel Pierdo001 \
-DomainLabel 9.100.87.16-1 \
-server gascogne

/usr/CML/bin/ahmlecmd DeleteElanInstance \
-ElanIndex 15 \
-BoxIpAddress 9.100.87.16 \
-server gascogne
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The following shows an example of using the command.

DeleteLes

The DeleteLes command is used to delete a LES instance. The command has the
following parameters:

Parameter Description

-LesIndex (M) The IP address of the desired LES.

-BoxIpAddress (M) The index of the desired LES.

The following shows an example of using the command.

DeleteSinglePolicy

The DeleteSinglePolicy command is used to delete a single policy. The command has
the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address where the ELAN is registered.

-PolicySelectorIndex (M) The index of the selector (allow to link the policy and the LECS
entity)

-PolicyIndex (M) The index of the desired policy (uniquely identifies the policy)

The following shows an example of using the command.

GetGeneric

The GetGeneric command is used to get a given MIB variable. The command has the
following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

/usr/CML/bin/ahmlecmd DeleteLecs \
-BoxIpAddress 9.100.87.16 \
-LecsIndex 1 \
-server gascogne

/usr/CML/bin/ahmlecmd DeleteLes \
-LesIndex 13 \
-BoxIpAddress 9.100.87.16 \
-server gascogne

/usr/CML/bin/ahmlecmd DeleteSinglePolicy \
-BoxIpAddress 9.100.87.16 \
-PolicySelectorIndex 1 \
-PolicyIndex 9 \
-server gascogne
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Parameter Description

-MibVarToGet (M) The desired MIB variable.

-Index The index that uniquely identifies the resource.

The following show examples of using the command.

GetBusConfTable

The GetBusConfTable command is used to get BUS Configuration table values. The
command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

The following shows an example of using the command.

GetBusErrCtlTable

The GetBusErrCtlTable command is used to get BUS Error Control table values. The
command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd GetGeneric \
-BoxIpAddress 9.100.87.16 \
-MibVarToGet sysName

/usr/CML/bin/ahmlecmd GetGeneric \
-BoxIpAddress 9.100.87.16 \
-MibVarToGet ifSpeed \
-Index 1

/usr/CML/bin/ahmlecmd GetBusConfTable \
-BoxIpAddress 9.100.94.114 \
-Index 4

/usr/CML/bin/ahmlecmd GetBusErrCtlTable \
-BoxIpAddress 9.100.94.114 \
-Index 4
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GetElanConfTable

The GetElanConfTable command is used to get ELAN Configuration table values. The
command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

The following shows an example of using the command.

GetIfTable

The GetIfTable command is used to get a value from the MIB II Interface Table. The
command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

The following shows an example of using the command.

GetLecConfTable

The GetLecConfTable command is used to a valu from the LEC Configuration table The
command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

The following shows an example of using the command.

GetLecStatusTable

The GetLecStatusTable command is used to get a value from the LEC Status table.
The command has the following parameters:

/usr/CML/bin/ahmlecmd GetElanConfTable \
-BoxIpAddress 9.100.94.114 \
-Index 4

/usr/CML/bin/ahmlecmd GetIfTable \
-BoxIpAddress 9.100.94.114 \
-Index 4

/usr/CML/bin/ahmlecmd GetLecConfTable \
-BoxIpAddress 9.100.94.114 \
-Index 4
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Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

The following shows an example of using the command.

GetLecsConfTable

The GetLecsConfTable command is used to get a value from the LECS Configuretion
table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

GetLecsErrCtlTable

The GetLecsErrCtlTable command is used to get a value from the LECS Error Control
table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

GetLesConfTable

The GetLesConfTable command is used to get a value from the LES Configuration
table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

/usr/CML/bin/ahmlecmd GetLecStatusTable \
-BoxIpAddress 9.100.94.114 \
-Index 4

/usr/CML/bin/ahmlecmd GetLecsConfTable \
-BoxIpAddress 9.100.94.114 \
-Index 4

/usr/CML/bin/ahmlecmd GetLecsErrCtlTable \
-BoxIpAddress 9.100.94.114 \
-Index 4
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GetLesErrCtlTable

The GetLesErrCtlTable command is used to get a value from the LES Error Control
Table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource.

The following shows an example of using the command.

GetBcmCacheInfo

The GetBcmCacheInfo command is used to get BCM cache values for all protocols.
The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource

The following shows an example of using the command.

GetNextBusConfTable

The GetNextBusConfTable command is used to get all values from the BUS
Configuration table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd GetLesConfTable \
-BoxIpAddress 9.100.94.114 \
-Index 4

/usr/CML/bin/ahmlecmd GetLesErrCtlTable \
-BoxIpAddress 9.100.94.114 \
-Index 4

/usr/CML/bin/ahmlecmd GetBcmCacheInfo \
-BoxIpAddress 9.100.94.114 \
-Index 4

/usr/CML/bin/ahmlecmd GetNextBusConfTable \
-BoxIpAddress 9.100.94.114
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GetNextLecsTlvTable

The GetNextLecsTlvTable command is used to get LECS Tlv table values. The
command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index The starting index. The getNext will start at this index until the end of
the table

The following shows an example of using the command.

GetNextBusErrLogTable

The GetNextBusErrLogTable command is used to get all values from the BUS Error Log
table, or to get the next value if an index is given. The command has the following
parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

GetNextBusLec

The GetNextBusLec command is used to get all values from the BUS LEC table, or the
next value if an index is given. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd GetNextLecsTlvTable \
-BoxIpAddress 9.100.94.114 \
-Index 0

/usr/CML/bin/ahmlecmd GetNextBusErrLogTable \
-BoxIpAddress 9.100.94.114 \
-Index

/usr/CML/bin/ahmlecmd GetNextBusLec \
-BoxIpAddress 9.100.94.114 \
-Index
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GetNextConf

The GetNextConf command is used to get all values from the 8260/8285 private MIB
Interface table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

The following shows an example of using the command.

GetNextElanConfTable

The GetNextElanConfTable command is used to get all values of the ELAN
Configuration table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

The following shows an example of using the command.

GetNextElanLes

The GetNextElanLes command is used to get all the values of the ELAN LES table, or
to get the next value if an index is given. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

GetNextElanPolicy

The GetNextElanPolicy command is used to get all values from the ELAN Policy table,
or to get the next value if an index is given. The command has the following
parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

/usr/CML/bin/ahmlecmd GetNextConf \
-BoxIpAddress 9.100.94.114

/usr/CML/bin/ahmlecmd GetNextElanConfTable \
-BoxIpAddress 9.100.94.114

/usr/CML/bin/ahmlecmd GetNextElanLes \
-BoxIpAddress 9.100.94.114 \
-Index
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Parameter Description

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

GetNextLecAtmAddressTable

The GetNextLecAtmAddressTable command is used to get all values from the LEC ATM
Address table, or to get the next value if an index is given. The command has the
following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

GetNextLecMacAddressTable

The GetNextLecMacAddressTable is used to get all values from the LEC MAC Address
table, or to get the next value if an index is given. The command has the following
parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

GetNextLecRdTable

The GetNextLecRdTable command is used to get all values from the LEC Route
Descriptor table, or to get the next value if an index is given. The command has the
following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

/usr/CML/bin/ahmlecmd GetNextElanPolicy \
-BoxIpAddress 9.100.94.114 \
-Index

/usr/CML/bin/ahmlecmd GetNextLecAtmAddressTable \
-BoxIpAddress 9.100.94.114 \
-Index

/usr/CML/bin/ahmlecmd GetNextLecMacAddressTable \
-BoxIpAddress 9.100.94.114 \
-Index
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Parameter Description

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

GetNextLecStatusTable

The GetNextLecStatusTable command is used to get all values from the LEC
Configuration table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

The following shows an example of using the command.

GetNextLecsConfTable

The GetNextLecsConfTable command is used to get all values from the LECS
Configuration table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

The following shows an example of using the command.

GetNextLecsErrLogTable

The GetNextLecsErrLogTable command is used to get all values from the LECS Error
Log table, or to get the next value if an index is given. The command has the following
parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd GetNextLecRdTable \
-BoxIpAddress 9.100.94.114 \
-Index

/usr/CML/bin/ahmlecmd GetNextLecStatusTable \
-BoxIpAddress 9.100.94.114

/usr/CML/bin/ahmlecmd GetNextLecsConfTable \
-BoxIpAddress 9.100.94.114
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GetNextLesArpMac

The GetNextLesArpMac command is used to get all values from the LesArpMac table.
The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index (M) The index that uniquely identifies the LES.

The following shows an example of using the command.

GetNextLesArpRd

The GetNextLesArpRd command is used to get all values from the LesArpRd table. The
command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index (M) The index that uniquely identifies the LES.

The following shows an example of using the command.

GetNextBcmStaticTargetTable

The GetNextBcmStaticTargetTable command is used to get BCM static target table
values. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The index that uniquely identifies the resource

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd GetNextLecsErrLogTable \
-BoxIpAddress 9.100.94.114 \
-Index

/usr/CML/bin/ahmlecmd GetNextLesArpMac \
-BoxIpAddress 9.100.94.114 \
-Index

/usr/CML/bin/ahmlecmd GetNextLesArpRd \
-BoxIpAddress 9.100.94.114 \
-Index

/usr/CML/bin/ahmlecmd GetNextBcmStaticTargetTable \
-BoxIpAddress 9.100.94.114 \
-Index 4
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GetNextLesBus

The GetNextLesBus command is used to get all values from the LES BUS table, or the
next value if an index is given. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index (M) The index that uniquely identifies the resource.

The following shows an example of using the command.

GetNextLesConfTable

The GetNextLesConfTable command is used to get all values of the LES Configuration
table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

The following shows an example of using the command.

GetNextLesErrLogTable

The GetNextLesErrLogTable command is used to get all values of the LES Error Log
table, or to get the next value if an index is given. The command has the following
parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

GetNextLesLec

The GetNextLesLec command is used to get all values of the LesLec table. The
command has the following parameters:

/usr/CML/bin/ahmlecmd GetNextLesBus \
-BoxIpAddress 9.100.94.114 \
-Index

/usr/CML/bin/ahmlecmd GetNextLesConfTable \
-BoxIpAddress 9.100.94.114

/usr/CML/bin/ahmlecmd GetNextLesErrLogTable \
-BoxIpAddress 9.100.94.114 \
-Index
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Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index (M) The index that uniquely identifies the LES.

The following shows an example of using the command.

GetNextOid

The GetNextOid command is used to get the next value from a table and give the Oid
of each line. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-MibVarToGet (M) The MIB variable to get from the table.

-Index The index that uniquely identifies the resource.

The following shows an example of using the command.

GetNextPolicyValue

The GetNextPolicyValue command is used to get all values from the Policy table for the
specified ELAN or LES. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-ElanIndex (M) The index that uniquely identifies the ELAN.

-LesIndex (M) The index that uniquely identifies the LES.

-PolicyType (M) It can be:

v ByAtmAddr

v ByMacAddr

v ByRouteDescriptor

v ByPktType

v ByElanName

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd GetNextLesLecTable \
-BoxIpAddress 9.100.94.114 \
-Index

/usr/CML/bin/ahmlecmd GetNextOid \
-BoxIpAddress 9.100.94.114 \
-MibVarToGet LesLeArpAtmAddr
-Index
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GetNextSvc

The GetNextSvc command is used to to get the next value from the 8260/8285 private
MIB SVC table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired Box

-Index (M) The index that uniquely identifies the SVC.

The following shows an example of using the command.

GetSystemGroup

The GetSystemGroup command is used to get MIB II System Group variables. The
command has the following parameters:

Parameter Description

-BoxIpAddress (M) The desired Box IP/hostname address

The following shows an example of using the command.

ListBox

The ListBox command is used to obtain information about boxes (devices). The
command has the following parameters:

Parameter Description

-server (M) The hostaname/IP address where the server is curently running

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd GetNextPolicyValue \
-BoxIpAddress 9.100.94.114 \
-ElanIndex 21 \
-LesIndex 1 \
-PolicyType ByMacAddr

/usr/CML/bin/ahmlecmd GetNextPolicyValue \
-BoxIpAddress 9.100.94.114 \
-Index 0

/usr/CML/bin/ahmlecmd GetSystemGroup \
-BoxIpAddress 9.100.94.114 \

/usr/CML/bin/ahmlecmd ListBox \
-server gascogne
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ListBus

The ListBus commanad is used to obtain information about a BUS. The command has
the following parameters:

Parameter Description

-server (M) The hostaname/IP address where the server is curently running

-ElanLabel Label of the desired ELAN

The following show examples of using the command.

ListDomain

The ListDomain command is used to obtain information about a domain. The command
has the following parameters:

Parameter Description

-server (M) The hostaname/IP address where the server is curently running

The following shows an example of using the command.

ListElan

The ListElan command is used to obtain information about an ELAN. The command
has the following parameters:

Parameter Description

-server (M) The hostaname/IP address where the server is curently running

-DomainLabel Label of the desired Domain

The following shows an example of using the command.

The following show examples of using the command.

/usr/CML/bin/ahmlecmd ListBus \
-server gascogne

/usr/CML/bin/ahmlecmd ListBus \
-ElanLabel Pierdo005 \
-server gascogne

/usr/CML/bin/ahmlecmd ListDomain \
-server gascogne

/usr/CML/bin/ahmlecmd ListElan \
-server gascogne
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ListLec

The ListLec command is used to obtain information about a LEC. The command has
the following parameters:

Parameter Description

-server (M) The hostaname/IP address where the server is curently running

-ElanLabel Label of the desired ELAN

The following show examples of using the command.

ListLecs

The ListLecs command is used to obtain information about a LECS. The command has
the following parameters:

Parameter Description

-server (M) The hostaname/IP address where the server is curently running

The following shows an example of using the command.

ListLes

The ListLes command is used to obtain information about a LES. The command has
the following parameters:

Parameter Description

-server (M) The hostaname/IP address where the server is curently running

-ElanLabel Label of the desired ELAN

/usr/CML/bin/ahmlecmd ListElan \
-DomainLabel 9.100.87.16-1 \
-server gascogne

/usr/CML/bin/ahmlecmd ListLec \
-server gascogne

/usr/CML/bin/ahmlecmd ListLec \
-ElanLabel Pierdo005 \
-server gascogne

/usr/CML/bin/ahmlecmd ListLecs \
-server gascogne
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The following show example of using the command.

MoveLec

The MoveLec command is used to move an existing LEC into a new ELAN. The
command has the following parameters:

Parameter Description

-LecAtmAddress (M) The desired LEC ATM address (the ATM address can be replaced
by the -LecIpAddress and -LecInstanceNbr)

-LecIpAddress (M) The desired LEC IP address. This can be used along with the
instance number instead of -LecAtmAddress)

-LecInstanceNbr (M) The desired LEC instance number

-ElanLabel (M) The name of the destination ELAN

-DomainLabel (M) The name of the domain where the destination ELAN is.

-DoTheMove (M) Specifies if the move is to be done "Now" or "AtNextLecRestart"

The following show examples of using the command.

SetGeneric

The SetGeneric command is used to set MIB II System Group variables. The command
has the following parameters:

Parameter Description

-BoxIpAddress (M) The desired box IP address.

/usr/CML/bin/ahmlecmd ListLes \
-server gascogne

/usr/CML/bin/ahmlecmd ListLes \
-ElanLabel Pierdo005 \
-server gascogne

/usr/CML/bin/ahmlecmd MoveLec \
-LecAtmAddress 39.99.99.99.99.99.99.00.00.99.99.03.02.60.00.00.00.87.17.01 \
-ElanLabel Pierdo215 \
-DomainLabel 9.100.87.16-1 \
-DoTheMove Now \
-server gascogne

/usr/CML/bin/ahmlecmd MoveLec \
-LecIpAddress 9.100.87.17 \
-LecInstanceNbr 20 \
-ElanLabel Pierdo215 \
-DomainLabel 9.100.87.16-1 \
-DoTheMove Now \
-server gascogne
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Parameter Description

-MibVarToSet (M) The MIB variable to set.

-ValueToSet (M) The desired value of the variable.

The following shows an example of using the command.

UnadminElan

The UnadminElan command is used to move an ELAN from a LECS domain to the
'unadmin' domain. The command has the following parameters:

Parameter Description

-ElanLabel (M) The desired ELAN label

-DomainLabel (M) The label of the domain where the Elan is registered.

The following shows an example of using the command.

UnassignElanFromLecs

The UnassignElanFromLecs command is used to unassign an ELAN from a LECS in
the ELAN LECS table. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The desired LECS IP address

-ElanIndex (M) The desired Elan index

-LecsIndex (M) The desired Lecs index

The following shows an example of using the command.

UnassignLecFromLes

The UnassignLecFromLes command is used to unassign a LEC from a LES in the LES
LEC table. The command has the following parameters:

/usr/CML/bin/ahmlecmd SetGeneric \
-BoxIpAddress 9.100.87.16 \
-MibVarToSet sysName \
-ValueToSet Coucou

/usr/CML/bin/ahmlecmd UnadminElan \
-ElanLabel Pierdo004 \
-DomainLabel 9.100.87.16-1 \
-server gascogne

/usr/CML/bin/ahmlecmd UnassignElanFromLecs \
-BoxIpAddress 9.100.87.16 \
-ElanIndex 24 \
-LecsIndex 1 \
-server gascogne
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Parameter Description

-BoxIpAddress (M) The desired LES IP address

-LesIndex (M) The desired LES index

-LecIndex (M) The desired LEC index in the LesLec table

The following shows an example of using the command.

UnassignLesFromElan

The UnassignLesFromElan (only for an administred ELAN) command is used to
unassign a LES from and ELAN in the ELAN LES table. The command has the
following parameters:

Parameter Description

-BoxIpAddress (M) The desired LECS IP address

-ElanIndex (M) The desired ELAN index

-LesIndex (M) The desired LES index in the Leslec table.

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd UnassignLecFromLes \
-BoxIpAddress 9.100.94.105 \
-LesIndex 2 \
-LecIndex 5 \
-server gascogne

/usr/CML/bin/ahmlecmd UnassignLesFromElan \
-BoxIpAddress 9.100.87.16 \
-ElanIndex 24 \
-LesIndex 2 \
-server gascogne
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Chapter 21. Command-line Interface for ATM Manager

The following describes the command line interface for ATM Manager.

Command Overview for ATM Manager

The command line interpreter ahmlecmd is located in directory /usr/CML/bin. Several
functions available from the ATM Manager graphical user interface are also available
from the command line. A list of available commands can be obtained by issuing the
command:

/usr/CML/bin/ahmlecmd -help

The following table lists the commands available in the command line interface.

Table 13. Command Line Interface Commands

Command Description

GetSinglePnniTopology Get the PNNI topology as seen by a PNNI node

GetPnniRouteSpanningTree Get the spanning tree for a given service category

GetPnniNodeBasicInfo Get basic configuration information about a PNNI
node

GetNextPnniSummaryTable Get the PNNI summary table for a given PNNI node

GetPnniIfTable Get the PNNI interface table for a given PNNI
interface

GetPnniLinkTable Get the PNNI link table for a given PNNI link port ID

GettPnniMapAddrTable Get the PNNI map address table for a given PNNI
port ID

GetGenericInterfaceInfo Get the MIB II generic interface data

GetPrivateAtmSwitchInterfaceInfo Get the private ATM switch interface data

GetAtmLogicalLinkControlsInfo Get the ATM logical link controls VPI/VCI

GetAtmLogicalLinksList Get the ATM logical links list for a given interface

ExecuteCommand Execute a command on the local system

Command Parameters and Examples of Using the Commands

The following describes each command and the parameters asscociated with the
command Examples of using the commands are also provided. The commands are
listed in alphabetical order. A parameter designated M is mandatory.

GetSinglePnniTopology

The GetSinglePnniTopology command is used to get the PNNI topology as seen by a
node. The command has the following parameters:
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Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-PnniNodeIndex (M) The index that uniquely identifies the Pnni node

-PnniPeerGroupId (M) The ID of the PNNI peer group to which the node belongs.

The following shows an example of using the command.

GetPnniRouteSpanningTree

The GetPnniRouteSpanningTree command is used to get the PNNI spanning tree for a
given service category. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-ServiceCategory (M) The requested service category.

The following shows an example of using the command.

GetPnniNodeBasicInfo

The GetPnniNodeBasicInfo command is used to get basic configuration information
about a PNNI node. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-PnniNodeIndex (M) The index that uniquely identifies the PNNI node

The following shows an example of using the command.

GetNextPnniSummaryTable

The GetNextPnniSummaryTable command is used to get the PNNI summary table for a
given PNNI node. The command has the following parameters:

/usr/CML/bin/ahmlecmd GetSinglePnniTopology \
-BoxIpAddress 9.100.108.111 \
-PnniNodeIndex 1 \
-PnniPeerGroupId 6039999999999999000088880000

/usr/CML/bin/ahmlecmd GetPnniRouteSpanningTree \
-BoxIpAddress 9.100.108.111 \
-ServiceCategory 6

/usr/CML/bin/ahmlecmd GetPnniNodeBasicInfo \
-BoxIpAddress 9.100.108.111 \
-PnniNodeIndex 1
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Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-PnniNodeIndex (M) The index that uniquely identifies the PNNI node.

The following shows an example of using the command.

GetPnniIfTable

The GetPnniIfTable command is used to get the PNNI interface table for a given PNNI
interface. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The interface index.

The following shows an example of using the command.

GetPnniLinkTable

The GetPnniLinkTable command is used to get the PNNI link table for a given PNNI link
port ID. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-PnniNodeIndex (M) The index that uniquely identifies the PNNI node.

-PnniLinkPortId (M) The requested PNNI link port ID

The following shows an example of using the command.

GetPnniMapAddrTable

The GetPnniMapAddrTable command is used to get the PNNI map address table for a
given PNNI port ID. The command has the following parameters:

/usr/CML/bin/ahmlecmd GetNextPnniSummaryTable \
-BoxIpAddress 9.100.108.111 \
-PnniNodeIndex 1

/usr/CML/bin/ahmlecmd GetPnniIfTable \
-BoxIpAddress 9.100.108.111 \
-Index 101

/usr/CML/bin/ahmlecmd GetPnniLinkTable \
-BoxIpAddress 9.100.108.111 \
-PnniNodeIndex 1 \
-PnniLinkPortId 2
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Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-PnniNodeIndex (M) The index that uniquely identifies the PNNI node.

-PnniNodeId (M) The PNNI node ID.

-PnniPortId (M) The PNNI port ID

The following shows an example of using the command.

GetGenericInterfaceInfo

The GetGenericInterfaceInfo command is used to get the MIB II generic interface data.
The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The interface index

The following shows an example of using the command.

GetPrivateAtmSwitchInterfaceInfo

The GetPrivateAtmSwitchInterfaceInfo command is used to get the private ATM switch
interface data. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The interface index.

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd GetPnniLinkTable \
-BoxIpAddress 9.100.108.111 \
-PnniNodeIndex 1 \
-PnniNodeId 60.A0.39.99.99.99.99.99.99.00.00.88.88.88.88.01.02.03.04.05.07.00 \
-PnniPortId 2

/usr/CML/bin/ahmlecmd GetGenericInterfaceInfo \
-BoxIpAddress 9.100.94.40 \
-Index 101

/usr/CML/bin/ahmlecmd GetPrivateAtmSwitchInterfaceInfo \
-BoxIpAddress 9.100.94.40 \
-Index 101
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GetAtmLogicalLinkControlsInfo

The GetAtmLogicalLinkControlsInfo command is used to get the ATM logical link
controls VPI/VCI. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The interface index.

The following shows an example of using the command.

GetAtmLogicalLinksList

The GetAtmLogicalLinksList command is used to get the ATM logical links list for a
given interface. The command has the following parameters:

Parameter Description

-BoxIpAddress (M) The IP address of the desired box

-Index (M) The interface index.

The following shows an example of using the command.

/usr/CML/bin/ahmlecmd GetAtmLogicalLinkControlsInfo \
-BoxIpAddress 9.100.94.40 \
-Index 101

/usr/CML/bin/ahmlecmd GetAtmLogicalLinksList \
-BoxIpAddress 9.100.94.40 \
-Index 101
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Appendix. Notices

This information was developed for products and services offered in the U.S.A. IBM
may not offer the products, services, or features discussed in this document in other
countries. Consult your local IBM representative for information on the products and
services currently available in your area.

References in this publication to IBM products, programs, and services do not imply
that IBM intends to make these available in all countries in which IBM operates. Any
reference to an IBM product, program, or service is not that only IBM’s product,
program, or service may be used. Any functionally equivalent product, program, or
service that does not infringe any of IBM’s intellectual property rights may be used
instead of the IBM product, program, or service. Evaluation and verification of operation
in conjunction with other products, except those expressly designated by IBM, are the
user’s responsibility.

IBM may have patents or pending patent applications covering the subject matter in this
document. The furnishing of this document does not give you any license to these
patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other country
where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS
MACHINES CORPORATION PROVIDES THIS PUBLICATION ″AS IS″ WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT,
MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. Some states do
not allow disclaimer of express or implied warranties in certain transactions, therefore,
this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes
are periodically made to the information herein; these changes will be incorporated in
new editions of the publication. IBM may make improvements and/or changes in the
product(s) and/or program(s) described in this publication at any time without notice.
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Any references in this information to non-IBM Web sites are provided for convenience
only and do not in any manner serve as an endorsement of those Web sites. The
materials at those Web sites are not part of the materials for this IBM product and use
of those Web sites is at your own risk.

Industry Standards Reflected in this Product

This product, IBM Nways Element Manager, is designed according to the specifications
of the following industry standards as understood and interpreted by IBM as of
December 1994.

v SNMP:

– RFC1155 - Structure and Identification of Management Information (SMI) for
TCP/IP based Internet.

– RFC1157 - Simple Network Management Protocol (SNMP)

– RFC1212 - Concise MIB definitions

– RFC1213 - Management Information Base (MIB) for Network Management of
TCP/IP based Internets (MIB-II)

– RFC 1215 - Convention for defining Traps for use with SNMP

– RFC1573 - MIB II Extension.

v ATM

– RFC 1695 (AToMMIB)

– UNI V3.0 ILMI MIB and Address Registration MIB.

Trademarks and Service Marks

The following terms in this publication are trademarks or service marks of the IBM
Corporation in the United States, other countries, or both:

AIX OS/2 System/370
AIXwindows POWERserver

IBM RS/6000

The following terms used in this publication, are trademarks of other companies:

NetView and TME 10 are trademarks of Tivoli Systems, Inc. in the United States or
other countries or both.

UNIX is a registered trademark in the United States and other countries licensed
exclusively through X/Open Company Limited.
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List of Abbreviations

The following abbreviated terms often appear in the online books:

AIX Advanced Interactive Executive operating system.

AIXwindows AIXwindows Environment/6000

IBM Hub Manager IBM Intelligent Hub Manager for AIX or HP-UX

ATM device An ATM switch, ATM concentrator, an ATM bridge, a
Multiprotocol Switch Services Server, or any other
ATM device.

ATM concentrator The 8282 Workgroup Concentrator.

ATM bridge The Nways 8260 ATM Tr/Ethernet LAN Bridge
Module.

Nways Manager-ATM IBM Nways Element Manager

Nways Element Manager IBM Nways Element Manager

ATM Hub 8260 Nways Multiprotocol Switching Hub

ATM Workgroup Switch 8285 Nways ATM Workgroup Switch

8265 ATM Switch 8265 Nways ATM Switch.

The following abbreviations are used in this book:

ASCII American National Standard Code for Information
Interchange

Async Asynchronous

ATM Asynchronous transfer mode

BNC Bayonet node connector

BOOTP Bootstrap protocol

Bps Bytes per second

bps Bits per second

BUS Broadcast and Unknown Server

CNM Communication network management

CPN Customer premises network

CRC Cyclic redundancy check

DMM Distributed management module

EMM Ethernet management module

EUI End user interface

FDDI Fiber distributed data interface
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FMM FDDI management module

Gbps Gigabits per second

GTM Generic topology manager

GUI Graphical user interface

8260 Hub 8260 Nways Multiprotocol Switching Hub

Media module IBM ATM Media module

IBM Switch IBM Control Point and Switch Module (A-CPSW)

ICMP Internet control message protocol

IEEE Institute of Electrical and Electronic Engineers
(USA)

IP Internetwork protocol (OSI)

ISO International Organization for Standardization

kbps kilo bits per second

LAN Local area network

LE LAN emulation

LEC LAN Emulation Client

LECS LAN Emulation Configuration Server

LES LAN Emulation Server

MAC Media access control

MAU 1) Multi-station access unit (Token Ring) 2) Medium
attachment unit

MB Megabytes

Mbps Mega bits per second

MIB Management information base

MIC Medium interface connector

MSS Multiprotocol Switch Services server

NNI Network-to-network interface

NRZ Non Return to Zero

NRZI Non Return to Zero Inverted

OSF Open System Foundation

OSI Open System Interconnection

OVw OpenView windows

OVsnmp OpenView SNMP
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PC Personal computer

PCM Physical Connection Management

PIM Product Integrator Module

PNNI Private-network-to-network interface

PSM Product Specific Module

PS/2* Personal System/2*

PTT Post, Telegraph and Telephone (Company)

RAM Random Access Memory

RFC Request for comments

RISC Reduced instruction set computer

SAAL Signalling ATM Adaptation Layer

SDDI Shielded distribution data interface

SMIT System management information tool

SNA System network architecture

SNMP Simple network management protocol

SQE Signal quality error

SSI Switch-to-switch interface

STP Shielded twisted pair

TCP Transmission control protocol

TDM Time Division Multiplexing

TELNET Telecommunication network protocol

TFTP Trivial file transfer protocol

TRMM Token-ring management module

QOS Quality of Service

UDP User datagram protocol

UNI User-to-network interface

UTP Unshielded twisted pair

VC Can be:

v Virtual circuit (X.25)

v Virtual connection (Frame Relay)

v Virtual channel (ATM)

VCC Virtual Channel Connection

VCI Virtual Channel Identifier
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VP Virtual Path

VPC Virtual Path Connection

VPI Virtual Path Identifier

WAN Wide Area Network

Other abbreviations used are as follows:

v Version and Release are abbreviated as V and R, respectively.

v A small x is used to mean ″the specifed version and all later versions of the
operating system″, as in OS/2 2.x. It is also used to stand for a family of products, as
in IBM 786x Modems and IBM 37xx Communication Controllers.

For other abbreviations, see the “Glossary” on page 279.
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Glossary

This glossary defines terms and abbreviations used in this manual. It includes terms
and definitions from the IBM Dictionary of Computing (New York; McGraw-Hill, Inc.,
1994).

v The symbol (A) identifies definitions from the American National Standard Dictionary
for Information Systems, ANSI X3.172-1990, copyright 1990 by the American
National Standards Institute (ANSI). Copies can be purchased from the American
National Standards Institute, 1430 Broadway, New York, New York 10018.

v The symbol (E) identifies definitions from the ANSI/EIA Standard - 440A: Fiber Optic
Terminology, copyright 1989 by the Electronics Industries Association (EIA). Copies
can be purchased from the Electronic Industries Association, 2001 Pennsylvania
Avenue N.W., Washington, DC 20006.

v The symbol (I) identifies definitions from the Information Technology Vocabulary,
developed by Subcommittee 1, Joint Technical Committee 1, of the International
Organization for Standardization and the International Electrotechnical Commission
(ISO/IEC JTC1/SC1).

v The symbol (T) identifies definitions from draft international standards, committee
drafts, and working papers being developed by ISO/IEC JTC1/SC1.

The following cross-references are used in this glossary:

Contrast with. This refers to a term that has an opposed or substantively different
meaning.

See. This refers the reader to multiple-word terms in which this term appears.

See also. This refers the reader to terms that have a related, but not synonymous,
meaning.

Synonym for. This indicates that the term has the same meaning as a preferred
term, which is defined in the glossary.

If you do not find the term you are looking for, refer to the index or to the IBM
Dictionary of Computing.

AAL. ATM Adaptation Layer.

active. (1) Able to communicate on the network. A token-ring network is active if it is able to transmit
and receive on the network. (2) Operational. (3) Pertaining to a node or device that is connected or is
available for connection to another node or device. (4) Currently transmitting or receiving.

adapter. In a LAN, within a communicating device, a circuit card that, with its associated software and/or
microcode, enables the device to communicate over the network.

address. (1) In data communication, the IEEE-assigned unique code or the unique locally administered
code assigned to each device or workstation connected to a network. (2) To refer to a device or an item
of data by its address (A).

Advanced Interactive Executive (AIX). An IBM-developed family of operating systems based on
UNIX**. AIX is the operating system on which Nways Manager-ATM runs.
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AFI. Authority and Format Identifier.

agent. In the TCP/IP environment, a process running on a network node that responds to requests and
sends information.

AIX. Advanced Interactive Executive.

AIX Operating System. (1) IBM’s implementation of the UNIX Operating System. The AIX Operating
System runs on the RISC System/6000 system.

alert. (1) For IBM LAN management products, a notification indicating a possible security violation, a
persistent error condition, or an interruption or potential interruption in the flow of data around the
network. (2) In SNA, a record sent to a system problem management focal point to communicate the
existence of an alert condition. (3) In the NetView for AIX or HP OpenView Windows program, a
high-priority event that warrants immediate attention. This database record is generated for certain event
types that are defined by user-constructed filters.

American National Standard Code for Information Interchange (ASCII). The standard code, using a
coded character set consisting of 7-bit coded characters (8 bits including parity check), used for
information interchange among data processing systems, data communication systems, and associated
equipment. The ASCII set consists of control characters and graphics characters. (A)

application program. (1) A program written for or by a user that applies to the user’s work. Some
application programs receive support and services from a special kind of application program called a
network application program. (2) A program used to connect and communicate with stations in a network,
enabling users to perform application-oriented activities.

application registration file. A file created by a programmer to integrate an application into the
NetView for AIX program by defining its place in the program’s menu structure, where help information is
found, the number and types of parameters allowed, the command line used to start the application, and
other characteristics of a user-written application.

ASCII. American National Standard Code for Information Interchange.

asynchronous. (1) Pertaining to two or more processes that do not depend upon the occurrence of a
specific event such as a timing signal. (T) (2) A class of data transmission service whereby all requests
for service contend for a pool of dynamically allocated ring bandwidth and response time (MAC) (3) In
fiber distributed data interface (FDDI) rings, a type of data traffic that does not need bounded access
delay to the medium and guaranteed throughput.

ATM. Asynchronous transfer mode.

ATM campus network. A union of privately-owned ATM subnetworks interconnected by network node
interfaces (NNIs). See also network node interface (NNI).

ATM Cluster. A set of ATM subsystems interconnected by ATM interfaces (SSI).

ATM user device. An end system that encapsulates data into ATM cells and forwards them to the ATM
subsystem in the 8260 Nways Multiprotocol Switching Hub across an UNI interface.

ATM subnetwork. A set of ATM clusters interconnected by ATM interfaces.
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ATM subsystem. The ATM components in the 8260 Nways Multiprotocol Switching Hub including, 8260
ATM Control Point and Switch and 8260 ATM Media modules and ATM interfaces (UNI, SSI, NNI).

attach. To make a device a part of a network logically.

Note: Not to be confused with connect, which implies physically connecting a device to a network.

Authority and Format Identifier. One octet in an ATM address.

backbone. A set of nodes and their interconnecting links providing the primary data path across a
network. In a local area network multiple-bridge ring configuration, a high-speed link to which the rings
are connected by means of bridges or routers. A backbone may be configured as a bus or as a ring. In a
wide area network, a high-speed link to which nodes or data switching exchanges (DSEs) are connected.

bandwidth. The difference, expressed in hertz, between the highest and the lowest frequencies of a
range of frequencies. For example, analog transmission by recognizable voice telephone requires a
bandwidth of about 3000 hertz (3 kHz). The bandwidth of an optical link designates the
information-carrying capacity of the link and is related to the maximum bit rate that a fiber link can
support.

BCM. BroadCast Manager

BER. Bit error rate.

bit error rate (BER). The ratio of the number of bits experiencing error on a telecommunications link
divided by the number of bits sent over the link.

bridge. (1) An attaching device that connects two LAN segments to allow the transfer of information
from one LAN segment to the other. A bridge may attach the LAN segments directly by network adapters
and software in a single device, or may connect network adapters in two separate devices through
software and use of a telecommunications link between the two adapters. (2) A functional unit that
connects two LANs that use the same logical link control (LLC) procedures but may use the same or
different medium access control (MAC) procedures. (T) Contrast with gateway and router.

broadband. A frequency band divisible into several narrower bands so that different kinds of
transmissions such as voice, video, and data transmission can occur at the same time. Synonymous with
wideband.

broadcast. (1) Transmission of the same data to all destinations. (T) (2) Simultaneous transmissions of
the same data to more than one destination. (3) A packet delivery system where a copy of a given packet
is given to all hosts attached to the network. Broadcast can be implemented in hardware (Ethernet for
example) or software. Contrast with multicast.

broadcast and unknown server (BUS). A LAN emulation service component responsible for the
delivery of multicast and unknown unicast frames.

broadcast frame. A frame that is simultaneously transmitted to more than one destination. A broadcast
frame is forwarded by all bridges, unless otherwise restricted.

Broadcast Manager.. An IBM extension to LAN Emulation designed to limit the effects of broadcast
frames.
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bus. (1) In a processor, a physical facility on which data is transferred to all destinations, but from which
only addressed destinations may read in accordance with appropriate conventions. (I) (2) A network
configuration in which nodes are interconnected through a bidirectional transmission medium. (3) One or
more conductors used for transmitting signals or power. (A)

BUS. Broadcast and Unknown Server

BUS monitor. BUS Monitor is a function of the MSS server. that provides a mechanism to pinpoint
end-users who could be overutilizing the BUS. It can improve network performance by identifying the
causes of a possible bottleneck at the BUS.

button. A word or picture on the screen that can be selected. Once selected and activated, a button
begins an action in the same manner that pressing a key on the keyboard can begin an action.

byte. A string that consists of a number of bits, treated as a unit, and representing a character. (T) A
binary character operated upon as a unit and usually shorter than a computer word. (A) A string that
consists of a particular number of bits, usually 8, that is treated as a unit, and that represents a character.
A group of 8 adjacent binary digits that represent one extended binary-coded decimal interchange code
(EBCDIC) character. See n-bit byte.

cable segment. A section of cable between components or devices on a network. A segment can
consist of a single patch cable, multiple path cables connected together, or a combination of building
cable and path cables connected together. See LAN segment, ring segment.

call. A physical or logical association between two or more parties. A held telephone call has two or
more parties logically connected, although they are physically disconnected.

client. A functional unit that receives shared services from a server.

click. To press and release a mouse button.

client. A functional unit that receives shared services from a server.

CNM. Communication network management.

component. (1) Any part of a network other than an attaching device, such as an IBM 8228 Multistation
Access Unit. (2) Hardware or software that is part of a functional unit.

concentrator. (1) An FDDI node that provides additional attachment points for stations that are not part
of the dual-ring. (2) An FDDI node that has additional ports beyond those required for its own attachment
to an FDDI network. These additional ports are for attaching other FDDI nodes (including other
concentrators) in a tree topology. (SMT) (3) A node on the FDDI ring, which in turn provides connections
for additional conforming FDDI stations so that they may communicate with other attachments to the
FDDI ring. A concentrator has physical layer entities that may or may not have one or more data link
layer entities.

configuration. (1) The arrangement of a computer system or network as defined by the nature, number,
and chief characteristics of its functional units. More specifically, the term may refer to a hardware
configuration or a software configuration. (I) (A) (2) The devices and programs that make up a system,
subsystem, or network. (3) See also system configuration.

connect. In a LAN, to physically join a cable from a station to an access unit or network connection
point. Contrast with attach.
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context menu. A menu (also known as a pop-up menu) that provides no visual clue to its presence, but
pops-up when operators perform a menu selection with mouse button 3 of a three-button mouse.

controller. A unit that controls input/output operations for one or more devices.

CRC. Cyclic redundancy check.

daemon. (1) A background process usually started at system initialization that runs continuously and
performs a function required by other processes. (2) In the AIX Operating System, a program that runs
unattended to perform a standard service. Some daemons are triggered automatically to perform their
task; others operate periodically.

data. (1) A representation of facts, concepts, or instructions in a formalized manner suitable for
communication, interpretation, or processing by human or automatic means. (I) (A) (2) Any
representations such as characters or analog quantities to which meaning is or might be assigned. (A)

data communication. (1) Transfer of information between functional units by means of data
transmission according to a protocol. (T) (2) The transmission, reception, and validation of data. (A)

default. Pertaining to an attribute, value, or option that is assumed when none is explicitly specified.

destination. Any point or location, such as a node, station, or particular terminal, to which information is
to be sent.

destination address. A field in the medium access control (MAC) frame that identifies the physical
location to which information is to be sent. Contrast with source address.

device. (1) A mechanical, electrical, or electronic contrivance with a specific purpose. (2) An input/output
unit such as a terminal, display, or printer. See also attaching device.

dialog box. (1) A dialog box provides data fields and buttons for setting controls, selecting from lists,
choosing from mutually exclusive options, entering data, and presenting the user with messages. The
NetView for AIX dialog boxes are defined by Motif. (2) A pop-up window that is used primarily to gather
user input.

discovery. The automatic detection of network topology changes (for example, new and deleted nodes,
new and deleted interfaces).

DMM. Distributed Management Module.

ELAN. Emulated local area network.

emulated local area network (ELAN). A LAN segment implemented with ATM technology.

entity. (1) An active functional agent within an Open System Interconnection (OSI) layer or sublayer,
including both operational and management functions. (2) An active service or management element
within an Open Systems Interconnection (OSI) layer or sublayer. (3) An active element within an Open
System Interconnection (OSI) layer, or sublayer, or SMT, in a specific station.

equipment rack. A metal stand for mounting network components, such as distribution panels and IBM
8228 Multistation Access Units. Synonymous with rack.
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Ethernet network. A baseband LAN with a bus topology in which messages are broadcast on a coaxial
cable using a carrier sense multiple access/collision detection (CSMA/CD) transmission method.

event. (1) An occurrence of significance to a task, such as an SNMP trap or a NetView for AIX or HP
OpenView Windows internal event. (2) In the NetView for AIX or HP OpenView Windows program, an
unsolicited notification from the managed object or SNMP agent that at least one of the following has
occurred:

v A threshold limit was exceeded.

v The network topology changed.

v An informational message or error occurred.

v An object’s status changed.

v A node’s configuration changed.

explodable symbol. (1) A symbol defined such that double-clicking on it displays the child submap of
the parent object that the symbol represents. The child submap displays the contents of the parent object.
If the object the symbol represents has no child submap, a New Submap dialog box appears enabling
you to create and configure a child submap. After the submap is created, double-clicking on the symbol
opens the child submap.

fault. An accidental condition that causes a functional unit to fail to perform its required function. (I) (A)

FDDI. Fiber distributed data interface.

fiber. (1) Dielectric material that guides light; waveguide.

fiber distributed data interface (FDDI). A high performance, general-purpose, multi-station network
designed for efficient operation with a peak data transfer rate of 100 Mbps. It uses token-ring architecture
with optical fiber as the transmission medium over distances of several kilometers.

fiber optic cable. (1) A jacketed fiber(s). (2) A cable containing one or more optical fibers.

fiber optics. The technology whereby optical signals from light-generating transmitters are propagated
through optical fiber waveguides to light-detecting receivers.

field. On a data medium or a storage medium, a specified area used for a particular category of data;
for example, a group of character positions used to enter or display wage rates on a panel. (T)

file. A named set of records stored or processed as a unit. (T)

filter. (1) In the AIX Operating System, a command that reads standard input data, modifies the data,
and sends it to the display screen. (2) A device or program that separates data, signals, or material in
accordance with specified criteria. (3) In the NetView for AIX program, a set of criteria that determines
which events are received by registered applications, selected for displaying, or forwarded to the NetView
and NETCENTER programs as alerts. (4) In the NetView program, a function that limits the data that is to
be recorded on the database and displayed at the terminal.

frame. (1) A unit of transmission in some LANs, including the IBM Token-Ring Network and the IBM PC
Network. It includes delimiters, control characters, information, and checking characters. On a token-ring
network, a frame is created from a token when the token has data appended to it. On a token bus
network (IBM PC Network), all frames including the token frame contain a preamble, start delimiter,
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control address, optional data and checking characters, end delimiter, and are followed by a minimum
silence period. (2) A protocol data unit transmitted between cooperating MAC entities on a ring, consisting
of a variable number of octets.

FMM. FDDI management module.

gateway. A device and its associated software that interconnect networks or systems of different
architectures. The connection is usually made above the reference model network layer. For example, a
gateway allows LANs access to System/370 host computers. Contrast with bridge and router.

gtmd daemon. A background process that received generic topology information for the multiprotocol
topology functions of the NetView for AIX program.

hardware. Physical equipment as opposed to programs, procedures, rules, and associated
documentation. (I) (A)

help menu. An action bar menu that provides detailed help information about the NetView for AIX or HP
OpenView Windows graphical interface. It also provides information about registered applications that are
integrated with the graphical interface.

highlighting. (1) In the NetView for AIX or HP OpenView Windows program, a visual clue showing the
nodes or connections that are the output of certain operations. (2) Emphasizing a display element or
segment by modifying its visual attributes.

icon. A graphic symbol, displayed on a screen, that a user can point to with a device, such as a mouse,
in order to select a particular function or software application.

ICMP. Internet Control Message Protocol.

IEEE. Institute of Electrical and Electronic Engineers (USA).

interface. (1) A shared boundary between two functional units, defined by functional characteristics,
common physical interconnection characteristics, signal characteristics, and other characteristics as
appropriate. (I) (2) A shared boundary. An interface may be a hardware component to link two devices or
a portion of storage or registers accessed by two or more computer programs. (A) (3) In Nways
Manager-ATM, an entity allowing data transfer between the network and an ATM Node. It usually consists
of hardware, microcode, and an associated protocol stack.

IP. Internetwork protocol (OSI)

ISO. International Organization for Standardization.

kbps. kilo bits per second.

LAN. Local area network.

LAN emulation (LE, LANE). The MSS server implements the LAN Emulation Over ATM: Version 1.0
Specification, which is widely accepted as the industry standard for multivendor multiprotocol
interoperability. LAN emulation protocols allow ATM networks to provide the appearance of local area
networks like Ethernet and token-ring.

layer. (1) One of the seven levels of the Open System Interconnection (OSI) reference model. (2) In
open systems architecture, a collection of related functions that comprise one level of hierarchy of

Glossary 285



functions. Each layer specifies its own functions and assumes that lower level functions are provided. (3)
In SNA, a grouping of related functions that are logically separate from the functions of other layers.
Implementation of the functions in one layer can be changed without affecting functions in other layers.

LAN emulation client (LEC). A LAN emulation component that represents users of the emulated LAN.

LAN emulation configuration server (LECS). A LAN emulation service component that centralizes and
disseminates configuration data.

LAN emulation server (LES). A LAN emulation service component that resolves LAN destinations to
ATM addresses.

LAN emulation server (LES). A LAN emulation service component that resolves LAN destinations to
ATM addresses.

LAN multicast. Sending of a transmission frame that is intended to be accepted by a group of selected
data stations on the same local area network. (T)

LAN segment. (1) Any portion of a LAN (for example, a single bus or ring) that can operate
independently but is connected to other parts of the establishment network via bridges. (2) An entire ring
or bus network without bridges. See Cable segment, ring segment.

LE. LAN emulation

local area network (LAN). A computer network located on a user’s premises within a limited
geographical area.

Note: Communication within a local area network is not subject to external regulations; however,
communication across the LAN boundary may be subject to some form of regulation. (T)

LEC. LAN emulation client.

LECS. LAN emulation configuration server.

LES. LAN emulation server.

local registration file (LRF). A file that provides information about an agent or daemon, such as the
name, the location of the executable code, and details about the objects that an agent manages.

MAC. Media access control

map. A set of related submaps that provides a graphical and hierarchical presentation of a network and
its systems.

Mb. Megabit; 1 048 576 bits.

MB. Megabyte; 1 048 576 bytes.

menu. A list of options displayed to the user by a data processing system, from which the user can
select an action to be initiated.

menu bar. A rectangular area at the top of the client area of a window that contains the titles of the
standard pull-down menus for that application.
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menu item. One of a list of options contained in a menu.

media access control (MAC). The portion of the data link layer responsible for scheduling and routing
data transmissions on a local area network (for example, an FDDI ring).

medium. A physical carrier of electrical or optical energy.

megabyte. A unit of measure for data. 1 megabyte = 1 048 576 bytes.

MIB. (1) MIB module. (2) Management information base.

MIB module. In the Simple Network Management Protocol (SNMP), a collection of objects relating to a
common management area. See also management information base (MIB) and MIB object.

MIB object. A data object contained in the MIB. Synonymous with MIB variable.

MIB variable. A data object contained in the MIB. It refers to a specific instance of a specific data object
in a MIB module. Synonym for MIB object.

netmon daemon. A background process that discovers and monitors nodes on the network.

network. (1) A configuration of data processing devices and software connected for information
interchange. (2) An arrangement of nodes and connecting branches. Connections are made between
data stations.

network administrator. A person who manages the use and maintenance of a network.

network application program. A program used to connect and communicate with adapters on a
network, enabling users to perform application-oriented activities and to run other application programs.

network architecture. The logical structure and operating principles of a computer network. (T) See
also systems network architecture (SNA) and Open Systems Interconnection (OSI) architecture.

network manager. A program or group of programs that is used to monitor, manage, and diagnose the
problems of the network.

network node interface (NNI). The interface between two network nodes.

NNI. Network node interface.

node. In a topological description of a network a node is a point of junction in the links. The word has
come to mean a switching center in the context of data networks, particularly in the context of packet
switching.

object. (1) In the NetView for AIX or HP OpenView Windows program, a generic term for any entity that
NetView for AIX or HP OpenView Windows discovers and displays on the topological map, or any entity
that you add to the topology map.

on-line information. Information stored in a computer that can be displayed, used, and modified in an
interactive manner without any need to obtain hardcopy.

operating system. Software that controls the execution of programs. An operating system may provide
services such as resource allocation, scheduling, input/output control, and data management. (A)
Examples are IBM PC DOS and IBM OS/2.
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optical fiber. A small-diameter strand made from glass and/or polymer that consists of a core
surrounded by a lower-index-of-refraction cladding. It guides light from one end to another by a
combination of a graded index in the core and internal reflectance.

optical fiber cable. One or more optical fibers aligned with each other, with strengthening material and
a protective cover.

option. (1) A specification in a statement, a selection from a menu, or a setting of a switch, that may be
used to influence the execution of a program. (2) A hardware or software function that may be selected or
enabled as part of a configuration process. (3) A piece of hardware (such as a network adapter) that can
be installed in a device to modify or enhance device function.

OSF. Open System Foundation.

OSI. Open System Interconnection.

ovspmd daemon. A background process that coordinates the start and stop of the other NetView for
AIX or HP OpenView Windows daemons.

ovtopmd. A process that puts Internet Protocol (IP) topology information in the NetView for AIX or HP
OpenView Windows program’s database.

packet internet groper (PING). In Internet communications, a program used in TCP/IP networks to test
the ability to reach destinations by sending the destinations an Internet Control Message Protocol (ICMP)
echo request and waiting for a reply. In communications, a test of reachability.

parameter. (1) A variable that is given a constant value for a specified application and that may denote
the application. (I) (A) (2) An item in a menu or for which the user specifies a value or for which the
system provides a value when the menu is interpreted. (3) Data passed between programs or
procedures.

Parent Peer Group. The parent peer group of a peer group is the one containing the logical group node
representing that peer group. The parent peer group of a node is the one containing the parent node of
that node.

path. (1) In a network, any route between any two nodes. (T) (2) The route traversed by the information
exchanged between two attaching devices in a network.

PC. Personal computer

PC network. An IBM broadband or baseband LAN with a bus topology in which messages are
broadcast from PC network adapter to PC network adapter.

Peer entities. Entities within the same layer.

Peer group. A set of logical nodes which are grouped for purposes of creating a routing hierarchy.
PTSEs are exchanged among all members of the group.

Peer group identifier. A string of bits that is used to unambiguously identify a peer group.

Peer group leader. A node which has been elected to perform some of the functions associated with a
logical group node.
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Peer group level. The number of significant bits in the peer group identifier of a particular peer group.

Peer node. A node that is a member of the same peer group as a given node.

permanent virtual channel connection (PVCC). A virtual channel connection (VCC) is an ATM
connection where switching is performed on the VPI/VCI fields of each cell. A permanent VCC is one
which is provisioned through some network management function and left up indefinitely.

permanent virtual circuit (PVC). In X.25 and frame-relay communications, a virtual circuit that has a
logical channel permanently assigned to it at each data terminal equipment (DTE). Call-establishment
protocols are not required. Contrast with switched virtual circuit (SVC). The logical connection between
two frame-relay terminating equipment stations, either directly or through one or more frame-relay frame
handlers. A PVC consists of one or more PVC segments.

permanent virtual path connection (PVPC). A virtual path connection (VPC) is an ATM connection
where switching is performed on the VPI field only of each ce. A permanent VPC is one which is
provisioned through some network management function and left up indefinitely.

physical link. The simplex path (through PMD and attached medium) from the transmit function of one
PHY entity to the receive function of an adjacent PHY entity (in concentrators, repeaters, or stations) in
an FDDI ring.

Ping. Packet Internet Groper.

polling. (1) On a multipoint connection or a point-to-point connection, the process whereby data stations
are invited, one at a time, to transmit. (2) Interrogation of devices for such purposes as to avoid
contention, to determine operational status, or to determine readiness to send or receive data.

PNNI. Private Network-Network Interface: A routing information protocol that enables extremely scalable,
full function, dynamic multi-vendor ATM switches to be integrated in the same network.

PNNI protocol entity. The body of software in a switching system that executes the PNNI protocol and
provides the routing service.

PNNI routing control channel. VCCs used for the exchange of PNNI routing protocol messages.

PNNI routing domain. A group of topologically contiguous systems which are running one instance of
PNNI routing.

PNNI routing hierarchy. The hierarchy of peer groups used for PNNI routing.

PNNI topology state element (PTSE). A collection of PNNI information that is flooded among all logical
nodes within a peer group.

PNNI topology state packet. A type of PNNI Routing packet that is used for flooding PTSEs among
logical nodes within a peer group.

point-to-multipoint connection. A Point-to-Multipoint Connection is a collection of associated ATM VC
or VP links, with associated endpoint nodes, with the following properties.

1. One ATM link, called the Root Link, serves as the root in a simple simple tree topology. When the
Root Node sends information, all of the remaining nodes on the connection, called Leaf Nodes,
receive copies of the information.
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2. Each of the Leaf Nodes on the connection can send information directly to the Root Node. The Root
Node cannot distinguish which Leaf is sending information without additional information.

Note: UNI 4.0 does not support traffic sent from a Leaf to the Root.

3. The Leaf Nodes cannot communicate directly to each other with this connection type.

point-to-point connection. A connection with only two endpoints.

port. (1) An access point for data entry or exit. (2) A connector on a device to which cables for other
devices such as display stations and printers are attached. Synonymous with socket. (3) A PHY entity
and a PMD entity in a node, together creating a PHY/PMD pair, that may connect to the fiber media and
provide one end of a physical connection with another node.

port identifier. The identifier assigned by a logical node to represent the point of attachment of a link to
that node.

protocol. (1) A set of semantic and syntactic rules that determines the behavior of functional units in
achieving communication. (I) (2) In SNA, the meanings of and the sequencing rules for requests and
responses used for managing the network, transferring data, and synchronizing the states of network
components. (3) A specification for the format and relative timing of information exchanged between
communicating parties.

PS/2. Personal System/2.

pull-down menu. In the AIXwindows program, a type of MenuPane widget that gives the appearance of
being pulled down from a MenuBar widget as the result of a user action, usually, clicking a mouse button.

PVC. Permanent virtual circuit.

PVCC. Permanent virtual channel connection.

PVPC. Permanent virtual path connection.

QOS. Quality of service

quality of service (QOS). A set of communication characteristics required by an application. Each QOS
defines a specific transmission priority, level of route reliability, and security level. Each QOS also defines
whether the sessions are interactive.

rack. Synonym for equipment rack.

receive. The action of a station in accepting a frame, token, or control sequence from the medium
(PHY).

reachability. The ability of a node or a resource to communicate with another node or resource.

registration file. See application registration file

repeater. (1) In a network, a device that amplifies or regenerates data signals in order to extend the
distance between attaching devices. (2) A physical layer relay in an FDDI network.

resource. Any facility of the computing system required by a job or task, and including main storage,
input/output devices, the processing unit, data sets, and control of processing programs.
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ring. A network configuration in which devices are connected by unidirectional transmission links to form
a closed path.

ring segment. A ring segment is any section of a ring that can be isolated (by unplugging connectors)
from the rest of the ring. A segment can consist of a single lobe, the cable between access units, or a
combination of cables lobes, and/or access units. See cable segment, LAN segment.

RISC. Reduced instruction set computer.

root-level submap. Contains the highest level of the submap hierarchy. Multiple networks can be
placed within the root-level submap.

root user. See superuser authority.

router. An attaching device that connects two LAN segments, which use similar or different
architectures, at the reference model network layer. Contrast with bridge and gateway.

routine. Part of a program, or a sequence of instructions called by a program, that may have some
general or frequent use.

routing. (1) The assignment of the path by which a message will reach its destination. (2) The
forwarding of a message unit along a particular path through a network, as determined by the parameters
carried in the message unit, such as the destination network address in a transmission header.

segment. (1) A group of display elements. (2) A contiguous area of virtual storage allocated to a job or
system task. A program segment can be run by itself, even if the whole program is not in main storage.
(3) A portion of a computer program that may be executed without the entire program being resident in
main storage. (4) In AIX Enhanced X Windows, one or more lines that are drawn but not necessarily
connected at the end points. (5) In the IBM Token-Ring network, a section of cable between components
or devices on the network. A segment may consist of a single patch cable, multiple patch cables
connected together, or a combination of building cable and patch cables connected together.

segment-level submap. Represents the topology of a segment of a network. A segment submap
contains network nodes and connectors.

select. (1) In the AIX Operating System, to choose a button on the display screen. (2) To place the
cursor on an object (name or command) and press a button on the mouse or the appropriate key on the
keyboard.

server. (1) A device, program, or code module on a network dedicated to providing a specific service to
a network. (2) On a LAN, a data station that provides facilities to other data stations. Examples are a file
server, print server, and mail server.

Simple Network Management Protocol (SNMP). In the Internet suite of protocols, a network
management protocol that is used to monitor routers and attached networks. SNMP is an application
layer protocol. Information on devices managed is defined and stored in the application’s Management
Information Base (MIB).

SMIT. System management information tool.

SNA. Systems Network Architecture.

SNMP. Simple network management protocol.
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socket. Synonym for port. (2)

SSI. Switch-to-switch interface.

startup file. A file that contains information about the ordered sequence of network management
processes, such as daemons and agents. The startup sequence is listed in the /usr/OV/conf/ovsuf file.

station. (1) A communication device attached to a network. The term most often used in LANs is an
attaching device or workstation. (2) An input or output point of a system that uses telecommunication
facilities. (3) An addressable node on an FDDI network capable of transmitting, repeating and receiving
information. A station has exactly one SMT, at least one MAC, at least one PHY, and at least one PMD.

station. An input or output point of a system that uses telecommunications faces; for example, one or
more systems, computers, terminals, devices, and associated programs at a particular location that can
send or receive data over a telecommunication line.

status. The current condition or state of a program or device. (2) In the NetView for AIX or HP
OpenView Windows program, the condition of a node or portion of the network as represented by the
color of a symbol on a submap.

submap. (1) A particular view of some aspect of a network that displays symbols to represent objects.
Some symbols may explode into other submaps, usually having a more detailed view than their parent
submap. The application that creates a submap determines what part of the network the submap
displays.

superuser authority. (1) In the AIX Operating System, the unrestricted authority to access and modify
any part of the operating system, usually associated with the user who manages the system. (2) See root
user.

SVC. Switched virtual circuit.

switched virtual circuit (SVC). An X.25 circuit that is dynamically established when needed. The X.25
equivalent of a switched line. A virtual circuit that is requested by a virtual call. It is released when the
virtual circuit is cleared. Contrast with permanent virtual circuit (PVC).

switch-to-switch interface (SSI). The interface between 8260 ATM Control Point and Switch modules
in 8260 Nways Multiprotocol Switching Hubs.

symbol. (1) In the NetView for AIX or HP OpenView Windows program, a picture or icon that represents
an object. Each symbol has an outside and inside component.

v The outside component differentiates the object classes.

v The inside component differentiates the objects within the class.

synchronous. (1) Pertaining to two or more processes that depend on the occurrences of a specific
event such as a common timing signal. (I) (A) (2) Occurring with a regular or predictable timing
relationship. (3) A class of data transmission service whereby each requester is preallocated a maximum
bandwidth and guaranteed a response time not to exceed a specific delay.

system configuration. A process that specifies the devices and programs that form a particular data
processing system.
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System Management Interface Tool (SMIT). An interface tool that is provided with the AIX Operating
System for installing, maintaining, and diagnosing tasks.

System Network Architecture (SNA). The description of the logical structure, formats, protocols, and
operational sequences for transmitting information units through, and controlling the configuration and
operation of, networks.

Note: The layered structure of SNA allows the ultimate origins and destinations of information, that is, the
end users, to be independent of and unaffected by the specific SNA network services and facilities
used for information exchange.

task. In a multiprogramming or multiprotocol environment, one or more sequences of instructions treated
by a control program as an element of work to be accomplished by a computer.

TCP/IP. Transmission Control Protocol/Internet Protocol

TELNET. Telecommunication Network protocol.

TFTP. Trivial file transfer protocol.

token-ring. A network with a ring topology that passes tokens from one attaching device (node) to
another. A node that is ready to send can capture a token and insert data for transmission.

token-ring network. A bus network in which a token-passing procedure is used. (T)

topology. The physical or logical arrangement of nodes in a computer network. Examples include ring
topology and bus topology.

tralert daemon. A background process that receives SNMP traps, converts the traps to NMVT alerts,
and sends the alerts to the host system that is running the NetView for AIX or HP OpenView Windows
and NETCENTER programs.

transmit. (1) The action of a station in generating a token, frame, or other symbol sequence and placing
it on the outgoing medium. (2) The action of a station that consists of generating a frame, token, or
control sequence, and placing it on the medium to the next station.

trap. An unsolicited event generated by an agent and forwarded to a manager. Traps inform the
manager of changes that occur in the network.

trapd daemon. A background process that receives events and traps, logs them to a specific log file,
and upon request can forward the events to other daemons or processes.

tree. A physical topology consisting of a hierarchy of master-slave connections between a concentrator
and other FDDI nodes (including subordinate concentrators).

Trivial File Transfer Protocol (TFTP). In the Internet suite of protocols, a protocol for file transfer that
requires minimal overhead and minimal capability. TFTP uses the connectionless datagram delivery
services of the User Datagram Protocol (UPD), which allows hosts that have no disk srorage to
implement TFTP in read-only memory (ROM) and use it to boot themselves.

TRMM. Token-ring management module.
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trunk. A physical topology, either open or closed, employing two optical fiber signal paths, one in each
direction (i.e., counter-rotating), forming a sequence of peer connections between FDDI nodes. When the
trunk forms a closed loop it is sometimes called a trunk ring.

UNI. User-network interface.

universally administered address. The address permanently encoded in an adapter at the time of
manufacture. All universally administered addresses are unique.

UNIX Operating System. An operating system developed by Bell Laboratories that features
multiprogramming in a multiuser environment. The UNIX Operating System was originally developed for
use on minicomputers but has been adapted for main frames and microcomputers.

Note: The AIX operating System is IBM’s implementation of the UNIX Operating System. See AIX.

unknown status. (1) The status of an object that is not yet known or does not actually exist in the
network. The default icon color for unknown status is Blue. The default connection symbol color is Black.

unmanaged object. (1) An object that is not actively managed. An unmanaged object displays status as
Unmanaged. It does not display active status (normal, marginal, critical). Unmanaged objects do not
display compound status nor do they contribute to compound status. Objects can be kept in an
unmanaged state if they are not of interest. An object may be toggled between a managed and
unmanaged state.

user. Any person or anything that may issue commands and messages to or receive commands and
messages from the information processing system.

user-network interface (UNI). Physical and logical definition of the interface between an ATM user
device and the ATM network.

variable. (1) In computer programming, a character or group of characters that refers to a value and, in
the execution of a computer program, corresponds to an address. (2) A quantity that can assume any of a
given set of values. (A)

VCC. Virtual channel connection.

VCI. Virtual channel identifier (in ATM cell header).

view. See submap.

virtual local area network (VLAN). A logical grouping of one or more LANs based on protocol and
subnet and used to isolate network traffic within these groups.

VLAN. Virtual Local Area Network.

VPI. Virtual path identifier (in ATM cell header).

widget. (1) In the AIX Operating System, a graphic device that can receive input from the keyboard or
mouse and communicate with an application or another widget by means of a callback. Every widget is a
member of only one class and always has a window associated with it. (2) The fundamental data type of
the AIX Enhanced X-WindowsToolkit. (3) An object that provides a user-interface abstraction; for example,
a Scrollbar widget. It is the combination of an AIX Enhanced X-Windows window (or subwindow) and its
associated semantics. A widget implements procedures through its widget class structure.
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window. A portion of a visual display surface in which display images pertaining to a particular
application can be presented. Different applications can be displayed simultaneously in different windows.

wiring closet. A room that contains one or more distribution panels and equipment racks that are used
to interconnect cables. Sometimes called a network wiring closet to distinguish it from a telephone wiring
closet.

wiring concentrator. A unit that allows multiple attaching devices access to the ring at a central point
such as a wiring closet or in an open work area. A star-wired ring consists of one or more concentrators
connected together to form a ring.

workstation. (1) An I/O device that allows either transmission of data or the reception of data (or both)
from a host system, as needed to perform a job: for example, a display station or a printer. (2) A
configuration of I/O equipment at which an operator works. (T) (3) A terminal or microcomputer, usually
connected to a mainframe or network, at which a user can perform tasks.
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example 261
parameters 261

show status of coupling 221
signaling channel 87
SLIP configuration 84
SMIT administration 207
SNMP, inband 72
specifying statistics attributes 181
standalone Nways Manager-ATM 80
start and stop process 215

ATM Manager 40
the ATM Manager user interface 41
traces 167

station information in search database 154
statistics categories 184
statistics information, replaying 183
status

displaying for ahmtopod daemon 208
of objects 39
of traces and dumps, displaying 165

stop query pushbutton 68, 81
sublayer characteristics 68
submaps

ATM meta-connection 49
different 40
NetView for AIX Root 41
Peer Group 43

subnetworks 10
subsystem, ATM 9
subsystem, ATM in ATM Workgroup Switch 9
SVCs

deleting 91
displaying physical characteristics 90
listing 87
managing 87
tearing down 69
tracking 108

swapping code 162
switch-to-switch interface 10
system

reliability, increasing 33

T
taking program dumps 167
tearing down SVCs 69, 91
temporarily disabling lock status 72
terms, glossary of 279
TFTP, retrieving files 167
traces, how to use 165
trademarks 274
traffic characteristics 98
transferring files 168
traps, understanding 164
trouble shooting 201

U
UnadminElan command

description 262
example 262
parameters 262

UnassignElanFromLecs command
description 262
example 262
parameters 262

UnassignLecFromLes command
description 262
example 263
parameters 262

UnassignLesFromElan command
description 263
example 263
parameters 263

unattended endpoints 92
understanding traps 164
uniquely identifying

SVCs 87
unlocking and locking ATM switches 72
unmanaging

ATM Clusters and Peer Groups 43
ATM devices 45
the ATM campus 41

uploading files 171
user devices 9, 10
user devices ATM 9
user information in search database 153
user interface

starting 217
user-to-network interface 10
using

ATM Manager 39
ATM Manager from NetView for AIX 41
icons 40
SMIT for administration 207
standardNetView for AIX functions 41

using the search function 149

V
views

ATM Meta-Connection submap 49
ATM view 45
Device Submap 43
different levels 40
IP Map segment submap 50
network submap 42
PNNI Spanning Tree 48
PNNI Topology Validation panel 47

virtual links
listing 103
listing ATM virtual links for a non IBM device 106
listing configuration 105

306 Nways Manager-ATM User’s Guide



virtual links (continued)
listing traffic for a non IBM device 103
managing for IBM devices 102
managing for non IBM devices 105
tracking 111

virtual tracking 107

W
warranties 273

ways to display event information 163

X
X Window publications 298

Index 307



308 Nways Manager-ATM User’s Guide



Readers’ Comments — We’d Like to Hear from You

Nways Manager
ATM User’s Guide
2.0

Publication No. SH11-3068-02

Overall, how satisfied are you with the information in this book?

Very Satisfied Satisfied Neutral Dissatisfied Very Dissatisfied

Overall satisfaction h h h h h

How satisfied are you that the information in this book is:

Very Satisfied Satisfied Neutral Dissatisfied Very Dissatisfied

Accurate h h h h h

Complete h h h h h

Easy to find h h h h h

Easy to understand h h h h h

Well organized h h h h h

Applicable to your tasks h h h h h

Please tell us how we can improve this book:

Thank you for your responses. May we contact you? h Yes h No

When you send comments to IBM, you grant IBM a nonexclusive right to use or distribute your comments in any way it

believes appropriate without incurring any obligation to you.

Name Address

Company or Organization

Phone No.



Readers’ Comments — We’d Like to Hear from You
SH11-3068-02

SH11-3068-02

IBMR
Cut or Fold
Along Line

Cut or Fold
Along Line

Fold and Tape Please do not staple Fold and Tape

Fold and Tape Please do not staple Fold and Tape

NO POSTAGE
NECESSARY
IF MAILED IN THE
UNITED STATES

BUSINESS REPLY MAIL
FIRST-CLASS MAIL PERMIT NO. 40 ARMONK, NEW YORK

POSTAGE WILL BE PAID BY ADDRESSEE

Department CGFA
Design & Information Development
IBM Corporation
PO Box 12195
RESEARCH TRIANGLE PARK, NC 27709-9990

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_
_

_





IBMR

Program Number: 5697-C30

Printed in the United States of America
on recycled paper containing 10%
recovered post-consumer fiber.

Nways Management Web site:
http://www.networking.ibm.com/netmgt

SH11-3068-02


